Solved

In transition from Excahnge 2003 to Exchange 2010 I have difficulty to send any email to a user email account on 2010 server with this error:5.7.1 smtp;550 5.7.1 Unable to relay for auser@abcd.org

Posted on 2010-11-26
10
610 Views
Last Modified: 2012-08-13
I completed installing an Exchange 2010 server in an Exchange 2003 environment. I was using one Excahnge 2003 for the company emails. Let's assume my company domain is called abcd.org. After completion of the 2010 server, I moved one user (Let's assume his account is auser@abcd.org). This user can send emails to any internal and external recipients successfuly, but any emaik from inside or outside of the company will not get to his Inbox. Here is the error:
You do not have permission to send to this recipient. For assistance, contact your system administrator.
  <jklm2.abcd.org #5.7.1 smtp;550 5.7.1 Unable to relay for fauser@abcd.org>

JKLM2 is the name of the 2003 server. The 2010 server is named MNOP2.
Please help me to resolve this problem ASAP.
Thank you all in advance

Jay
0
Comment
Question by:Jay555
  • 5
  • 4
10 Comments
 
LVL 17

Expert Comment

by:Viral Rathod
ID: 34219177
I guess you have not yet allow relay on Receive connector on Exchange 2010

Please refer this article by Akhater

http://www.zerohoursleep.com/2010/02/allow-relaying-on-exchange-2007-exchange-2010-in-4-easy-steps/
0
 
LVL 17

Expert Comment

by:Viral Rathod
ID: 34219204
Basically we need to adjust the properties of the Default Receive Connector to allow anonymous access.

http://msexchangeteam.com/archive/2006/11/17/431555.aspx

Since enabling anonymous relaying on the default receive connector is a huge security issue ,i have suggest you to create separate receive connector

Here is an article wrote by Akhater that will guide you through it step by step
http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_2666-Allow-relaying-on-Exchange-2007-Exchange-2010-in-4-easy-steps.html 
0
 
LVL 15

Expert Comment

by:getzjd
ID: 34219560
Exchange 2010 should have prompted you to create the legacy connector to the 2003 server in the setup.  Did you specify the 2003 during setup?
0
 

Author Comment

by:Jay555
ID: 34219666
Answer to qetzid:

Yes, I did and I am able to send email from the one user account on the any internal and external recipients. Right now the mailbox database is on the 2003 server except the one I mentioned above.
0
 
LVL 17

Expert Comment

by:Viral Rathod
ID: 34219736
The error message you have posted above is what you usually get when you try and send an email with another address in the from field that is different to your primary account AND you don't have permissions to do that.

Can you just right click on the user and check the E-mail Address ?

Can you please cross check the Receive connector settings & Make sure the domain name is listed under "Accepted Domains"
http://www.petri.co.il/configure-exchange-2007-recieve-email-other-domains.htm
0
Is Your AD Toolbox Looking More Like a Toybox?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

 
LVL 17

Expert Comment

by:Viral Rathod
ID: 34219755
By default anonymous users do not have the rights to submit email for external domains so we need to grant them, and this has to be done through the Exchange Management Shell. Enter the following command:

Get-ReceiveConnector "connector name" | Add-ADPermission -User "NT AUTHORITY\ANONYMOUS LOGON" -ExtendedRights "ms-Exch-SMTP-Accept-Any-Recipient"

Make sure you enter the connector name as it appears in the Management Console and run the command, it should confirm the permission has been added. As before make sure you restart the Transport Service and then test your new connector, and don't forget the open relay test to be sure!

http://www.petri.co.il/configuring-exchange-2007-send-connectors.htm
0
 

Author Comment

by:Jay555
ID: 34220521
I do not find any place in Exch 2010 in Exchange Management Console to check the Recieve Connector.
0
 

Author Comment

by:Jay555
ID: 34220738
This link http://www.petri.co.il/configuring-exchange-2007-send-connectors.htm 
Is all about sending an email. I don't have any problem sending an email out successfuly. IMy problem is RECIEING the emails sent from other persons from inside and outside of the Exchane.
0
 

Accepted Solution

by:
Jay555 earned 0 total points
ID: 34244801
In fact I needed to change the Private IP in the spam controller appliance to point to the new Exchange 2010 server.
0
 

Author Closing Comment

by:Jay555
ID: 34276850
I followed the instructions the 2 specialist shared with me, with no success. I posted help requests 2 more times and waited several days. Nobody responded to my questions, at the same time I continued working to resolve my problem and found out if I direct the emails to the new server, then emails will move in both directions without Error.
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Lotus Notes – formerly IBM Notes – is an email client application, while IBM Domino (earlier Lotus Domino) is an email server. The client possesses a set of features that are even more advanced as compared to that of Outlook. Likewise, IBM Domino is…
Find out what you should include to make the best professional email signature for your organization.
how to add IIS SMTP to handle application/Scanner relays into office 365.
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…

863 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

26 Experts available now in Live!

Get 1:1 Help Now