Running out of Memory

This may be an impossible question to answer without seeing my system, but I am at a loss.  My PC is suddenly low on memory all the time.  I have 4 G of RAM and used to be able to open many applications; outlook, lots of IE browsers, Word, Excel all at the same time.  Now, within the last week, I have to close all my browser to open Outlook.  I am only able to open one or two apps at any time.

I have run tests on my RAM and they all pass, I have attached screen shots from my task manager.  

I'm interested in any help trouble shooting the problem, I know enough to be dangerous, but not sure how to track this down and resolve it.


Windows XP, Dell Vostro 420, 4 G RAM, about 30 G free on the disk
LVL 39
Who is Participating?
wmcdon7160Connect With a Mentor Commented:
In my opinion, if you can afford to permanently sacrifice the 6GB of hard drive space, then it is more efficient for the operating system to make a one-time virtual memory allocation.
what browsers are you running?  Check your add ons.  some of those add ons can really eat up memory.  

You will also want to check task manager to see what processes are using up a lot of your memory.  You will also probably want to go into MSCONFIG and disable any programs you dont need running at startup.  
QlemoBatchelor, Developer and EE Topic AdvisorCommented:
Something missing here ... (Hint: Screenshots).
But you won't need to attach screenshots yet. Just display "virtual size", and "peak memory size" (it might sound little different, can't have a look right now), and sort for the peak one to get the biggest consumer. Both IE and Firefox are known to consume a lot of memory when running some time.
Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

Dr. KlahnPrincipal Software EngineerCommented:
Get a copy of Microsoft Autoruns and see what is starting up automatically.  It is possible that something got into your system and set itself to autoload at startup.

And the screenshots will be very helpful.
Unless XP is 64bit, then it is only seeing 3GB of usable memory. Is it possible to remove 1GB of memory to see if that fixes it? In fact, even running on 2GB should be fine for what you are using. Honestly it doesn't sound like the RAM memory is the issue.

Also check Virtual Page File size. Use this article and make sure you set the "initial size" and the "max size" to both be 6144 in the "custom" area.

Most importantly... are you running Antivirus and Antimalware on this PC??

you can also have these vary symptoms when your hard drive is to full.
you might consider purchasing an external hard drive to store things on such as movies and music.
Gary CaseConnect With a Mentor RetiredCommented:
As noted above, you forgot to attach the screenshots you mentioned in your question :-)

First, there's no need to remove memory from the system -- the x32 version of XP is limited to a 4GB address space ... which means it can't "see" a full 4GB of memory due to the system level functions that must be assigned in the upper end of the address space, it will typically "see" somewhere in the 3.2GB to 3.5GB range.    In addition, if your system supports dual channel mode, removing one modules will cause it to run in a less efficient access mode (either a lower-bandwidth dual channel mode or in single channel mode, depending on the chipset).

The issue you're describing is more likely a virtual memory issue than a memory issue.     Have you recently changed your virtual memory settings?    A nearly full system disk can also cause this -- but you indicated there is 30GB free so that shouldn't be the issue.    It IS, however, possible that you simply have a badly fragmented page file.    Change your virtual memory settings to "system managed", and run a defrag on your system disk ... then see if you still have this issue.
gdemariaAuthor Commented:
oops, forgot to attach the screen shots of the task manager!
gdemariaAuthor Commented:
Thanks for all the posts, here are my answers to your questions!

> what browsers are you running?  Check your add ons.

IE 8, I had disabled down to minimal add-ons, I don't usually do fancy things as the computer is basically for work.  I have google and roboform, but I have had them forever and nothing has changed in that area.

> Unless XP is 64bit, then it is only seeing 3GB of usable memory

I was wondering why the Physical Memory was only showing 3 G.  Wonder how I could buy a computer with 4 G of RAM when they know only 3 will be used..

> are you running Antivirus and Antimalware on this PC??

Forgot to mention that, I am running both Norton and Spyware doctor and have done full scans with both.  

>  A nearly full system disk can also cause this -- but you indicated there is 30GB free so that shouldn't be the issue.

Actually, my hard disk was nearly full and then I cleaned a bunch of files off to my external drive to create the 30 G of space.   Is it possible the settings changed automatically giving me this problem?    Perhaps I need to change them back manually.

I will use info and links posted above to try and determine these settings...

gdemariaAuthor Commented:
> Also check Virtual Page File size. Use this article and make sure you set the "initial size" and the "max size" to both be 6144 in the "custom" area

I have done this

Is this better than system manager, which do you folks recommend?

Dr. KlahnPrincipal Software EngineerCommented:
Well, I personally would start by removing Norton and installing another antivirus.  I like AVG.  I've found both Norton and McAfee to be problematic, i.e., you install them, you automatically get problems.

Unless you're very fond of the Google taskbar, I'd remove that entirely.

There are other e-mail clients that are more efficient of space than Outlook, which is using nearly 100 MB.
Gary CaseRetiredCommented:
Pre-NT-based OS's  (Win95/98/ME) were poor at managing the page file, but XP and later do a much better job ... I'd set the virtual memory to "system managed" rather than specifying a fixed size.

When your disk was nearly full that's very likely what caused the slowdowns you experienced.    Now that you've freed up some space, it should get better -- but you'll likely need a reboot for XP to reassign the page file space.    Also, if it was set to a fixed size, and it wasn't available for allocation, it may not reset --- but if you change it to system managed you'll be fine.

As I noted above, I'd be sure your virtual memory is system managed;  and defrag the disk -- THEN see if you still have a problem  (I suspect you won't).
Gary CaseRetiredCommented:
...  by the way, I agree that Norton's Antivirus products tend to be resource hogs.    The exception is the new Norton 360, which is much less "bloated" then its predecessors of the past few years.    AVG has also become pretty bloated with their new 2011 product.    The best choice for most folks is the free Microsoft Security Essentials.

It's unlikely, however, that your AV product is causing the slowdowns you've noted ... as I said earlier, it's almost certainly a virtual memory issue.
I personally would go to Start Menu->Run->msconfig->Start Up Tab, and uncheck all the software you don't want eating up memory an run malwarebytes and anti-virus to remove any malware
This behavior can occur if the desktop heap in the WIN32 subsystem is depleted.  

To correct this problem, increase the size of the desktop heap:

   1. Run Registry Editor (Regedt32.exe).
   2. From the HKEY_LOCAL_MACHINE subtree, go to the following key: \System\CurrentControlSet\Control\Session Manager\SubSystems
   3. Select the Windows value.
   4. From the Edit menu, choose String.
   5. Increase the SharedSection parameter.

      For Windows NT:
      SharedSection specifies the system and desktop heaps using the following format:
      Add ",256" or ",512" after the yyyy number.

      For Windows 2000, Windows XP, and Windows Server 2003:
      SharedSection uses the following format to specify the system and desktop heaps:
      For 32-bit operating systems, increase the yyyy value to "12288";
      Increase the zzzz value to "1024".
      For 64-bit operating systems, increase the yyyy value to "20480";
      Increase the zzzz value to "1024".
Free RAM Optimizer XP
automatic memory cleaner

Also I recommend:
Removing Norton AV and installing an AVG product (as already stated) is a good idea.
AVG 9 is free, still available, & relatively light on computer resources.

Also recommend running Malwarebytes(already suggested by koquito) to check for Malware infections that Norton can so easily have missed, which could be causing the memory issue.

Try downloading & updating Malwarebytes anti-Malware, from here:
Run in normal mode.
Tutorial, if required:

You could follow that with a Hitman Pro scan, for a second opinion:
Hitman Pro

This article may be helpful>
"Products' ratings":
When "Running out of Memory" -
go to administrative tools - event manager.
get last 40 lines from system, application optionally IE logs and paste it here.
gdemariaAuthor Commented:
Ok, things seem a bit better having set the virtual memory to system managed, I could open a few more items.  I worked for several hours, then I ran out of memory again as I opened some more windows (MS Outlook and about 4 IE tabs).

Going back into see the setting is for virtual memory, the current size is 3070 MB.  So, I will now try manually setting it to 6144.

I looked at the event logs and there are no warnings in any of the different folders.  IE log is completely empty.

I am looking at the different software suggested.   But please keep in mind that I was running Nortonn and PC Doctor for some months without an issue, I understand that replacing them probably will help, but it doesn't seem they are the issue since it was fine with them for some time.

Thanks for your continued support!
QlemoBatchelor, Developer and EE Topic AdvisorCommented:
If you are on system-managed VM size, and it has max of 3GB, the system either does not need more, or is unable to reclaim more space for the pagefile. Making the file bigger might improve performance, but not the issue as-is (as long as the harddisk is fast enough to allow for some extra load when resizing the pagefile). Is you harddisk heavily used all the time?
Gary CaseRetiredCommented:
System-managed will automatically increase the page file as its needed PROVIDING your disk has sufficient free space for it.    Check the space on your C: drive ... and if you have another drive with a lot of free space allocate some of it for paging as well.
you dont want to run two antivirus programs at the same time. they trample over each other. Norton and McAfee are resource hogs and in my experience you could still get viruses same with AVG. I recommend kaspersky its much lighter on the system and it looks like you have more than one tool bars .. youre bound to run into issues when you have toolbars in your IE.. usually other stuff is installed along with them
to clarify...kaspersky antivirus...not internet security
gdemariaAuthor Commented:
Sorry for the slow resolution.  I had set the setting to system managed and it helped some.  I was able to open more windows, but not back to my usual.  I checked disk fragmentation, rebooted several times, ensured no viruses and let it go a day.  No further improvement.  I then set the value to 6144 and have been running perfectly fine for several days now.  I can't explain it, but that's just what has happened!   I can now open all the windows I used to...

Thanks to all for your advice and help!
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.