Microsoft Kit: Wireless Mouse 5000 with BlueTrack and Wireless Keyboard 3000 v2

I'm having this problem with a new kit of wireless mouse & keyboard from microsoft.  It was working just fine, but now only the keyboard work.  There's no ON/OFF button to turn off the mouse.  There's a little switch that is activated if you place the USB dongle under the mouse, but this switch is not pressed.

There's no led on this model so there's no way to say if the mouse is On or Off.  

I've changed the batteries of course: still not working.
I've unplugged the dongle, and plugged it back in the same port: still not working
I've unplugged the dongle and plugged it in another USB port... same problem.

The keyboard still work, but the mouse is dead.

There's no yellow icon showing a problem in the device manager.

This computer is running under Windows Vista.

Any idea?

P.S: I've just tested the kit on another computer, same problem... keyboard is working, mouse is dead.  So i guess it's only dead and i got to return it?
LVL 10
Christian de BellefeuilleProgrammerAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
Matt DaviesConnect With a Mentor Commented:
You have done the tests I would recommend and come to the right conclusion....  Faulty Mouse
0
 
Christian de BellefeuilleProgrammerAuthor Commented:
That's what i think too.  I just raised the flag on E-E just to see if it was a common problem and to make sure it was not a software issue.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.