Vista and XP cannot access each other (ping ip works; ping name not working)

I have three computers. A vista desktop, vista laptop, and an xp desktop.  The vistas both have home premium and the xp is home edition.  I have a netgear router.  Internet is working fine with all of them.  The vista laptop and the xp can share files with each other and ping using the ip and computer names, but the desktop and xp machines cannot.  I can ping back and forth between the two using the ip address, but I can't ping using the names on either the vista desktop or xp.  When I try to map a network drive on any of the computers, I can see all 3 of them. However, I can't access the xp computer with the vista desktop and I can't access the vista desktop on the xp.  I've been comparing the two vistas, but can't find anything different in the network settings.  I've installed all the windows updates and ran malwarebytes, spybot, and microsoft security essentials to get rid of any viruses and such.  They are all on the same workgroup.

Any ideas what's going on here?  

I included a screen shot of the error I get when I try to map a network drive to the xp from the vista desktop.

Thanks

 vista to xp error
LVL 3
deer22Asked:
Who is Participating?
 
NikConnect With a Mentor Systems SpecialistCommented:
Strange issue, but you can fix it this way.

Navigate to:
C:\Windows\System32\drivers\etc

Edit the hosts file and type the names and IP addresses of the PC's that are not resolvable by name:

example

192.168.1.50      DADS

Save the file and try to ping the other PC by name. If it still isn't working, restart your computer.
0
 
ken2421Commented:
In order to access files on the vista machine you will have to create an account to login with. Create a user on each machine and log onto it from the other machine with that account. Save the credentials.

You do no have to have logins at the PC but you must have user accounts. Once you create the Account you can have the PC log into it's main account automatically. Click start, run, and then type < control userpasswords2 >. Highlight the main account and uncheck the box. In this way you can have multiple user accounts but auto login to the main one. The other accounts are only there so that they can authenticate remote shares and whatever.

HTH,
Ken
0
 
deer22Author Commented:
If that's so, then why does the laptop connect without user accounts?  The xp can share files with the vista laptop.  The vista laptop and vista desktop are both setup the same from what I can tell.  
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
deer22Author Commented:
It's seems like there's something wrong with the host name recognition on the vista desktop keeping it from allowing it and the xp from accessing each other...?
0
 
deer22Author Commented:
I figured out that I can share files if I map the drives using the ip address on both the vista desktop and xp.

I guess this works, but I would still like to know why they're not mapping using the computer names?

Anyone know what the problem would be?
0
 
deer22Author Commented:
I'm thinking i got a virus keeping it from using host names.  Your solution might work if I could change the file, but vista won't let me for one and even if it did work the ip addresses could change like they did on me today.  Can i make them static?  I've gotten around vista not letting you save files in system32 before but it's been awhile since i've done that...i'd have to figure it out again......?
0
 
NikSystems SpecialistCommented:
Right click on the hosts file and click Security tab.
Add the Users group Modify permission on the file.
Reopen the file and edit it as mentioned above.

I can't remember, but on Windows Vista, you might need to take ownership of the hosts file before you will be able to change permissions.

Security tab | Advanced | Edit | Change owner then hit apply!
0
 
deer22Author Commented:
OK, I'll try it when I get home tonight.  Also, is there a way to make the ip address static?  I tried to do it in the general tab of the TCP/IPv4 properties by changing the ip, subnet, and gateway to what was there when I ran ipconfig.  After I did then I couldn't get connected to the internet.  Do I need to put in the DNS server address too?  Not sure where I get that at if so?
0
 
NikConnect With a Mentor Systems SpecialistCommented:
You should be able to use the static IP address.
Have you entered the gateway address (IP address of your router)?
You can also enter DNS address (IP address of your router).
0
 
deer22Author Commented:
Worked great once I took control of the hosts file.  This link shows you how: http://www.tech-recipes.com/rx/2204/vista_how_to_take_ownership_system_file/

I made the ip addresses static also following your instructions.

Thanks a million!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.