• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 872
  • Last Modified:

Classic ASP pages not working in 64-bit Windows 2008 and IIS 7

Hi. I just moved a web site built in classic ASP to a 64-bit Windows 2008 and IIS 7 environment.

The web site in question is: www.careplanners.net. The web site will not resolve; I get only a vague "500 - Internal server" error.

Can you tell me what I need to do to get classic ASP pages to work in this new 64-bit environment?

I have enabled 32-bit applications in the application pool for www.careplanners.net.

What else should I do? I'm very grateful for any advice.

Thank you very much for your time.

Eric
0
Eric Bourland
Asked:
Eric Bourland
3 Solutions
 
sammySeltzerCommented:
Hi,

Your asp page is set up well. THere is probably some error somewhere.

To get specific error to display on the browser follow this link to enable "Send Browser Errors to Browser by setting to True.

Right now, it is false:

http://learn.iis.net/page.aspx/564/classic-asp-script-error-messages-no-longer-shown-in-web-browser-by-default/

Also, go to internet options, click on Advanced tab.

Go down and uncheck the box that says, "Show HTTP Friendly Error Messages"

Then run your code and you should see what is going on.

Good luck
0
 
TonyRebaCommented:
sammySeltzer is right, your configuration is correct can you tell us more about the error you are getting?
0
 
BurniePCommented:
You can take a look at

http://stackoverflow.com/questions/637326/how-to-guide-for-getting-a-classic-asp-application-working-under-iis-7-0

Also another thread from expert-exchange

http://www.experts-exchange.com/Web_Development/Web_Languages-Standards/ASP/Q_25121824.html

You might have to configure IIS to display the real error somehow, and from that real error you will be able to find your solution.
0
 
Eric BourlandAuthor Commented:
I got it to work. Here is what I did.

First of all -- I apologize. I did not give you all of the information. My DSN is a MS Access 2003 database. That makes a difference. Sorry! I should have said that.

To run MS Access as a DSN, I put the careplanners.net site in a 32 bit app pool. Then, I removed the ColdFusion mappings for the careplanners.net site from within IIS.

The site now works correctly.

I am going to give points to everyone who replied. Thank you very much for your time and expertise.

Eric B
0
 
Eric BourlandAuthor Commented:
Thank you for your kind help.
0

Featured Post

Become an Android App Developer

Ready to kick start your career in 2018? Learn how to build an Android app in January’s Course of the Month and open the door to new opportunities.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now