Solved

Winodw SBS 2008 Backup

Posted on 2010-11-28
28
1,579 Views
Last Modified: 2012-05-10
I am running Windows SBS 2008 and run a sceduled backup each day , I checked the Windows SBS 2008 report that is emailed to me on a dily basis and noticed that Exchnage is not being backed up , files and folders are being backed up fone , however Exchnage is NOT being backed up. I receive the Server Event Log's as below: ID 565, 9782 AND 518. Why will Exchange not be backed up ? Files & Foders are backing up fine....

Backup      565      27/11/2010 23:07:53      2
Event Details:    
Consistency check for component ''ab6a6f9e-8640-4b44-aa3b-ce248b2473a5''\''Microsoft Exchange Server\Microsoft Information Store\UKPCXSRV001'' failed. Application ''Exchange'' will not be avaliable in the backup done at time ''2010-11-27T23:00:10.096Z''

MSExchangeIS      9782      27/11/2010 23:12:36      4
Event Details:    
Exchange VSS Writer (instance ebd8694f-db96-4201-96c4-28d1461836e7:25) has unsuccessfully completed the backup of storage group ''Second Storage Group''. No log files have been truncated for this storage group.

ESE      518      27/11/2010 23:03:32      6
Event Details:    
eseutil (9000) The log file \\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy121\Program Files\Microsoft\Exchange Server\Mailbox\First Storage Group\E00000037B8.log is missing (error -528) and cannot be used. If this log file is required for recovery, a good copy of the log file will be needed for recovery to complete successfully. For more information, click http://www.microsoft.com/contentredirect.asp.

Regards

Daljit
0
Comment
Question by:BhanaD2
  • 17
  • 10
28 Comments
 
LVL 3

Expert Comment

by:dccj
ID: 34225920
Sounds like you need to do a manual consistency check of your Exchange databases. You haven't been deleting the log files have you? The one that eseutil can't find may be damaged, or have been deleted. This could also suggest some disk corruption. I would start with a full error scan of your Exchange disk and the disk containing the log file (if they are different). Then do a manual consistency check of the databases. Write back if you need help with that.

Also, let us know what your disk configuration is - Exchange on separate disk from system, RAID, etc. Did you build the server or is it an oem model?
0
 
LVL 11

Expert Comment

by:louisreeves
ID: 34226643
I presume exchange is working. As long as you can mount the database and all we are troubleshooting is backup o would ask if you have a third party backup installed. I would say remove that application  and backup up again. If this fails I would try using servermgrcommand to reinstall the backup roll. That should fix any issues you might have
0
 

Author Comment

by:BhanaD2
ID: 34229224
louisreeves.

I do not have any third party backup software installed , you mentioned to try the servermgrcommand to reinstall the backup roll , could you give me a step by step guide on how to do this.

Thanks

Dal
0
 

Author Comment

by:BhanaD2
ID: 34229237
dcci.

I have not been deleting the lig files , I am using disk mirroring and the sofware is Windows SBS 2008 OEM.

Note the backup of files and folders is working fine , the problem is ONLy with Exchnage.

Any Suggestions ?

Regards

Dal
0
 
LVL 3

Expert Comment

by:dccj
ID: 34230759
Then my original suggestions still apply, and in that order. Your server will have some down time to do teh error scan. And Exchange will be down for the Exchange scans because you'll want to do offline scans and repairs.
0
 

Author Comment

by:BhanaD2
ID: 34230877
dcci

I need help doing the  manual consistency check of the databases , can you provide an idiots guide ?

Dal
0
 
LVL 3

Expert Comment

by:dccj
ID: 34230913
No problem. It will be a little while though. It's pretty easy though.
0
 

Author Comment

by:BhanaD2
ID: 34238009
dcci

Any news on the idiots guide to carry out a manual consitency check on the exchnage dateabases ?

Dal
0
 
LVL 3

Expert Comment

by:dccj
ID: 34239294
Sorry for the delay.

First, I would use ntbackup and do a backup of the Exchange store to a temp location. You'll probably just delete this later on.

Then, I would still do a chkdsk scan of the Exchange disk. If there are issues there, anything we do from here will only make things worse.

Next, dismount the store you are going to work on.

Check the integrity by running the following command from the bin dir of the Exchange folder. Use the correct path to the database.
eseutil /g <path>\priv1.edb

Next, run this command.
isinteg -s <servername> -test allfoldertests

Do these two and lets see where we are before we go on. Please don't skip the error scan on the disk!
0
 

Author Comment

by:BhanaD2
ID: 34240720
dcci

Could you provise a step by step guide as Iam not confident in following the instuctions you mentioned.

Dal
0
 
LVL 3

Expert Comment

by:dccj
ID: 34244906
OK, first the disk scan. Open Computer and find the drive that the Exchange databases are on. Right-click on it and click Properties, then on teh Tools tab. Next, click Check Now, check both boxes, click OK, click Yes to schedule for the next reboot. Reboot. Watch and make sure that the scan starts and then go do something else for a while.

Next, open the Exchange Management Console, click on Mailbox under Server Configuration. Click on the database under First Storage Group. Then, on the right, click on Dismount Database. Leave this window open, but minimized. Now, open a cmd shell. Next, go to the drive where Exchange is and cd into the bin dir.

Now run the eseutil above and substitute the full path to the database for the <path>. For isinteg command, substitute the name of your server for <servername>.
0
 

Author Comment

by:BhanaD2
ID: 34257026
dcci

I am following the steps you provided.

1) Right Click on the C: and select tools and then checked both box's to schedule a scan at reboot
2) I opened Exchnage Management Console, clicked on Mailbox under server Configuration and Right Clicked and dismounted Database.
3) How do I open the the CMD Shell ? Is this the "Exchnage Management Shell ?
4) The bin dir is C:\Program Files\Microsoft\Exchange Server\Bin
5) Could you provide the exact text I need to type to use the eseutil and also for the isinteg.

Dal
0
 
LVL 3

Expert Comment

by:dccj
ID: 34266506
BhanaD2 - I hate to do this to you, but your level of experience here is a lot lower than what you need to be doing this job. There is a lot at stake here, and me having to provide basically a script to do this puts me in a position I'm not comfortable with. If someone else wants to pop in here and try to help, I'll back out of the way.

From your list above, it appears that you still have not done an error scan on your hard drive. This system needs to be rebooted and that scan completed before you even attempt any of the other steps. Please do that before you continue.

Sorry. Good luck.
0
 

Author Comment

by:BhanaD2
ID: 34273054
dcci:

I have completed the Error Scan after a reboot already and am ready to attempt the other steps, could you provide the information requested for points 3, 4 and 5 from the previous post.

thanks Dal
0
Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 
LVL 3

Expert Comment

by:dccj
ID: 34274767
Please post the results of the scan. Look in the eventvwr under Windows Applications for Winlogon. Find the one with the scan results and post it here.
0
 

Author Comment

by:BhanaD2
ID: 34277733
dcci

I checked under eventvwr - Microsoft - Windows - Winlogon , there is a text file called "Operational" with no information in it.

I cannot locate the apth you mentioned under Windows Applications for Winlogon ?

Dal
0
 
LVL 3

Expert Comment

by:dccj
ID: 34277910
Sorry - look under Windows Logs, Application, source Winlogon.
0
 

Author Comment

by:BhanaD2
ID: 34278146
dcci

I checked and there is no source for Winlogon.

I found VSS which has the following info:

Log Name:      Application
Source:        VSS
Date:          05/12/2010 17:59:43
Event ID:      8224
Task Category: None
Level:         Information
Keywords:      Classic
User:          N/A
Computer:      UKPCXSRV001.pcexcelled.local
Description:
The VSS service is shutting down due to idle timeout.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="VSS" />
    <EventID Qualifiers="0">8224</EventID>
    <Level>4</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2010-12-05T17:59:43.000Z" />
    <EventRecordID>435968</EventRecordID>
    <Channel>Application</Channel>
    <Computer>UKPCXSRV001.pcexcelled.local</Computer>
    <Security />
  </System>
  <EventData>
    <Data>
    </Data>
    <Binary>2D20436F64653A2020434F525356434330303030303737352D2043616C6C3A2020434F525356434330303030303735372D205049443A202030303030373333362D205449443A202030303030343837322D20434D443A2020433A5C57696E646F77735C73797374656D33325C76737376632E6578652020202D20557365723A204E5420415554484F524954595C53595354454D20202020202D205369643A2020532D312D352D3138</Binary>
  </EventData>
</Event>
0
 

Author Comment

by:BhanaD2
ID: 34278151
dcci

Also this

The VSS service is shutting down due to idle timeout.
0
 

Author Comment

by:BhanaD2
ID: 34278153
dcci

Also

The start address <sts3s://mail.pcexcelled.co.uk:987/contentdbid={8bf04f20-107b-4c5a-b594-5a0615b16804}> cannot be crawled.

Context: Application 'Search index file on the search server', Catalog 'Search'

Details:
      Access is denied. Verify that either the Default Content Access Account has access to this repository, or add a crawl rule to crawl this repository. If the repository being crawled is a SharePoint repository, verify that the account you are using has "Full Read" permissions on the SharePoint Web Application being crawled.   (0x80041205)
0
 
LVL 3

Expert Comment

by:dccj
ID: 34278630
You are moving onto other issues with that one!

Did you actually see the disk scan run when you rebooted? Sometimes I've seen SBS 2008 not do the scan.
0
 

Author Comment

by:BhanaD2
ID: 34281585
dcci

Yes I did see the scan start and complete.
0
 

Author Comment

by:BhanaD2
ID: 34290727
CAN ANY ONE HELP WITH A SOLUTION !!!!
0
 

Author Comment

by:BhanaD2
ID: 34290732
7 DAYS AND STILL NO SOLUTION.....
0
 

Accepted Solution

by:
BhanaD2 earned 0 total points
ID: 34299375
It's been over a week and I have not received a Satisfactory Solution. I will close this Question.

Dissapointed with the Service Provided by Experts Exchnage and may consider a Refund.

Regards

Dal
0
 
LVL 3

Expert Comment

by:dccj
ID: 34306605
I understand your frustration with the results you are getting. However, as a person who does this for a living, I also have a responsibility to not send you down a path that if you run into problems, you will not be able to recover. You have a responsibility to be able to use the the advice given with a certain amount of knowledge of your own, such as filling in paths, etc., into commands. Your questions suggest that you do not have enough knowledge to do that, therefore, it would be negligent on my part to attempt to adapt the instructions given to your environment since I cannot possibly know all there is to know.

My closing advice is that you need to hire someone to come to your site and sort this out. I kow that is not what you came here looking for, but given that no one else has stepped forward on this one, I have to believe that there are many others that agree with me.

So, I apologize, and wish you good luck. I do not object to this question being closed.
 
0
 

Author Comment

by:BhanaD2
ID: 34308940
dcci

Could you provide me support via a remote connection with Teamviewer ?
0
 

Author Closing Comment

by:BhanaD2
ID: 34332910
It's been over a week and I have not received a Satisfactory Solution. I will close this Question.

Dissapointed with the Service Provided by Experts Exchnage and may consider a Refund.

Regards

Dal
0

Featured Post

Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

Join & Write a Comment

I’m often asked about newer and larger USB drives connected to SBS2008 and 2011 failing Windows Server Backup vs the older USB drives not failing. As disk space continues to grow and drive technology change SBS2008 and some SBS2011 end up with the f…
Sometimes drives fill up and we don't know why.  If you don't understand the best way to use the tools available, you may end up being stumped as to why your drive says it's not full when you have no space left!  Here's how you can find out...
This tutorial will show how to push an installation of Backup Exec to an additional server in both 2012 and 2014 versions of the software. Click on the Backup Exec button in the upper left corner. From here, select Installation and Licensing, then I…
This tutorial will walk an individual through locating and launching the BEUtility application and how to execute it on the appropriate database. Log onto the server running the Backup Exec database. In a larger environment, this would generally be …

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now