Solved

iSCSI NIC registerning in DNS

Posted on 2010-11-28
12
1,530 Views
Last Modified: 2012-05-10
I have a iSCSI SAN.
I have installed a iSCSI NIC in my DC/DNS server and advertised storage fine.
Problem is that the NIC is registering itself in DNS and PCs are resolving the host to the iSCSI IP address.
I have unticked the checkbox to register in DNS, changed the order of the NIC in advanced options to the bottom
but it makes no difference. Any ideas?
It is Windows Server 2008.
0
Comment
Question by:SteveSext
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 3
  • 2
  • +2
12 Comments
 
LVL 7

Accepted Solution

by:
tstritof earned 250 total points
ID: 34227123
Hi,

have you tried to manually remove the A record in Forward Lookup Zone and PTR record in Reverse Lookup Zone of your iSCSI NIC from DNS after unticking it in NIC properties? These records won't get deleted immediately after you change the NIC settings.

You should also clear the DNS cache on server and clients after that.

Regards,
Tomislav

0
 
LVL 42

Expert Comment

by:kevinhsieh
ID: 34227270
Having multiple NICs on a domain controller is a bad idea, and this is one of the reasons why. You can try to make a static entry for the DC in DNS. That prevents normal machines from making dynamic updates to DNS, but I don't know if that works for DCs. If it doesn't, you should disable the NIC being used for iSCSI and just use your main NIC to talk to your SAN. That's not "best practice", but unless your SAN is completely isolated from the rest of your network such that it won't work, I can't make a convincing arguement as to why it won't work or why it really, really shouldn't be done. Performance will be fine, and security probably won't change either.
0
 
LVL 7

Expert Comment

by:tstritof
ID: 34227317
I think the configuration with multiple NICs on DC gets blamed too often. I have W2K8 DCs configured with multiple NICs (even SBS), some running as routers, some running virtual machines in Hyper-V all with no issues. The only thing I always do to keep out of problems is disable the IPv6 protocol on all NICs, if necessary disable registration of certain NICs in DNS and make sure my DNS listens only on a single chosen IP address.

Also since I believe iSCSI NICs usually use offloading quite heavily to keep the CPU from melting and I've seen that same offloading cause grief with normal network traffic (especially with some Broadcom models) I'm somewhat worried about the outcome of single NIC scenario.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
LVL 42

Expert Comment

by:kevinhsieh
ID: 34227334
My thinking is that if there is so much iSCSI traffic such to the point where a single NIC really would be a problem, the author wouldn't be trying to run the file server/SQL server/Exchange server/whatever on a domain controller in the first place.
0
 
LVL 7

Expert Comment

by:tstritof
ID: 34227366
I don't know what will else might or might not be running on Steve's machine. What I meant was that having multiple NICs on a DC is more of a controllable configuration issue compared to unknown potential issues in one NIC scenario with iSCSI. Sorry if that came ot wrong.
0
 
LVL 7

Expert Comment

by:tstritof
ID: 34227368
:) out...
0
 
LVL 15

Assisted Solution

by:msmamji
msmamji earned 250 total points
ID: 34229183
If your iSCSI is getting address from the DHCP then there is a possibility that the DHCP might be registering the IP to the DNS on your (machine's) behalf. If that is the case try assiging a static IP to the iSCSI NIC.
0
 

Author Comment

by:SteveSext
ID: 34229238
The iscsi nics have assigned static addresses fom my storage subnet.
I've disabled al checkboxes in nic properties, disabed lmhosts, made no difference.
Any other ideas??
0
 
LVL 15

Expert Comment

by:msmamji
ID: 34229378
did you remove the DNS records from the DNS server after that
0
 
LVL 7

Expert Comment

by:tstritof
ID: 34229577
Have you disabled NetBIOS? If primary domain suffix gets applied there the fqdn will be popping around again with NetBIOS enabled.

If you want to be sure no other interference comes from that NIC disable all protocols you don't need for your iSCSI and go rechek the Tcpip settings for that NIC directly in registry to make sur they got applied (I haven't seen that problem on W2K8 machine yet, but...)

When cleaning DNS make sure you clean out ALL A records pointing to the wrong IP address and that you disable all but 1 desired address as DNS listener in DNS server (or your nameserver will be registering under multiple addresses again).

Clear the DNS cache. Do a restart after the cleanup process. Clear DNS cache on your clients and retest.

Regards,
Tomislav
0
 
LVL 42

Expert Comment

by:kevinhsieh
ID: 34233155
Did you try my idea of deleting all DNS entries and putting in a static entry? Otherwise, I suggest going to 1 NIC, or enable everything on the iSCSI NICs so that if clients use that IP that it will work (as long as they can route to it).
0
 
LVL 55

Expert Comment

by:andyalder
ID: 34237704
0

Featured Post

SharePoint Admin?

Enable Your Employees To Focus On The Core With Intuitive Onscreen Guidance That is With You At The Moment of Need.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Automate Windows Updates with SCCM 2 90
Decommissioning DNS server question 3 36
Regarding Disk IO 3 49
IIS Authentication Error 401 16 17
Is your phone running out of space to hold pictures?  This article will show you quick tips on how to solve this problem.
The business world is becoming increasingly integrated with tech. It’s not just for a select few anymore — but what about if you have a small business? It may be easier than you think to integrate technology into your small business, and it’s likely…
This tutorial will give a an overview on how to deploy remote agents in Backup Exec 2012 to new servers. Click on the Backup Exec button in the upper left corner. From here, are global settings for the application such as connecting to a remote Back…
This tutorial will walk an individual through the steps necessary to enable the VMware\Hyper-V licensed feature of Backup Exec 2012. In addition, how to add a VMware server and configure a backup job. The first step is to acquire the necessary licen…

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question