db_recovery_dest for flashback

in order to flashback database, I used the following steps..
but I could not create the destination..
I already created a file called dest.txt
still shows error. What could be the reason?
SQL> alter system set db_recovery_file_dest=c:\n.txt;
alter system set db_recovery_file_dest=c:\n.txt
                                        *
ERROR at line 1:
ORA-00922: missing or invalid option


SQL> alter system set db_recovery_file_dest= c:\n.txt;
alter system set db_recovery_file_dest= c:\n.txt
                                         *
ERROR at line 1:
ORA-00922: missing or invalid option


SQL> alter system set db_recovery_file_dest='c:\n.txt';
alter system set db_recovery_file_dest='c:\n.txt'
*
ERROR at line 1:
ORA-02097: parameter cannot be modified because specified value is invalid
ORA-01261: Parameter db_recovery_file_dest destination string cannot be
translated
ORA-01263: Name given for file destination directory is invalid
OSD-04018: Unable to access the specified directory or device.
O/S-Error: (OS 2) The system cannot find the file specified.


SQL> alter system set db_recovery_file_dest='c:dest.txt';
alter system set db_recovery_file_dest='c:dest.txt'
*
ERROR at line 1:
ORA-02097: parameter cannot be modified because specified value is invalid
ORA-01261: Parameter db_recovery_file_dest destination string cannot be
translated
ORA-01263: Name given for file destination directory is invalid
OSD-04018: Unable to access the specified directory or device.
O/S-Error: (OS 2) The system cannot find the file specified.


nobleitAsked:
Who is Participating?
 
manzoor_dbaConnect With a Mentor Commented:
Hi,

By default the db_recovery_file_dest will be configured with the Flashback desination folder. If you want to configure you own desination the proceed as per below..

1) You need to enter the value of the desination folder where you flashback files will be stored. You are not supposed to specify any file name  ( here you have mentioned a file name)..

If database is stared up using pfile:-

1) shutdown the database.
2) Modify the below parameter in the pfile.
   db_recovery_file_dest = 'C:\FLASHBACK'
   
  Here i have give the folder name as flashback which already exists in the c: drive.

3) The startup your database using the modified pfile.

If the database is started using spfile then.

1)
SQL> alter system set db_recovery_file_dest = 'C:\FLASHBACK'  SCOPE=Both;
System altered.


Thanks...

 




0
 
AnandCommented:
manzoor_dba has given the pin pointed answer.
0
 
nobleitAuthor Commented:
Sorry for the delay. The issue is solved. Thank you for all your support..
0
 
nobleitAuthor Commented:
accept manzoor_dba and give points..
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.