?
Solved

When sending email to .org domain, i receive NDR for .nl domain

Posted on 2010-11-29
10
Medium Priority
?
429 Views
Last Modified: 2012-06-27
Dear All,

I have a strange issue.

Windows server 2008 Std
Exchange 2007 SP2

I work for a International company.
I am located in the Netherlands. there is a company in Belgium with the same name but own domain.
There is NOT a trust relation between our sites.

When I send a message from company.nl to company.com i receive an NDR message that the user isn't in the .nl server uh? yes. instead of trying to send to the .org he try to send it to the .nl domain. our own domain.
before the . (dot) the company name is identical.
I have a feeling that DNS is making some mistakes.
Sometimes the message will arrive. but mostly not.
The NDR message we receive from our server.
IMCEAEX-_O=BDV_ou=First+20Administrative+20Group_cn=Recipients_cn=user+name@company.nl  (while we send to .org)
#550 5.1.1 RESOLVER.ADR.ExRecipNotFound; not found ##

What i've tried is to create a DNS zone for the .org domain. i created an A record (blank) and filled in IP of there mailserver. but then i receive the message:
ns1.xxxxx.be #554 5.7.1 <user.name@company.org>: Relay access denied ##
(they won't add our IP to allow relaying)
what am i doing wrong? or how can i solve this issue.

Many thanks in advance.

Richard
0
Comment
Question by:RichardWltenburg
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 3
10 Comments
 
LVL 14

Expert Comment

by:Shabarinath Ramadasan
ID: 34229316
Create a external routing connector for company.com pointing to the external relay servers of company.com
On the external relay server, include the ip address of company.nl relay servers in the accepted list so that your relay servers can relay mails.

In between, if your server is generating this NDR, then see if any contact or mail enabled object with this SMTP address exist on your domain and the target SMTP address is correct.

Good luck
Shaba
0
 
LVL 26

Expert Comment

by:Tony J
ID: 34229361
Or make sure the receiving Exchange servers accept .nl as an accepted email domain. Most likely, they do not from what you describe.
0
 
LVL 5

Author Comment

by:RichardWltenburg
ID: 34229413
problem is that the other company is a company on its own and wont change there settings. (relay)

in the NDR message we see that the mail is send TO .org, but that the mailbox cant be found on the .nl domain.

when i resend 10 times maybe 2/3 will succeed. so very strange.
tnx for your reply
0
Are your AD admin tools letting you down?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

 
LVL 26

Accepted Solution

by:
Tony J earned 2000 total points
ID: 34229439
So often the case - receiving company claims no problem/refuses to make a simple change!

I've never tried, so not sure, but could you alter the outbound domain with a transport rule?
0
 
LVL 5

Author Comment

by:RichardWltenburg
ID: 34229523
I've added a send connector. I will keep you informed.
tnx again
0
 
LVL 26

Expert Comment

by:Tony J
ID: 34229526
If you do an nslookup on the MX record for the receiving domain, do any of your DNS servers return the correct details?

Sounds like something is manipulating it / misconfigured but not everything.
0
 
LVL 5

Author Comment

by:RichardWltenburg
ID: 34229619
yes, the MX records are shown correctly.
0
 
LVL 5

Author Comment

by:RichardWltenburg
ID: 34229633
when i ping there mailserver by name mail.company.org i receive a reply of another ip. the ip is from the nameserver of there provider.

pinging mail.company.org [212.**.***.**]

reply from 62.**.**.**: TTL expired in transit
0
 
LVL 5

Author Comment

by:RichardWltenburg
ID: 34229656
forgot to mention same message when ping on ip.
0
 
LVL 5

Author Closing Comment

by:RichardWltenburg
ID: 34279275
It seems like the outbound connection rule for the .org domain solves this issue. havent got any complains.

Thanx for your replies
0

Featured Post

Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Read this checklist to learn more about the 15 things you should never include in an email signature.
New style of hardware planning for Microsoft Exchange server.
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…
Suggested Courses

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question