Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Sharepoint 3.0 search finds old documents

Posted on 2010-11-29
4
Medium Priority
?
770 Views
Last Modified: 2012-05-10
Our Sharepoint 3.0 website works fine apart from the search function, which appears to be returning old results, not up to date ones.

For example, we have a document called "Work Manual.doc" which we recently updated and renamed to "Work Manual.docx".  If you search the site for "Work Manual" it will find only the old document link, which doesn't work ("404 NOT FOUND" error).

If you edit the URL to change ".doc" to ".docx", the document opens.

It looks like the search results need to be refreshed.  I've already successfully run:

stsadm -o spsearch -action fullcrawlstart

but this has made no change.

How can I make the search return up to date results?

Thanks in advance!
0
Comment
Question by:David Haycox
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 6

Assisted Solution

by:Sushanta Sahu
Sushanta Sahu earned 600 total points
ID: 34231626
Is it for WSS 3.0?

If for MOSS run full crawl, if this does not help drop the index and run the full crawl.

Let me know how it goes.
0
 
LVL 2

Author Comment

by:David Haycox
ID: 34231675
It's not MOSS, it's WSS 3.0.

How would I go about dropping the index?

Thanks
0
 
LVL 2

Accepted Solution

by:
robertosljunior earned 1400 total points
ID: 34233048
SharePoint 3.0 Central Administration -> Operations -> Services on Server -> In Windows SharePoint Services Help Search service, click Stop. Click OK when you receive the following message: The Windows SharePoint Services Search service that was enabled on this server will be uninstalled and all index files will be deleted permanently. Repeat this step on each server where the Windows SharePoint Services Search service is running.
0
 
LVL 2

Author Comment

by:David Haycox
ID: 34237388
That's done the trick!  I had to delete the WSS_Search databases in SQL Management Studio before starting it up again, then ran the full crawl again.

Thanks very much.
0

Featured Post

On Demand Webinar: Networking for the Cloud Era

Ready to improve network connectivity? Watch this webinar to learn how SD-WANs and a one-click instant connect tool can boost provisions, deployment, and management of your cloud connection.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Note:  There are two main ways to deploy InfoPath forms:  Server-side and directly through the SharePoint site.  Deploying a server-side InfoPath form means the form is approved by the Administrator, thus allowing greater functionality in the form. …
I thought I'd write this up for anyone who has a request to create an anonymous whistle-blower-type submission form created using SharePoint 2010 (this would probably work the same for 2013). It's not 100% fool-proof but it's as close as you can get…
In this brief tutorial Pawel from AdRem Software explains how you can quickly find out which services are running on your network, or what are the IP addresses of servers responsible for each service. Software used is freeware NetCrunch Tools (https…
In this video, Percona Director of Solution Engineering Jon Tobin discusses the function and features of Percona Server for MongoDB. How Percona can help Percona can help you determine if Percona Server for MongoDB is the right solution for …

721 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question