• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1201
  • Last Modified:

XP machine VERY slow while logging onto domain

Hi all,

I have a customer that is complaining of very slow logon times on their XP machines. It would stick at the screen "Applying computer settings" for up to 40 minutes. They can log on by removing their network cable, logging on with a cached profile and then re-plugging in their network cable.

They are running Server 2003, and a mixture of XP, 7 and Vista machines, the 7 and Vista machines are not effected.

What I have done so far is manually assign the server in the client DNS which has resolved the problem and their logon times are back to normal. Obviously this isn't a permanent fix, so I'm looking at the bigger picture with this - I can't have them taking laptops home and then can't access their home broadband.

Any ideas?

Thanks.
0
Bruce Skinner
Asked:
Bruce Skinner
  • 6
  • 5
  • 2
  • +3
1 Solution
 
Darius GhassemCommented:
Make sure that the clients are only pointing to your Domain Controllers for DNS in their TCP\IP properties. Another issue with laptops is that when they are locally connected to the domain they are still connected to an outside WLAN which gives them a different IP scheme.

So, I would check the binding order go into Network Connections click Advanced Menu then Advance Settings check to make sure Wired LAN is listed first.
0
 
coalnineCommented:
Disabling the DHCP media sense in XP has helped me in a similar situation. Try this:

Start Registry Editor.
Locate the following registry subkey:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters

Add the following registry entry to the Parameters subkey:
Name: DisableDHCPMediaSense
Data type: REG_DWORD (Boolean)
Value: 1


Kenny
0
 
Bruce SkinnerAuthor Commented:
Hi dariusg,

I said in the opening question that I have pointed the clients towards the server for DNS, which is what fixed the problem. I can't keep them like this in case they go home, they can't have manually assigned settings.

Thanks though.
0
Evaluating UTMs? Here's what you need to know!

Evaluating a UTM appliance and vendor can prove to be an overwhelming exercise.  How can you make sure that you're getting the security that your organization needs without breaking the bank? Check out our UTM Buyer's Guide for more information on what you should be looking for!

 
Bruce SkinnerAuthor Commented:
Hi coalnine,

A registry fix cannot be done on more than 40 PCs,

I need the server to be dealing with DNS and the clients set to obtain automatically,

so when they're taken off site, they'll work with other networks.
0
 
Darius GhassemCommented:
What I am saying is that you need to find out why they are not getting the correct DHCP settings with the IP settings pointing to your internal DNS servers. So, you need to find the DHCP server causing the issue. Remove the static IP address ipconfig /release and ipconfig /renew you will then get IP settings see what is wrong with the settings. You can tell what DHCP server leased the IP scheme by looking at the ipconfig /all then go to the DHCP server make the approiate changes.

If your DHCP server is the router I would advise disabling this feature on the router then allow your Windows 2003 Server to be your DHCP server
0
 
Bruce SkinnerAuthor Commented:
Thanks dariusg,

The DHCP server is the domain controller, and when the customer just allows the delay and waits the 40 minutes, when they eventually get logged in, the ipconfig reveals that the primary DNS server is the domain controller and the secondary is the ISPs DNS server..
0
 
Darius GhassemCommented:
The secondary needs to be removed there should not be any external DNS servers listed in the TCP\IP properties of the clients or servers.

Again check the wireless binding order as well or disable the wirless card for testing
0
 
Darius GhassemCommented:
Also, make sure you are getting the IP Addresses from the correct DHCP server you could have a rouge DHCP server on the network as well
0
 
ipajonesCommented:
You do need to ensure that the DNS settings inherited by the clients via DHCP is correct as per dariusq's post.  That said assuming your Vista/Win7 clients use the same DHCP servers I think there might be something else going on here.

You said that these machines are laptops and I assume by that they'll all have wireless NICs.  I had some similar problems recently with exactly the symptoms you describe of logging in hanging at the "Apply computer settings" stage.

When I disabled the wireless NIC everything was fine.  This led me to think the problem seemed to be due to Wireless Adapters.  What fixed the problem for me was ensuring Windows Wireless is only set to “infrastructure networks” and not “ad-hoc”.

Unfortunately you might find this problem is with the client machines themselves.  Whilst it often is, it's not always DNS!

Incidentally you can do registry changes to multiple machines using login script commands etc.

Hope this helps.
--IJ
0
 
coalnineCommented:
oops, didn't read all of your question.. sorry about that.. I am thinking along the same lines as dariusg on this..

Kenny
0
 
Bruce SkinnerAuthor Commented:
dariusg,

The external DNS server being the secondary DNS server isn't the issue, I have assigned those settings are we're currently up and running for the short term. I need the clients to get the DNS through DHCP so nothing is manually assigned,

Also, just to note, all of the XP machines aren't laptops, only some of them. I'm just using laptops as an example because I can't have them being taken off site with static addresses assigned for obvious reasons.

Thanks for the suggestions, I shall try the wireless NIC settings and DHCP settings tomorrow morning when I get into work.

ipajones,

Same as above, I'll try your wireless NIC suggestions tomorrow. Thanks.

Also, I'm aware I can do the registry fixed through login scripts, but this isn't a viable fix. One day it was working and the next day is not, registry fixes for a problem like this is a bit temperamental in my opinion.
0
 
Darius GhassemCommented:
Either way you should never have external DNS servers in the TCP\IP settings of any server or client in a domain environment. Before proceeding you need to remove from DHCP.
0
 
januismerCommented:
Check out this screenshot too of how the script applied.  Note that there is no percentage for the home directory
Screen-shot-2010-11-30-at-8.14.4.png
0
 
januismerCommented:
Sorry... Posted to wrong thread above!
0
 
vvramakrishnaCommented:
Have you tried adjusting the network setting of the client to full duplex?
0
 
Bruce SkinnerAuthor Commented:
I have resolved this problem myself. It turned out that the connection between Active Directory and DNS required more virtual memory than what was set. The drive in the server only had 1GB of free space so that's all the virtual memory was using, I moved the virtual memory to the D drive, increased it, restarted and all was fine.
0
 
Bruce SkinnerAuthor Commented:
I have resolved this problem myself. It turned out that the connection between Active Directory and DNS required more virtual memory than what was set. The drive in the server only had 1GB of free space so that's all the virtual memory was using, I moved the virtual memory to the D drive, increased it, restarted and all was fine.
0

Featured Post

Will You Be GDPR Compliant by 5/28/2018?

GDPR? That's a regulation for the European Union. But, if you collect data from customers or employees within the EU, then you need to know about GDPR and make sure your organization is compliant by May 2018. Check out our preparation checklist to make sure you're on track today!

  • 6
  • 5
  • 2
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now