Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

linux ftp problem

Posted on 2010-11-29
10
Medium Priority
?
380 Views
Last Modified: 2012-05-10
I am using centos 5.4 with plesk 10.0.1 and when i try to connect to ftp i got the following error :


421 Service not available, remote server has closed connection

i have tryed to ping and resolve domain domain both of them has been succed and i 've checked what if  a program listen 21 port :
lsof -i tcp:21
but it seems ok as described here http://help.godaddy.com/topic/93/article/1587
what should be the problem
0
Comment
Question by:3XLcom
  • 5
  • 4
10 Comments
 
LVL 30

Expert Comment

by:Britt Thompson
ID: 34233093
Can you telnet into the server on port 21:

telnet server.address.com 21

If not, then it's likely the service is not running or it's firewalled
0
 
LVL 6

Assisted Solution

by:Kailash Aghera
Kailash Aghera earned 600 total points
ID: 34233175
It seems some firewall issue. Can you ftp locally? I mean does it ask for username if you type ftp localhost on your server (via SSH)?
0
 

Author Comment

by:3XLcom
ID: 34233298
yes i tryed locally but it does not work  and also i have checked what if it listen 21 port but it seems every thing is ok.
0
Fill in the form and get your FREE NFR key NOW!

Veeam is happy to provide a FREE NFR server license to certified engineers, trainers, and bloggers.  It allows for the non‑production use of Veeam Agent for Microsoft Windows. This license is valid for five workstations and two servers.

 
LVL 30

Expert Comment

by:Britt Thompson
ID: 34233317
So it does connect when you telnet into port 21?
0
 

Author Comment

by:3XLcom
ID: 34233362
no it does not server closes connection directly
0
 

Author Comment

by:3XLcom
ID: 34233441
Microsoft Telnet> open
( to ) moviegy.com:21
Connecting To moviegy.com:21...Could not open connection to the host, on port 23
: Connect failed
Microsoft Telnet>
0
 
LVL 30

Expert Comment

by:Britt Thompson
ID: 34233579
the syntax should be exactly like so:

telnet movieguy.com 21
0
 

Author Comment

by:3XLcom
ID: 34233605
same result
0
 
LVL 30

Accepted Solution

by:
Britt Thompson earned 1400 total points
ID: 34233637
Same answer...it's either being blocked by a firewall or the ftp service is not running. You need to check your router/firewall settings and make sure port 21 is open and forwarded to the correct IP and also check your software firewall if you have one.

Try running a telnet on the local server from the terminal:

telnet localhost 21

If it connects, it's a firewall issue.
0
 

Author Closing Comment

by:3XLcom
ID: 34233664
Thanks for all your help i have found the answer :

if inetd not working try to use the proftp

edit /etc/proftpd.conf

change Servetype from inetd to Standalone

kill first the current ftp process

linux:# lsof -i tcp:21
COMMAND PID USER FD TYPE DEVICE SIZE NODE NAME
inetd 25261 root 0u IPv4 452954 TCP *:ftp (LISTEN)

linux:# kill 25261

then run the proftp

linux:# /usr/sbin/proftpd
0

Featured Post

Get your Conversational Ransomware Defense e‑book

This e-book gives you an insight into the ransomware threat and reviews the fundamentals of top-notch ransomware preparedness and recovery. To help you protect yourself and your organization. The initial infection may be inevitable, so the best protection is to be fully prepared.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I. Introduction There's an interesting discussion going on now in an Experts Exchange Group — Attachments with no extension (http://www.experts-exchange.com/discussions/210281/Attachments-with-no-extension.html). This reminded me of questions tha…
Lease-to-own eliminates the expenditure of hardware replacement and allows you to pay off the server over time. Usually, this is much cheaper than leasing servers. Think of lease-to-own as credit without interest.
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
Suggested Courses

972 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question