Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Terminal Services - Default "Log on to:"

Posted on 2010-11-29
8
Medium Priority
?
514 Views
Last Modified: 2012-05-10
After applying quite a number of Windows updates, something has gone awry with Terminal Services.

Any new connection that does not define the domain name via the username (i.e. user@domain.com or domain.com\user) will default to attempting the credentials as localhost\user.

I understand that I can force Terminal Services to default to my domain, but then that requires my users to enter their credentials again.

My understanding is that Terminal Services uses the last logged in cache but my experience is otherwise after these windows updates.  It keeps defaulting back to the localhost unless I force terminal services to prompt for credentials or define the domain in the username field.

This is a Windows 2003 SE with SP2.

I've also tried editing the "AltDefaultDomainName" and "AltDefaultUserName" in HKLM\Software\Microsoft\Windows NT\CurrentVersion\Winlogon, but to no avail.  I'm pretty much down to selectively removing Windows updates to see which one has affected this change.  Any ideas to the contrary will be much obliged.
0
Comment
Question by:patterned
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 3
8 Comments
 
LVL 8

Expert Comment

by:FOTC
ID: 34234731
is this happening on all machines or just your machine?

if its just yours, you may want to try deleting the file "Default" located in the users "my documents / documents" folder. you will have to enable hidden files and folders to see it.
0
 
LVL 4

Author Comment

by:patterned
ID: 34234961
This is all machines.  Newly added to the domain machines, I've tested.

Local settings shouldn't matter in a domain environment.  If you're logged in under the domain, the default login to a Terminal Server should be the domain.

After some more poking I found this out:

On my XP machine running RDP 6, it will save the settings after the first login to the Windows 2003 server, however I still have to change it the first time.  Any connection to any other server defaults to my domain.

On all my clients (who are running RDP 7) they will not save the settings unless I specify the domain in the user field.
0
 
LVL 8

Expert Comment

by:FOTC
ID: 34235054
got me...it could having something to do with having a mixed bag of 6 & 7 clients. do you have any GPO settings applied with TermSvc settings?
0
Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

 
LVL 4

Author Comment

by:patterned
ID: 34235072
Nope.
No GPO settings, as they would be applied across all servers and those are not exhibiting the problem.

I only have 2 or 3 machines running 6..
This wasn't an issue until the updates came down the pipe.  I guess I'm forced to hunt and peck.. oh god the pain.  I feel it already.
0
 
LVL 8

Expert Comment

by:FOTC
ID: 34235130
lol sorry....couldn't you just update them all to v7?
0
 
LVL 4

Assisted Solution

by:patterned
patterned earned 0 total points
ID: 34235179
That wouldn't solve my problem.

RDP 7 doesn't default to the domain for login!  I have to define it in the user field.. and I don't want to run around to everyone and add domain\user to all my clients.  Too much of a hassle and I can't depend on them to figure it out.

I'm the only one who uses RDP 6, anyway.
0
 
LVL 4

Accepted Solution

by:
patterned earned 0 total points
ID: 34235267
Son of a monkey-nut.
This is so retarded.

Anyone who runs into this problem, it is not a windows update that causes the issue.

I usual do remote reboots and login via console and when I log in I use the domain\user combination, thus (I assume, I haven't researched) not setting the default.rdp that FOTC referred to earlier.

I'm kicking my self right now.
0
 
LVL 4

Author Closing Comment

by:patterned
ID: 34272895
Don't initially log into the machine via console with "domain\user" or "user@domain".  This will cause RDP clients to default to authenticating to the localhost.
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Many of us need to configure DHCP server(s) in their environment. We can do that simply via DHCP console on server or using MMC snap-in on each computer with Administrative Tools installed in a network. But what if we have to configure many DHCP ser…
The System Center Operations Manager 2012, known as SCOM, is a part of the Microsoft system center product that provides the user with infrastructure monitoring and application performance monitoring. SCOM monitors:   Windows or UNIX/LinuxNetwo…
Video by: ITPro.TV
In this episode Don builds upon the troubleshooting techniques by demonstrating how to properly monitor a vSphere deployment to detect problems before they occur. He begins the show using tools found within the vSphere suite as ends the show demonst…
Visualize your data even better in Access queries. Given a date and a value, this lesson shows how to compare that value with the previous value, calculate the difference, and display a circle if the value is the same, an up triangle if it increased…
Suggested Courses

598 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question