Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1138
  • Last Modified:

How to stop iMac sleeping?

I have my new OS X 10.6 iMac set in Energy Saver to "Never sleep" while I download a couple of very big apps. Unfortunately it's still sleeping!

What to do?

I had the "hard disk sleep when possible" box checked in the Energy Saver dialogue box. Would that be the problem?
0
Alan Henderson
Asked:
Alan Henderson
  • 5
  • 4
  • 2
  • +1
1 Solution
 
dj0rbitCommented:
Yes! Change that so it never sleeps
0
 
nwtechdeskCommented:
You might enjoy a small app called insomnia.  http://www.macupdate.com/info.php/id/22211/insomniax
0
 
Alan HendersonAuthor Commented:
@ dj0rbit
It doesn't make sense that enabling HDD sleep should override disabling Computer sleep. I'm trying it—I'll see what happens.

@ nwtechdesk:
1. Isn't Insomniax's purpose in life to disable sleep when closing a MacBook lid?
2. Is there a danger of overheating a MacBook when doing that?

0
Important Lessons on Recovering from Petya

In their most recent webinar, Skyport Systems explores ways to isolate and protect critical databases to keep the core of your company safe from harm.

 
nwtechdeskCommented:
Stuffing a macbook into a bag with it on would cause it to overheat but otherwise the air flows and the cpu stays cool.

Keep in mind that the disk sleep command applies only to the startup drive.  If you are using other drives it is possible that their own firmware controls the spin.
0
 
roylongCommented:
You don't have a sleep set somewhere else and timed do you?  It's possible to set the computer to sleep at a certain time each day separate from energy saver - this isn't the issue is it?
0
 
Alan HendersonAuthor Commented:
@ roylong
This is a new iMac 2 days ago. I haven't set any Sleep function up in anything that I'm aware of although I've been putting the Display to sleep with Exposé, maybe that's the problem.  it's still going to sleep with both HDD sleep and Computer sleep off.
0
 
roylongCommented:
Are you sure it's going to sleep and not just blanking the screen (i.e. Screensaver)?
0
 
Alan HendersonAuthor Commented:
It was stopping downloads and requiring a password/logon. I had Preferences set to not require a password.

I just noted that in the Security Preferences it was set to the default  "Log out after 30 minutes of inactivity". So would that be the problem? Is downloading a file not recognized as "activity"?

Sorry to be so dense. I'm a 20-year Windows convert. 3 days of relatively painless withdrawal so far.

:)
0
 
roylongCommented:
That is probably the issue, disable that.  Which web browser are you using?
0
 
Alan HendersonAuthor Commented:
Firefox.

Doesn't everybody?
0
 
roylongCommented:
I was curious as to whether safari would behave any differently with respect to the computer thinking you were busy while downloading...
0
 
Alan HendersonAuthor Commented:
Good point. Next time I try a big download I'll use Safari.
0

Featured Post

Vote for the Most Valuable Expert

It’s time to recognize experts that go above and beyond with helpful solutions and engagement on site. Choose from the top experts in the Hall of Fame or on the right rail of your favorite topic page. Look for the blue “Nominate” button on their profile to vote.

  • 5
  • 4
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now