Wireless Network Problem

I just purchased a recertified Linksys router - WRT54GS2. I need to set it up on our school network with a static IP, no DHCP and wireless access. I have given it a static IP, I have turned off the DHCP and the wireless computers can see the SSID I gave it. The problem is, they don't connect. I either get the "Limited or no connectivity" message or they are constantly trying to validate. I have already gone to the various settings in Windows XP where you can enter the pass phrase etc and made all of those changes with no success.

Please help.

Robert
Robert EhingerIT specialistAsked:
Who is Participating?
 
Fred MarshallConnect With a Mentor PrincipalCommented:
Follow these steps:

1) Disconnect the router from everything.
2) With a laptop or handy desktop, access it using an ethernet cable on one of the LAN ports.
- at this point, either you can access it or not.  Probably DHCP isn't going to work, eh?  So, you should try a variety of static IP addresses on the computer ethernet interface you're using.
- if you still can't access it, then reset it so that DHCP comes back on.  Then do this:
3) Set the WAN IP to "get automatically"  it won't matter much anyway (see below).
4) Set the LAN IP to a LAN IP that doesn't conflict with any other device on the LAN.  This will be a static address so should be *outside* any DHCP range working on the LAN.
5) Now you should be able to re-connect the computer to the router using DHCP and the new IP address will be in your LAN range - but maybe not unique yet...
6) Now access the router and turn off DHCP on the LAN.
.... at this point, the router is fully configured for what you need.
7) Plug your LAN via ethernet into a *LAN* port on the router.  Now you should be able to access the router, at its assigned LAN IP, from any computer on the LAN>
DO NOT plut anything into the WAN port!!  This router is being used as a simple switch and a wireless access point only.  The router/gateway/NAT/firewall features are all bypassed for all practical purposes.
8) Access the router and set up the wireless any way you want.
The wireless access point is connected to the internal switch in the router so any connections will connect to the LAN.  Handshaking should be working like this:
- wireless client connects the radios.
- router negotiates a secure connection with the client.
- client seeks an IP address via DHCP and gets one from the LAN's DHCP server whereever that may be.
0
 
Robert EhingerIT specialistAuthor Commented:
Also, I cannot access the router with its new static IP.
0
 
alexbumbaceaCommented:
1. WLAN - interface to your isp:
 You have configured it as a static ip address received(disabling DHCP client) from your isp

2. LAN&WLAN - interface to your computes
Here you have 2 choices:
1. Disable dhcp server and assign ip to the computes manually(other wise you'll get the error you said)
2. Enable dhcp server and it should work
0
Improved Protection from Phishing Attacks

WatchGuard DNSWatch reduces malware infections by detecting and blocking malicious DNS requests, improving your ability to protect employees from phishing attacks. Learn more about our newest service included in Total Security Suite today!

 
AngloCommented:
Because you want to disable DHCP I assume you are using a server to provide it at the school or use static addresses.  Limited or no connectivity is sometimes due to the MAC address security being enabled on a router or due to a security mismatch.   Check your security passphrase on the router and also what security,(you may want to try WEP instead of WPA.  Also some Laptop/NIC connections need to have the security phrase entered as the full hex equivalent of you passphrase http://www.corecoding.com/utilities/wep2hex.php
0
 
MARCOSALVESCommented:
Hi.
You set the static ip to the wireless network connection in the client computers? This message is because you disable dhcp server in router, and the clients are without a static ip.
To be sure about that, you can open cmd and type the ipconfig /all command.
Se in the wireless connection, the ip that show there.
0
 
Robert EhingerIT specialistAuthor Commented:
OK, maybe more information is needed here. We do have a server giving out DHCP. We have a total of 5 wireless routers - 4 of which I have had absolutely no problem getting setup the way I described. I have CAT 5 cables connected to two of the of the Ethernet ports on the back of each router. Our DHCP scope is 192.168.0.100 to 192.168.0.249. Our routers all havs static IP's of 192.168.0.220, 251, 252, 253 or 254. We have never experienced this problem with any of the other routers. This is a new one for us.

And BTW, the reason we have 5 routers is that we are in two buildings, that are 2 blocks apart and each is a block in size. The distance from the server and the individual routers requires we set up additional wireless access points.
0
 
MARCOSALVESCommented:
You comment that Also, "I cannot access the router with its new static IP."
Can´t ping the router in a machine connected and working in the network?
0
 
Robert EhingerIT specialistAuthor Commented:
No when I try to go back into the router setup to change the SSID or security, or to verify settings I can't log on with the new IP.
Incidentally, before I posted the issue here I had contacted Linksys support and they referred me to theis link -
http://www6.nohold.net/Cisco2/ukp.aspx?pid=80&login=1&app=search&vw=1&articleid=19850.

I followed the steps but still could not connect.
0
 
MARCOSALVESCommented:
Even you trying connect through the wired network can´t connect?
Try reset the router and configure again..
0
 
Robert EhingerIT specialistAuthor Commented:
I have reset it and then I can access using the original default IP.
0
 
alexbumbaceaCommented:
IP conflict on router's ip?
Wrong subnetmask?
0
 
alexbumbaceaCommented:
Other posibility: Router may be configured in NAT mode, that will make it to ignore DHCP requests from wlan and not sending them further?
0
 
AngloCommented:
Maybe this box just does not have any DHCP helper/forwarding function.  It is just aimed at the home market.  Maybe you should look at some open source firmware.  http://www.dd-wrt.com/phpBB2/viewtopic.php?p=470281&sid=79658ea7dfa1115c32a53a1e7cbf18fb
0
 
Robert EhingerIT specialistAuthor Commented:
I followed fmarshall's instructions and I can access the router with the new IP address but I can not connect to the wireless. With security enabled I first get a message that it can't find a certificate and then eventually get the Limited or no Connectivity message. If I disable security I just get the Limited or no Connectivity message.
0
 
OOsorioCommented:
-Go to Linksys and see if there is an update to the firmware. Apply it if there is one.
- Set the router to default.
- From a PC ping the IP address you plan to use as static. If there is no response then use that IP.
- Configure the LAN portion with no DHCP
- Configure the wilreless
0
 
Fred MarshallPrincipalCommented:
Certificate messages are often related to date/time settings.  Is the router's time set properly?

The router *is* plugged into the LAN (so there is connectivity to the DHCP server), right?
If that's the case then the traffic should traverse the switch.
The only other thing might be a firewall sort of setting in the router.
For example, AP isolation is OFF by default.  It should be OFF.
In the Firewall, turn off everything - we are only trying to use this device as a simple switch.  It may well be that Filter Multicast needs to be DESelected for the DHCP handshaking to work.
A lot depends on the internal architecture (i.e. the software architecture).  If the switch function is well separated from the router and firewall functions then that's one thing.  If not then ... as above.
0
 
Fred MarshallPrincipalCommented:
In Advanced Routing, you may need to set the Operating Mode to "Router" so that traffic doesn't get sent to that "node" ONLY.  This isn't the default and we're sure not using this device as a Gateway!!
0
 
Robert EhingerIT specialistAuthor Commented:
OK, I am sending screen shots of some of the setup pages.

The router is plugged into the LAN
I turned off any firewall settings

Doc1.docx
0
 
Fred MarshallPrincipalCommented:
Looks fine to me.  I don't see the page with Mode selection being Router.
I would turn off the wireless security until this is working without it.
Also,  WEP isn't very secure at all.
0
 
Fred MarshallPrincipalCommented:
If you plug into the LAN side of the router with a laptop (i.e. ethernet) , can you see the rest of the network?  That's a rather essential confirmation.
0
 
Robert EhingerIT specialistAuthor Commented:
If you plug into the LAN side of the router with a laptop (i.e. ethernet) , can you see the rest of the network?

No
0
 
Fred MarshallPrincipalCommented:
Well, that seems odd indeed.  
The laptop has a static IP address and subnet mask that is appropriate for the subnet you're trying to see?
The router has a static IP address and subnet mask on the LAN side that is appropriate for the subnet you're trying to see?  (Actually this isn't necessary but it's convenient).
There's an ethernet cable attached to the LAN side of this router that goes to a switch or the gateway on the LAN?
There's an ethernet cable attached to the laptop that goes to another LAN port on this router?
0
 
Robert EhingerIT specialistAuthor Commented:
The laptop has a static IP address and subnet mask that is appropriate for the subnet you're trying to see? -- No the laptop does not have a static IP

The router has a static IP address and subnet mask on the LAN side that is appropriate for the subnet you're trying to see?  (Actually this isn't necessary but it's convenient). -- The router has a static IP. That is how all of our other routers are set up - DHCP turned of and only used for wireless access.

There's an ethernet cable attached to the LAN side of this router that goes to a switch or the gateway on the LAN? -- Yes

There's an ethernet cable attached to the laptop that goes to another LAN port on this router? -- yes
0
 
Fred MarshallPrincipalCommented:
The first test is to confirm that the switch is connecting things as expected.  So, assign a static IP to the laptop.  Then you should be able to see the network.

We are only using this router as a *switch* and don't want any other things going on if possible.
Then the wireless should connect the same way.

That said, it's odd that the laptop when *wired* doesn't get an address via DHCP.  This suggests that there's some kind of blocking going on in this router at what I'd call the "switch" level.  So, the first test is important to confirm that there's not something else going on - as in a broken router or some such thing.
0
 
Fred MarshallPrincipalCommented:
And, just to make sure, there is *nothing* connected to the Internet/WAN port on the router, right?
0
 
Robert EhingerIT specialistAuthor Commented:
Nothing at all to the WLAN port.
0
 
Fred MarshallPrincipalCommented:
OK.  Good.  Now to assign a static IP to the laptop so we can test the switch function of the router.
0
 
Robert EhingerIT specialistAuthor Commented:
Maybe I did something wrong the first time but I went back as followed these steps again and it now works.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.