Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

How to correct incorrect grammar checking in Word 2007

Posted on 2010-11-30
6
863 Views
Last Modified: 2012-08-14
Without turning off Grammar & Style, or unchecking Hyphenated and compound words, and thus affecting all cases, how can I get Word (or, specifically, Outlook using Word as editor) to accept "trade mark" or "trade marks" without having to always ignore, or change to "trademark"?

I have tried adding trade mark to custom.dic, but that seems to have made no difference, probably because it is the writing style subset of grammar checking that is objecting, not the spell checker.
0
Comment
Question by:SMBelshaw
  • 3
  • 3
6 Comments
 
LVL 10

Accepted Solution

by:
LuckyLuke57 earned 500 total points
ID: 34238342
Hello,

In my version of Word 2007 I can type "Trade mark" as well as "Trademark" and both are accepted.
But, there are a few things you can try as work around.
Go to
- Office Button (colored icon at the left top)
- Word options (beneath that new window)
- Proofing
- Autocorrect options

Here you can uncheck "Automatically use suggestions from the spelling checker" and give it a try.
OR (not both)
Here you can add a new entry "Replace 'trademark' to 'trade mark'"

Luke
0
 

Author Comment

by:SMBelshaw
ID: 34238546
Hi Luke,

Thanks for the speedy reply.

So can I, and I'm struggling to see why some users get "trade mark" with a suggested change to trademark, and some do not. In fact, in my question, I made the assumption that I had found why, thinking the user had Grammar and Style selected, while I had Grammar Only. They have just come back from lunch and, when I checked, also had Grammar Only! There must be some relevant difference in settings somewhere, but I haven't found it yet.

However, to your suggestions - unchecking the Automatically... made no difference that I could see.

Having re-checked it and put in the replacement it seemed to resolve the issue if the term trademark was entered in the document, correctly inserting the space and not reporting the infringement on the final spelling & grammar check at Send. We are left with the problem that the term "trade marks" is in the footer of our HTML email stationery. It seems that the 'incorrect' grammar is ignored if Outlook / Word corrected it as you typed, but not if it pre-existed. It also seems that, if you change the settings and select Recheck Document, Word objects to the ones it self-corrected, since the "I've been checked" flag was reset.

So, so far, your 2nd suggestion has worked around the issue I raised in the question, but not the situation I neglected to mention :-) Any ideas here?

Mark
0
 
LVL 10

Expert Comment

by:LuckyLuke57
ID: 34238794
It is very difficult for me to check it out, because I can't replicate the problem.

Concerning your footer: do the words "trade marks" have adjacent other special characters, like the double quotes in this sentence, or the trade mark icon. If so, this may be the reason why it is not recognized.

Luke
0
Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

 

Author Comment

by:SMBelshaw
ID: 34238890
That's OK Luke - if I knew how to get my installation to misbehave, I'd know how to get the others to work! There is no text around the trade amrk - the quotes being there in my question just to highlight the text. The relevant bit says...

Deaf Alerter and Refuge Alerter are registered trade marks of Deaf Alerter plc.

If I understand how your suggestion works, because Word spotted and replaced the text as it was typed, that section of text is marked as spell-checked. In the same way, if you spell check before Send from Outlook, ignore some errors, then Cancel, those you ignored are not re-presented as spelling errors. They may be errors, but that bit has been checked and the user made a choice. I think it isn't working for our HTML stationery, because that isn't getting typed into the document / email.

If you haven't got any other ideas, the points are safe - you sorted the question I asked!
0
 
LVL 10

Assisted Solution

by:LuckyLuke57
LuckyLuke57 earned 500 total points
ID: 34239219
A last suggestion (before I run for my train): compare, check and double check your settings with that of the user. I once had a macro to print out all the settings of Word (hundreds) so you could compare them line by line.

Don't have that macro anymore :-(

Bye
0
 

Author Closing Comment

by:SMBelshaw
ID: 34239534
Full points for resolving the question I asked. Silly me for not asking the question I should have asked :-)

I'll check the settings but its gonna take a while.
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Follow this checklist to learn more about the 15 things you should never include in an email signature from personal quotes, animated gifs and out-of-date marketing content.
This video shows where to find templates, what they are used for, and how to create and save a custom template using Microsoft Word.
In a previous video Micro Tutorial here at Experts Exchange (http://www.experts-exchange.com/videos/1358/How-to-get-a-free-trial-of-Office-365-with-the-Office-2016-desktop-applications.html), I explained how to get a free, one-month trial of Office …

792 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question