Solved

no outgoing or incoming mail

Posted on 2010-11-30
30
617 Views
Last Modified: 2012-05-10
I tested the mx record and this is what I got:
smtp:69.199.57.100     smtp    
220 sis.onyxarchitects.com Microsoft ESMTP MAIL Service, Version: 6.0.3790.4675 ready at Tue, 30 Nov 2010 04:57:13 -0800


 Not an open relay.
 0 seconds - Good on Connection time
 5.507 seconds - Warning on Transaction time
 OK - 69.199.57.100 resolves to mail.onyxarchitects.com
 OK - Reverse DNS matches SMTP Banner

Session Transcript:
HELO please-read-policy.mxtoolbox.com
250 sis.onyxarchitects.com Hello [64.20.227.133] [47 ms]
MAIL FROM: <supertool@mxtoolbox.com>
250 2.1.0 supertool@mxtoolbox.com....Sender OK [250 ms]
RCPT TO: <test@example.com>
550 5.7.1 Unable to relay for test@example.com [5054 ms]
QUIT
221 2.0.0 sis.onyxarchitects.com Service closing transmission channel [47 ms]

I tested from several locations and they all say it is working but it is not working. Mail is sitting in the queue. The exchange troubleshooting assistant is telling me there is an error of Delivery status notification code 4.3.1   I have not been able to fix it. Any help would be appreciated.  2k3 server sp2 running on win 2k3 enterp. server sp2. Was working fine until the network card went bad and I changed it.
 
0
Comment
Question by:sergenet
  • 16
  • 14
30 Comments
 
LVL 3

Expert Comment

by:msincorp
ID: 34238789
I think you may have to recreate the SMTP virtual server under the exchange adminintrator.

Exchange administrator -> Server -> server name -> protocols -> smtp.  Document the existing settings, delete the virtual server, create a new one.  

This often resolves this type of problem when a new network card is installed.

Hope this helps.

msincorp
0
 
LVL 3

Expert Comment

by:msincorp
ID: 34238850
Wow.. missed that one.

Exchange administrator -> Servers ->connectors -> smtp connector.  Document the existing settings, delete the smtp connector, create a new one.  

One more thing.. Exchange administrator -> Server -> server name -> protocols -> smtp -> smtp virtual server -> advanced -> make sure you have the FQDN set properly (mail.domain.com) and that check dns comes back with a valid domain name.

sorry for the confusion.

msincorp
0
 

Author Comment

by:sergenet
ID: 34239148
let me give it a try.
0
 

Author Comment

by:sergenet
ID: 34239205
There are two smtp virtual servers. One is under Protocols - smtp - default smtp virtual server and the other is under  Connectors - new smtp virtual server. Which one to delete and replace?
0
 
LVL 3

Expert Comment

by:msincorp
ID: 34239378
The one under connectors should do it.

Also, make sure you check for valid FQDN under the protocols -> advanced tab.

msincorp
0
 

Author Comment

by:sergenet
ID: 34239507
I deleted the virtual server under connectors and filled in the data but one are won't let me finish. It says "You must specify a smart host" for the name. I put default smtp virtual server but it won't take it. What is it looking for?
0
 

Author Comment

by:sergenet
ID: 34239574
Under general tab it is asking for a name.
0
 
LVL 3

Expert Comment

by:msincorp
ID: 34239683
ok.. there are 3 required elements in the smtp connector:

1) A name for the connector (can be anythig, so make it meaningful to you)
2) The address space to "serve" usually set to SMTP and an "*" to indicate all domains
3) A local bridgehead server (usually set to your server)

If you are using a smarthost (one of your ISP's mail servers, or a 3rd party mail server) to send your mail, you will have to select that option in the "forward all mail through this connector to the following smart hosts".  This is only necessary if your mail server is NOT sending the mail directly.

Almost there.

msincorp
0
 

Author Comment

by:sergenet
ID: 34239869
Ok I did all that. Do I have to restart anything?
0
 
LVL 3

Expert Comment

by:msincorp
ID: 34239899
under services, find the IIS Admin service and restart all.  
0
 

Author Comment

by:sergenet
ID: 34239929
I restarted information store and still no emails. The queues are growing. Should I do anything to the other virtual server?
0
 
LVL 3

Expert Comment

by:msincorp
ID: 34239952
ok.. right click on the largest queue, and select "force connection".  see what the message is and post it here.

did you verify the FQDN settings under the smtp server -> advanced tab?  starting to sound like a DNS issue.
0
 

Author Comment

by:sergenet
ID: 34240036
fqdn is set at mail.onyxarchitects.com and all messages (54) are under pending submission. Nothing happens when I force a connection. How do I check for dns problem? Thanks for staying with me.
0
 

Author Comment

by:sergenet
ID: 34240056
I do a dns check for the fqdn and it comes back domain name is valid.
0
 
LVL 3

Expert Comment

by:msincorp
ID: 34240093
ok.. silly question, but here goes... when you replaced the network card did you set the IP address to a static IP?  was it the same as the old network card?  also, pay particular attention to the default gateway setting, is it set to your router / firewall?  can you get on the internet from this system?  can you "ping" other devices on the network?

don't worry... we'll get it sorted out.

msincorp
0
What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

 
LVL 3

Expert Comment

by:msincorp
ID: 34240161
Please confirm also that the following services are installed and running:

Microsoft Exchange Information Store
Microsoft Exchange Management
Microsoft Exchange MTA Stacks
Microsoft Exchange Routing Engine
Simple Mail Transfer Protocol (SMTP)

let me know.

msincorp
0
 
LVL 3

Accepted Solution

by:
msincorp earned 500 total points
ID: 34240214
Hows your disk space on this volume?  is it formatted as FAT or NTFS?

I found a microsoft article (http://support.microsoft.com/kb/284204) that describes the error code but it might not be related because it talks about disk space.  Here's the short version:

Numeric Code: 4.3.1

Possible Cause: This code may be caused by resource problem such as a disk full condition. This code may also occur if your Simple Mail Transfer Protocol (SMTP) queue is on a File Allocation Table (FAT) partition and the service has reached a Windows-imposed limit on the number of concurrent file handles that can be opened by the SMTP Service. In this case, instead of receiving a disk full error, you might be receiving an out of memory error.

Troubleshooting: Make sure you have sufficient disk storage, and try to operate your Exchange Transport queues on an NTFS partition.

Take a look at the artice and let me know what you think.

msincorp
0
 

Author Comment

by:sergenet
ID: 34240290
Ok, all the mentioned services are up and running. The ip is static and I can ping the entire network and have internet access. The volume is ntfs and has plenty of room. I saw that article already and it does not apply to me. The only thing I noticed is from a certain site, Network -tools.com, if I do email verification it comes with an error "No domain specified"  this could be a clue.
0
 
LVL 3

Expert Comment

by:msincorp
ID: 34240384
Exchange administrator -> Server -> server name -> protocols -> smtp -> default smtp virtual server -> access -> relay -> check "only list below" (make sure it is the internal IP address of the mail server) -> check "allow all computers......"

then restart the IIS service (take the restart all services option).

msincorp
0
 

Author Comment

by:sergenet
ID: 34240623
Now the queue is empty. I tried to send an internal email and it is just sitting in the outbos folder. I clicked on send/receive but that did not help.
0
 

Author Comment

by:sergenet
ID: 34240700
I was mistaken about the queue. The smtp service had not started and after starting it the queue is back at 68 and my email went out and joined the rest of them (in the queue).
0
 
LVL 3

Expert Comment

by:msincorp
ID: 34240847
can you "delete" the messages in the queue?

also, is there any chance of restarting this server after the messages are removed?

msincorp
0
 

Author Comment

by:sergenet
ID: 34240882
I have no choice. Have been working on this for 14 hours non stop. I will delete the messages and restart the server. I have to let everone know so they get off the server. It will take about 15 min for the server to restart.
0
 
LVL 3

Expert Comment

by:msincorp
ID: 34241127
have you tried the exchange best practices analyzer?  

http://www.microsoft.com/downloads/en/details.aspx?FamilyID=dbab201f-4bee-4943-ac22-e2ddbd258df3&displaylang=en

this will give us some insight.

msincorp
0
 

Author Comment

by:sergenet
ID: 34241302
Restarting did not help, I am running the analizer and troubleshooter. Will post in a few.
0
 

Author Comment

by:sergenet
ID: 34241620
done testing and found not much of any problem. I am attaching screen shots.
analyzer.JPG
best-practice-baseline.JPG
best-practice-health.JPG
0
 
LVL 3

Expert Comment

by:msincorp
ID: 34242854
looks like it could be your swap file (paging file) causing the error.  are you sure about your disk space?  do you have two volumes?  a system volume and a data volume?  could be your system volume is running out of disk space while you have plenty on the data volume.

Let me do some more checking on my lab computer.

msincorp
0
 

Author Comment

by:sergenet
ID: 34251371
The Filter folder on the exchange volume had grown too large and was the cause of the the problem. Deleting some of the older files resolved the issue. Thanks for all the help. You get all the points since you did suggest disk space problems could be causing the mail to fail.
0
 

Author Closing Comment

by:sergenet
ID: 34251385
Good job.
0
 
LVL 3

Expert Comment

by:msincorp
ID: 34251426
Happy to help!!

Have a good one!

msincorp
0

Featured Post

Too many email signature changes to deal with?

Are you constantly being asked to update your organization's email signatures? Do they take up too much of your time? Wouldn't you love to be able to manage all signatures from one central location, easily design them and deploy them quickly to users. Well, you can!

Join & Write a Comment

Resolve DNS query failed errors for Exchange
Exchange server is not supported in any cloud-hosted platform (other than Azure with Azure Premium Storage).
In this video we show how to create a Contact in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Contact ta…
In this video we show how to create a Resource Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: Navigate to the Recipients >> Resources tab.: "Recipients" is our default selection …

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now