• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 782
  • Last Modified:

Server 2008 - One shows 3GB and another shows 4GB Memory

Hello Everyone,

I have two servers, theoretically identical (Not cloned, but built via a standard spec).  They are both Win2K8 32bit.  Both are on VM ESXi 4.1 with exact configurations on the guest machines.  Both have VM tools and again, should be the same configuration.

One server shows 3GB of ram and the other shows 4GB of ram.  I am checking some other things but this is the first time I've seen this happen with the same builds.

Service packs are up to date.  No special memory switches on startup either.

Anything would help.

Thanks!
0
Attenuation
Asked:
Attenuation
  • 3
  • 3
  • 2
  • +2
1 Solution
 
TolomirAdministratorCommented:
Did you assign the same memory to them?
0
 
bgoeringCommented:
Do both have the /PAE switch in the boot.ini?
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
Luciano PatrãoICT Senior Infraestructure  Engineer  Commented:
Hi

With 32bits on Windows Standard the limit is 4Gb

http://msdn.microsoft.com/en-us/library/aa366778.aspx#physical_memory_limits_windows_server_2008

Check this treaht that can help you understand the memory limits and sizes.

http://forums.techarena.in/vista-help/980933.htm

There are many hardware or features that can reduce the memory alocated.

Jail.
0
 
AttenuationAuthor Commented:
I appreciate the quick responses, but as above, there are no memory switches that I put in (nor anyone else) and the memory allocation is the same on both.
0
 
coolsport00Commented:
It is odd that you even see 4GB on 1 of your VMs. I personally can't comment on why you do see 4GB on 1 VM. If you have allocated 4GB for each VM, for your VM to be able to 'see' all the RAM, since it's a 32-bit OS, you have to set the PAE switch.

~coolsport00
0
 
TolomirAdministratorCommented:
as said, please check which amount of RAM you did assign to each virtual machine.
0
 
AttenuationAuthor Commented:
This might be it - DEP getting turned on enables PAE.  Another person had made DEP forced off on the 3GB machine and is enabled on the 4GB machine.

I'm just surprised that shutting off DEP killed the apparent PAE.

Let me change these and I'll see if we're on to something.

0
 
coolsport00Commented:
That is correct; see Enabling PAE section in the MS KB I posted:
http://msdn.microsoft.com/en-us/library/aa366796(VS.85).aspx

~coolsport00
0
 
AttenuationAuthor Commented:
So I guess I shouldn't have overlooked someone else fiddling.  The PAE was off.  DEP was on, which told me that PAE would be on too.  Also, if DEP is turned off, PAE is told to remain unaffected.  I forced PAE on with DEP off, and we're good now.

Sorry I didn't see this sooner.  We restarted the machine this last weekend.

Thanks for the time!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

  • 3
  • 3
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now