Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 858
  • Last Modified:

Windows Small Business Server 2008 Remote Web Workplace

I recently migrated a SBS 2003 server to 2008, they were using Remote Web workplace. The problem I am having to start is that the pictures on the site do not come up. They come up with Red X's, I am leaning in thinking it might be a permissions problem, I am not finding much on the web about it.

I am enabled the service, can get to the link but no pictures come up.  OWA works fine just to let you know.
0
TJacoberger1
Asked:
TJacoberger1
  • 11
  • 10
1 Solution
 
Cris HannaCommented:
Ok...when you say pictures are red X'd is this at the main screen for RWW?
0
 
TJacoberger1Author Commented:
yes the main page for RWW?
0
 
Cris HannaCommented:
Have you run the SBS BPA on the new server?   How much RAM in the new server?  How many NICs?
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
TJacoberger1Author Commented:
I ran the SBS BPA prior to migrating to the new server and all was well. I haven't ran the BPA on the new server. The new server Is SBS 2008 with 8 gigs of RAM, and has 2 on board nics. One is being used the other is disabled.
0
 
Cris HannaCommented:
I would run the BPA on the SBS 2008 box?
I'm assuming the SBS 2003 box is gone?
You may also wish to check DNS on the SBS 2008 box, verify that no entries remain in DNS for the SBS 2003 box
0
 
TJacoberger1Author Commented:
I have nothing for SBS 2003 any where, and the old machine is off. I ran BPA, everything came back fine except for a new things. What am I looking for exactly?
0
 
Cris HannaCommented:
Anything the BPA reports can be a potential issue and should be fixed, regardless of whether it seems pertinent.  

Despite the Red X's...can you click and connect?
0
 
TJacoberger1Author Commented:
Yes the links work, the icons are missing.
0
 
Cris HannaCommented:
In the SBS 2008 Console > Network > Connectivity Tab..then under tasks on the right > Run the Fix My Network task (when no one is logged on)
0
 
TJacoberger1Author Commented:
I see this error in BPA, I searched the error and alot has to do with sharepoint, RWW, OWA and etc. I cannot find a fix though. This might be the problem.

The CNAME resource record for the Connect alias should point to the fully qualified domain name of the computer that is running Windows SBSĀ 2008
0
 
Cris HannaCommented:
The CNAME is record in the Internal DNS server on the SBS 2008  and would be found under the foward lookup zone    so look for a record called connect   and it should point to servername.domainname.local
0
 
TJacoberger1Author Commented:
So if I go to IIS 7 manaager, find the remote site under SBS Web Applications and go to the images section. I click content view and can see all the files that it is using. If I click the logo files that are available and then click browse. The icon picture doesnt come up, I get page cannot be displayed. It should display the icon, I'm guessing.
0
 
Cris HannaCommented:
Yes they should...the IIS side is not my strongest area of SBS.    I'm going to make some inquiries
0
 
Bondy74Commented:
I had a similar issue after a migration and found installing rollup 2 for exchange fixed the issues with RWW. Might be unrelated to your problem but probably worth checking.
0
 
Cris HannaCommented:
Certainly it's important to get SBS 2008 updated with the latest service packs
Windows Server 2008 SP2 should have been included
Exchange Server 2007 SP3 fixes many issues
And Windows Small Business Server 2008 Update Rollup 4
0
 
TJacoberger1Author Commented:
I installed all the updates, I think it is permissions problems. I went into IIS 7, sites, sbs web applications, and then remote. I click on images, and directroy browsing, and then browse https on the right hand side. I get an

HTTP Error 401.2- unauthorized
Your are not authorized to view this page due to invalid authenication headers. I looked up the error and tried a few things I found, but it is still not working, I referenced it to another server I have and they look identical and the other serer works fine.
0
 
TJacoberger1Author Commented:
Anyone have any info, why I am getting this http error above!!! I cannot find much on this..
0
 
Cris HannaCommented:
I've posed this to a private list and waiting for other suggestions that I'll post back if I get them
0
 
TJacoberger1Author Commented:
Awesome, Thank you!
0
 
TJacoberger1Author Commented:
OH MAN!!!! I got it to work!!!!! If you open IIS Manager, click the domain and then go to application Pools. Click on SBS Web Workplace AppPool, on the right hand side under Edit application Pool click advanced settings. In the windows that opens, you will see "Managed Pipeline Mode" it has to be set to Integrated not classic. Mine was set to classic, changed to integrated and Voila!!!!

The website is wroking, except for the actual remote desktop part. I am getting an error message. I will try to resolve that separately. Thank you for your help!!
0
 
Cris HannaCommented:
Just an FYI, One of the lead support engineers from SBS Team says the BPA if updated, should have caught this.

0
 
TJacoberger1Author Commented:
Yes, that is where I found it.. I have been using BPA, like you advised in the beggining. It was on the bottom of BPA, when I changed it. I tried it and worked.. Thank you again....
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 11
  • 10
Tackle projects and never again get stuck behind a technical roadblock.
Join Now