• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1401
  • Last Modified:

Cannot set ipv6 address on Server 2008 R2

I am setting up a test server with Server 2008 R2 Enterprise (Under a Hyper-V
, so this is a virtual machine) I want to set an IPV6 address for the adaptor.

But when I enter a (valid) address, and hit apply, then ok and go back into it.
It just show as back to a staitc address again as if I never entered it.

I think maybe it's a policy or something like that that's stopping it staying.

Anyone seen this before?

0
afurness
Asked:
afurness
  • 4
  • 3
1 Solution
 
IPv6GuyCommented:
What IPv6 address are you setting? Can you paste the exact address in your answer?


0
 
Darius GhassemCommented:
What you do is setup the IPv4 address then this will automaticlly configure the IPv6 IP address
0
 
IPv6GuyCommented:
But you said you entered a valid address and then hit apply. Did you mean that you entered a valid IPv4 address?

IPv6 does allow static IP Addressing, but it sounds like you are asking about tunneling addresses. Can you please clarify which type of address you mean?

0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
afurnessAuthor Commented:
Yes I entered a valid IPV4 address.
I see it automatically has set up a IPV6 address, (Dynamically)
But this test box is a DC and the BPA says the IPV6 address should be static.

I then copied the IPV6 address (extracted via an IPCONFIG /all )
The address is fe80::fd2b:38c:6ebb:1e03

But when I paste that in, it accepts it, but when hitting OK (and restarting as requested) it goes back to a static IP address (and the IPV6 ipaddress is blank when looking at the setup for the adaptor.)
An iipconfig shows it has an ipv6 address though.

0
 
IPv6GuyCommented:
You tried to assign a Link Local address as a Static IPv6 address. This is not allowed by RFC. Each IPv6 enabled interface will automatically generate a Link Local address, and they cannot be assigned statically. If you try, Windows will not accept it, as you saw.

The BPA is wrong. I tried to get this fixed before I left Microsoft, but I wasn't able to get it completed. With IPv6 enabled and a link local address assigned, you are aligned to the best practice and you may safely ignore the comment in the BPA.

The Link Local address is very similar to the APIPA addresses used in IPv4 (169.254.X.X). The Link Local Address is not registered in DNS, and is not used for communications with hosts in other subnets. A Windows DC will function just fine with a static IPv4 address and a link-local IPv6 address assigned.

Does that help?

0
 
afurnessAuthor Commented:
Yes it does thanks.
In server manager it comes up with a warning as well (an exclamation mark) also saying it should be static.
I saw it as an issue as in SBS2008 it is possible to assign a static IP address for IPV6. So I was wondering why I couldn't for server 2008 R2 Enterprise.

So you're saying based on this I can just ignore it?
I would prefer to keep my static IPV4 address though.

0
 
IPv6GuyCommented:
Yes, keep the static IPv4 address - you definitely need that. Ignore the warning for IPv6, though.

SP1 is supposed to remove the warning during DCPROMO and Server Manager.
0
 
afurnessAuthor Commented:
ok thanks fo the advice, will do.
0

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now