Setting up Tomcat

http://localhost:8080/  (Should return tomcat test page)

I am hoping to receive assistance setting up and testing tomcat.  I have completed the the following (hopefully correctly):
Download  
j2sdk-1_4_2_19-windows-i586-p.exe
Java Web Start (I thought this was the tomcat)
apache-tomcat-5.5.31-admin.zip which when unzipped to desk top creates folder called apache-tomcat-5.5.31 (this folder seems similar to a folder found on my C:drive, which the path is as follows)
C:\Program Files\Apache Software Foundation\Tomcat 5.5\webapps\.metadata

please help me help myself.
LVL 3
gazdzidAsked:
Who is Participating?
 
ashesh17Connect With a Mentor Commented:
gazdzid:

Please Install Java 5.0 or later version and set "JAVA_HOME" environment variable with value as base directory of Java installation (e.g. C:\Program Files\Java\jdk1.6.0), also update Path environment variable with ";%JAVA_HOME%\bin". After doing this try to install Tomcat and you will be able to install it successfully.
0
 
Sathish David Kumar NArchitectCommented:
you can set your enviroment variable in where you extract the tomact
0
 
ashesh17Commented:
Please do following and this should solve your problem:

1. Install Java
2. Set "JAVA_HOME" environment variable.
3. Unzip Tomcat release to desired location.
4. Set "CATALINA_HOME" to top level directory of your extracted Tomcat e.g. in your case "C:\Program Files\Apache Software Foundation\Tomcat 5.5".
5. Update "Path" environment variable with ";%JAVA_HOME%\bin;%CATALINA_HOME%\bin" (optional but recommended)
6. Start Tomcat and go to URL http://localhost:8080/ 
0
Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

 
gazdzidAuthor Commented:
ashesh17:

You Wrote:  4. Set "CATALINA_HOME" to top level directory of your extracted Tomcat e.g. in your case "C:\Program Files\Apache Software Foundation\Tomcat 5.5".

My response
This path is already set as stated in you recommendation

You wrote
5. Update "Path" environment variable with ";%JAVA_HOME%\bin;%CATALINA_HOME%\bin" (optional but recommended)

Found below are two variable that have the settings as follows, which should I change?

My "CLASSPATH" Shows:
C:\Program Files\Apache Software Foundation\Tomcat 5.5\server\lib;

My "Path" Shows
c:\oracle\products\9.0.1\bin;C:\Program Files\Oracle\jre\1.3.1\bin;C:\Program Files\Oracle\jre\1.1.8\bin;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;C:\Program Files\QuickTime\QTSystem\;C:\Program Files\Common Files\Roxio Shared\DLLShared\;C:\Program Files\Interactive Intelligence\ICUserApps\;C:\Program Files\Microsoft SQL Server\80\Tools\Binn\
0
 
ashesh17Commented:
gazdzid:

You should update "Path" variable in way as follows:

Windows Start>My Computer>Right Click>Properties>Advanced Tab>Environment Variables Button>Select "Path" variable>Click on Edit button > Append ;%JAVA_HOME%\bin;%CATALINA_HOME%\bin in existing value.
0
 
gazdzidAuthor Commented:
Due to my lack of success prior to your most recent post, I made the decision to uninstall everything and start from scratch:

1st) I tried to install tomcat.
Result
I was provided with a prompt that stated " Please select the path of the J2SE 5.0 or later JRE installed on your system.  Note that if you have 64 bit operating system, you must specify 64 bit jre:"

Question
Is the an installation of a software that needs to take place prior to installing Tomcat?
0
 
Sathish David Kumar NArchitectCommented:
The same think only i mention in my comment !!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.