[Last Call] Learn about multicloud storage options and how to improve your company's cloud strategy. Register Now

x
?
Solved

cannot boot sun sparc 5 with one good disk one bad disk

Posted on 2010-11-30
10
Medium Priority
?
468 Views
Last Modified: 2012-05-10
I have an old sparc 5 with two hard drives in it. one would boot into sun os, and the second into solaris. the machine came with the sun os disk and it sits on the bottom, with the solaris disk above it.

i turned it on today for the first time in years and it won't boot. from the sounds, the bottom sun os hard drive is not coming up (i put them in one at a time to hear when it gave a bad noise).

i need to work in the slaris disk, but when i put that in the machine by itself, in the bottom bay, it still won't boot. we see the message "lookuppn failed. no such file or directory errno 2"

Any suggestions? is the sun os disk needed to boot solaris?
0
Comment
Question by:rich_tanenbaum
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
  • 3
  • +1
10 Comments
 
LVL 80

Expert Comment

by:arnold
ID: 34241477
When you place it in, try to issue boot disk1 or boot disk0 depending on which you have it in.
The openboot is configured to boot of the first disk which is no longer functional.

You may need to look at the nvram to see which it is trying to boot first.  The other option is to get the Solaris install disks and reset/update the openboot configuration to point to the correct item.
use probe-scsi to see which scsi ID gets assigned.
Do not rember if the lower was scsi 0 and the upper was id 1 or whether the lower was 1 and the upper was 3.

at the ok prompt:
boot disk1 or boot disk0 should do the trick.

Are you using Solaris 8 I think this is the last version that is supported on the sparc 5.?


0
 
LVL 16

Expert Comment

by:Joseph Gan
ID: 34242340
Did you get ok promb?

I remember for those old machines, boot command was "b" instead of "boot".
0
 
LVL 80

Expert Comment

by:arnold
ID: 34242591
The issue the person likely has is that the openboot mechanism tries to load from the wrong disk, switching disks does not help since the Solaris path to boot the system differs from the SUNOS presumably pre 5.7
You should get an error during boot that a certain path can not be located.
0
[Video] Oticon Case Study

Open office environments can create the dynamics for innovation, but they also bring some challenges. With over 1,000 employees in an open office, Oticon needed a solution that would preserve the environment while mitigating disruptive background noises.

Watch how they did it.

 

Author Comment

by:rich_tanenbaum
ID: 34243298
I put just the good disk in, in the upper bay. then i tried boot disk0 then boot disk1 etc. to boot disk4. nothing works.

same error as before, every time. nothing about a path.

not sure of which solaris it is, as it is quite old.
0
 
LVL 15

Expert Comment

by:roylong
ID: 34243484
Get your install CDs out and reinstall?
0
 
LVL 16

Expert Comment

by:Joseph Gan
ID: 34243675
First to try when power on the system, using STOP-A to get to the ok prompt, then run

ok>prob-scsi-all

That should show you the internal disks aliases. If this doesn't work, go to the link below:

docs.sun.com/app/docs/doc/801-6396-11

The Sparcstation5 service manual contains some hardware testing commands as well as trouble shooting procedures.
0
 
LVL 80

Expert Comment

by:arnold
ID: 34243792
You do not need to reinstall, you need to update the openboot to reference the correct device.

I think the primary disk must be in the lower bay.  The SCSI ID assigned by the bay so make sure that you do not have SCSI ID jumpers on the drive itself.

You can still get a solaris 8 disk if you need it from Oracle for $95.

There is the more complex @boot string
i.e. deals with bus/pci/to a point where you point the boot to the correct parition to boot the system i.e. /platform/sun4m/kernel or something like that.

Using the Install media you can repair the boot verus reinstalling.

You can also use the install cd to gain access to the data.  I.e. the step before the final instruction to install, exit and it should drop you into a shell prompt where you can use mount to mount the partitions from the drive to see wat is there as well as to run tests on the drive.
0
 

Author Comment

by:rich_tanenbaum
ID: 34252439
I neglected to mention I tried prob-scsi, and it told me the good disk was dsk1. But it would still not boot off of it. There are no jumpers on either drive.
0
 
LVL 16

Accepted Solution

by:
Joseph Gan earned 2000 total points
ID: 34252574
Please try:

ok set-defaults
ok setenv auto-boot? false
ok setenv diag-switch? false
ok reset

ok probe-scsi

Use the disk to boot off.
0
 

Author Comment

by:rich_tanenbaum
ID: 34253266
That's close to what worked. On another forum (sunrescue) we were at the same monebt advised to try:

ok set-defaults boot-file

and it worked.

Thanks!
0

Featured Post

Q2 2017 - Latest Malware & Internet Attacks

WatchGuard’s Threat Lab is a group of dedicated threat researchers committed to helping you stay ahead of the bad guys by providing in-depth analysis of the top security threats to your network.  Check out our latest Quarterly Internet Security Report!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Windows 10 is here and for most admins this means frustration and challenges getting that first working Windows 10 image. As in my previous sysprep articles, I've put together a simple help guide to get you through this process. The aim is to achiev…
What do we know about Legacy Video Conferencing? - Full IT support needed! - Complicated systems at outrageous prices! - Intense training required! Highfive believes we need to embrace a new alternative.
This is used to tweak the memory usage for your computer, it is used for servers more so than workstations but just be careful editing registry settings as it may cause irreversible results. I hold no responsibility for anything you do to the regist…
Hi friends,  in this video  I'll show you how new windows 10 user can learn the using of windows 10. Thank you.

650 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question