Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

My joomla website shows a blank page for the index page

Posted on 2010-11-30
12
Medium Priority
?
1,818 Views
Last Modified: 2012-05-10
Hi,
I have just moved my joomla site to this domain here
http://familysupport.org.au/index.php

it was sitting here http://familysupport.org.au/newsite and was showing fine

However I get a blank page now when I got to the new site...

I have turned on the error reporting and tried adding this line to my configuration file
ini_set( 'display_errors', true ); error_reporting( E_ALL );

but I can't see the error.

Can someone help?
0
Comment
Question by:Amanda Watson
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 3
  • 2
  • +1
12 Comments
 
LVL 9

Expert Comment

by:Rowby Goren
ID: 34242067
HI

From here it looks like you fixed the problem?

I'm seeing your home page fine!


Rowby
0
 
LVL 11

Author Comment

by:Amanda Watson
ID: 34242355
No its this link here
http://familysupport.org.au/index.php

that I want to see as the homepage

I have their old index.html page showing for now
0
 
LVL 9

Expert Comment

by:Rowby Goren
ID: 34242396
I think you need to remove http://familysupport.org.au/index.html (the index.html) file and then you will see your index.php page.

Apparently your hosting company will show an index.html page if it is there, as the default setting.

So try deleting index.html or renaming it to indexold.html and then you wlll see the index.php page.

At least, if I am understanding your question correctly.

Rowby
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
LVL 6

Accepted Solution

by:
V4nP3rs13 earned 1600 total points
ID: 34242401
FIRST: Have you set a default template for your website ?? Try to change default template in joomla administration.

SECOND: try to reupload index.php file using some other FTP client (this is a recent bug that comes to users of joomla)

THIRD: try to update your joomla to the newest version, if you have some old version of joomla 1.5
0
 
LVL 6

Expert Comment

by:V4nP3rs13
ID: 34242443
FOURTH: try changing your site path inside configuration.php file

for example:
home/dir_name/public_html/
should be
/home/dir_name/public_html/
0
 
LVL 11

Author Comment

by:Amanda Watson
ID: 34242960
ok, firstly, I obviously had the index.html file removed but the index. php doesn't show so I put it back until I resolve the issue..you will see the index.php not showing is the problem because when you use the direct link to it its blank.

The config file has /home at described

my joomla is the latest version 1.5.20

I have ftp the index.php again still no joy

BUT

When I went to check my template situation I see this error


Warning: Invalid argument supplied for foreach() in /home/familysu/public_html/administrator/components/com_templates/helpers/template.php on line 62

hmmm what is the problem here?
0
 
LVL 11

Author Comment

by:Amanda Watson
ID: 34242976
There is also the error

JFolder::folder: Path is not a folder
0
 
LVL 6

Expert Comment

by:V4nP3rs13
ID: 34243012
open up configuration.php file and make these changes:

        var $ftp_enable = '1';
        var $ftp_host = 'familysupport.org.au';
        var $ftp_port = '21';
        var $ftp_user = 'YOUR FTP USERNAME HERE';
        var $ftp_pass = 'YOUR FTP PASSWORD HERE';
        var $ftp_root = '/home/familysu/public_html';

Open in new window


just change these two data-s
0
 
LVL 26

Expert Comment

by:lenamtl
ID: 34247554
Hi

for JFolder::folder: Path is not a folder ...then it suppose to display a path an a folder after this error
check which directory is the culprit
let say it is images folder then check your images folder chmod it to 775

For the index.php

check in the code in your template, this appear you put something in a table and this should not be in a table, maybe this is a menu

Which template are you using?

etra info for this error
http://php.syntaxerrors.info/index.php?title=Invalid_argument_supplied_for_foreach
0
 
LVL 26

Assisted Solution

by:lenamtl
lenamtl earned 400 total points
ID: 34247569
Also check if you have transfer all files maybe some pages are missing and check all directory chmod.
0
 
LVL 11

Author Comment

by:Amanda Watson
ID: 34251211
Ok, the server ended up moving the root folder to be inside the newsite folder which was working so I can no longer test this...however because of the template error its pretty clear that was the problem and yesterday when I was trying to upload all the files again the server kept shutting down (useless server, honestly they can waste a programmers time in a MAJOR way!0

So thanks everyone!
0
 
LVL 11

Author Closing Comment

by:Amanda Watson
ID: 34251220
thanks
0

Featured Post

Tech or Treat!

Submit an article about your scariest tech experience—and the solution—and you’ll be automatically entered to win one of 4 fantastic tech gadgets.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Since pre-biblical times, humans have sought ways to keep secrets, and share the secrets selectively.  This article explores the ways PHP can be used to hide and encrypt information.
Introduction This article is intended for those who are new to PHP error handling (https://www.experts-exchange.com/articles/11769/And-by-the-way-I-am-New-to-PHP.html).  It addresses one of the most common problems that plague beginning PHP develop…
The viewer will learn how to look for a specific file type in a local or remote server directory using PHP.
The viewer will learn how to create and use a small PHP class to apply a watermark to an image. This video shows the viewer the setup for the PHP watermark as well as important coding language. Continue to Part 2 to learn the core code used in creat…
Suggested Courses

604 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question