• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1101
  • Last Modified:

Lost of internet connectivity

At a client site, Was called in because one user lost connectivity to the internet but not the LAN. I had him open up the TCP/IP properties and had him change the IP address from 60 to 49. After clicking OK, it reconnected to the internet.

We have a windows 2003 server (1) that is a file server, DNS server, print server, Domain controller (active directory). We also have a SonicWall TZ 200 router which is setup to provide DHCP. It was configured as of last week with .10-.15 as the IP range to give out. BUT all the PCs and the one server had static IPs in the .55-.60 range. I know that the router has mappings to allow someone on the outside to RDP with an IP address and a port number. the port number is configured in the SonicWall to correspond to a specific users PC so that they can remote in to their PCs.

the network has been experiencing of late, say the last few months connectivity problems. where they have to either reboot the server and/or router.

What could be misconfigured? There has to be a misconfiguration either in the server's configuration and/or the routers.

The server is also showing the following events in the event view for the DNS:
2, 6702, 4004, 4015.

Thanks in advance for the assistance.
0
RSchierer
Asked:
RSchierer
  • 5
  • 4
  • 4
2 Solutions
 
Darius GhassemCommented:
The Server needs to be pointing to itself for DNS only it should not be pointing to the router at all. The clients should be pointing to the server only for DNS.

Post ipconfig /all for server and client.

Make sure Server has updated DNS Forwarders
0
 
RSchiererAuthor Commented:
PC:
IP
192.168.0.57
255.255.255.0
192.168.0.1
DNS
192.168.0.2

SERVER:
IP
192.168.0.2
255.255.255.0
192.168.0.1
DNS
192.168.0.2

Server is showing that it points to itself for the DNS.
The router is .1
I have changed the IP settings on the PCs from their present .55-.60 range to another unused number in the range on the router which is .10-.60 sometimes I can connect to the itnernet and sometimes I can't. No rthyme, no reason.

I have rebooted the PCs, but not the server or the router (at least not today). I also cannot get in remotely from my shop using RDP.

When I first looked at the IP range in the router that DHCP was giving out, I also noticed that the PCs had static IPs. Is there a setting in the SonicWall that converts the 192.168.0.55 ip address to 192.168.0.15 address?

I am on site and await your swift answer !! thanks for the fast reply!
0
 
Darius GhassemCommented:
I don't know much about Sonic Firewall. Did you check your DNS Forwarders?
0
 The Evil-ution of Network Security Threats

What are the hacks that forever changed the security industry? To answer that question, we created an exciting new eBook that takes you on a trip through hacking history. It explores the top hacks from the 80s to 2010s, why they mattered, and how the security industry responded.

 
digitapCommented:
have you set any static IP settings on the sonicwall?

when did the connectivity issues start?  are you on a DSL or cable modem connection?  have you updated the firmware on the sonicwall?  can you see anything in the sonicwall logs that might indicate an issue with settings in the sonicwall?  you can post anything here within the logs for us to look at with you.
0
 
RSchiererAuthor Commented:
I have no idea what DNS Forwarders are.

static IP settings on the sonicwall: yes LAN and WAN have static IP settings. One thing to note here, let's say that the WAN IP address is 10.10.35.25 (fictitious of course). The notes that the last tech left show that when a user wants to connect from home, he is to open RDP and type 10.10.32.26:8891. There are settings in the Sonicwall showing that the users static IP address 192.168.0.55 is mapped to the port # 8891. But the DHSP information on the SonicWall is configured to put out 192.168.0.10-15 addresses.

We are using cable modems for internet, fax and phones.

I have not updated the firmware. I have only been with this client a week.

Logs are not configured on the SonicWall. I would like to know how to do that so I can get some insight into what is going on too!

thanks in advance.
0
 
Darius GhassemCommented:
DNS Forwarders go to your DNS Console right-click your DNS go to properties you will see Forwarders you need to add the DNS servers from your ISP or use these well knowns 4.2.2.2 and 4.2.2.1.

If you are port forwarding in the firewall to use RDP then the clients must have static IP addresses with the same IP address constantly. If you don't do this then RDP will not work.

There are other softwares that are free like logmein that give access to a computer through port 80 which can be used on dynamic IP addresses
0
 
digitapCommented:
there is default logging on the sonicwall.  login to the sonicwall and on the left go to Log > View.  

so we have a better understanding of what you are working with, what firmware are you on and are you running the enhanced or standard version of the OS.  you can find this information by logging onto the sonicwall and going to System > Status.  it will be on the right hand side.

since we don't know how long they have been experiencing these issues, there's no way to tell if it's the cable modem connection or not.  however, it's a known issue with the sonicwall appliances and cable modem connections to incur connectivity issues if the MTU setting on the sonicwall WAN interface is not configured properly.  i have a EE article i wrote that walks through calculating and configuring the proper MTU on the WAN interface of a sonicwall.  the link is below.

http://www.experts-exchange.com/viewArticle.jsp?articleID=3110

regarding the remote RDP stuff, there are several options here to make that work.  either the sonicwall is handing out a static IP based on the workstation MAC address or the workstation is configured with a static IP that matches the NAT rule on the sonicwall or remote RDP hasn't worked for a while.  if there is a static assignment coming from the sonicwall based on a MAC, there should be an entry in the list along with the DHCP scope assigned to the LAN zone.
0
 
RSchiererAuthor Commented:
All great stuff guys! I will have to get back to you tomorrow when I am back at the client site, unless I can gain access via RDP, which has worked for them in the past off and on. The same with accessing the internet from their PCs. One day no problems and the next... Any and all pointers, best practices, etc for the sonic wall would be greatly appreciated. This way I will be able to bone up tonight and hit the ground running tomorrow.

I really appreciate both your efforts. Especially digitap. Your knowledge is obviously first hand from working on these things. Not to take anything away from dariusg. I know that I will definitely come away from this project a much more knowledgeable person. And I guess that is what it is all about, stretching ourselves and working together to get the desired end result!
0
 
Darius GhassemCommented:
Sonic firewall is not my thing but I think you are looking at a couple of basic firewall configurations like your port forwarding is not setup properly anymore since the clients are now getting different IP addresses then what is configured in the port forwarding in the firewall to use RDP.

I do remember an issue I worked on before that the MTU settings like digitap states was the cause of the dropping of the internet when using Sonic Firewalls but you are looking at a couple of issues currently.
0
 
RSchiererAuthor Commented:
I do not know how much experience the previous support company had with SonicWall appliances. He just told the client how great it was. The client tells me that ever since it was installed their were interminent issues with internet connectivity. I wish I had remote access so that I could give you both more information. We might just be able to work this thing out tonight! and I could sleep better.
0
 
digitapCommented:
dariusq's memory is correct about the MTU.  i remember seeing this for the first time and it was only with cable internet.  ended up being the size of the MTU.  anyway,  we can start there first.

regarding the remote RDP, once you get the ports configured, the workstations need to keep the IP address.

once you can login to the sonicwall again, let us know if it's enhanced or standard OS.  we can help you get the remote RDP squared away if we know that.
0
 
RSchiererAuthor Commented:
I am still working on this project. I believe that the problem might be that the server was setup with a single label domain name. I have checked the event logs and found multiple entries concerning DNS. I wanted to award the points as you have both been very helpful.

thanks and happy holidays!
0
 
digitapCommented:
you're welcome and thanks for the points!  let us know if you need any other help with this issue.
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

  • 5
  • 4
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now