Avatar of chrvon
chrvonFlag for United States of America asked on

routing to phone and computer on same port Cisco 3560G

I am new to vlan setups:
We have vlans setup on Cisco Switches/ with 3560 at top all vlans replicated to all switches. Everything is working fine (wireless vlan7, computer vlan1, VOIP vlan 8). I want to setup specific ports to receive both vlan1 and vlan8 traffic but can't seem to get it to work properly. For a port that will have an IP phone and a computer on it I am setting port up like this:
  interface GigabitEthernet0/20
     switchport trunk encapsulation dot1q
     switchport trunk allowed vlan 1,8
     switchport mode trunk

This doesn't seem to work. Can't ping ip address of phone or communicate with it.

When I set port up as just vlan 8 it works with no problem like this:

switchport access vlan 8
switchport mode access

I however need the port to work with vlan1 and vlan 8 so I can hook computer and phone to same port.  Any suggestions or help would be appreciated.
RoutersSwitches / Hubs

Avatar of undefined
Last Comment
chrvon

8/22/2022 - Mon
Don Johnston

Normally in this situation, the voice traffic would be tagged, and the data traffic would be untagged.

It sounds like your phone is not tagging the traffic.

What kind of phones are you using?
ASKER
chrvon

Aastra Ericksen which I believe are tagging traffic but i will check
ASKER CERTIFIED SOLUTION
rochey2009

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
See how we're fighting big data
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
Ernie Beek

There are ways to define a data and a voice vlan, dunno if this works on 3560 but you might want to look into it.
Configuration is something like this

 switchport access vlan 1
 switchport mode access
 switchport voice vlan 8
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape 10 0 0 0
 mls qos trust cos
 auto qos voip trust
 spanning-tree portfast

This is the best money I have ever spent. I cannot not tell you how many times these folks have saved my bacon. I learn so much from the contributors.
rwheeler23
jjmartineziii

+1 for

switchport access vlan 1
switchport access vlan 8

BTW, you shouldn't use vlan 1!
jjmartineziii

woops,

switchport access vlan 1
switchport voice vlan 8

is what i meant*
ASKER
chrvon

This works, but seems to slow computer down to a crawl.
interface GigabitEthernet0/20
     switchport mode access
     switchport access vlan 1
     switchport voice vlan 8
     spanning-tree portfast
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
Don Johnston

Which model Aastra phone do you have?
ASKER
chrvon

Various, but we are testing with an i7434ip
Ernie Beek

Phones are 100mb?
And computers (were) 1gb.........
All of life is about relationships, and EE has made a viirtual community a real community. It lifts everyone's boat
William Peck
ASKER
chrvon

Yes but speed is well below what I normally see on 100mb, slower than 10 mb.
rochey2009

what speed and duplex is the  phone negotiating with the switchport and the PC?
ASKER
chrvon

I will double check. It is set for auto on port. Will continue test as soon as I get access again to test phone. phone system is being setup now also.
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
ASKER
chrvon

I changed to this setting and it is working now. QOS was adjusted on the phone system and is working great.