Avatar of Lafflin
Lafflin asked on

Cisco switch dropping ICMP

I have a switch stack which seems to be dropping ICMP.
Not all, but nearly 10% I would say.
I need to figure out why it's dropping so many packets and explain it to my CTO who feels that there's a networking issue.
My instinct tells me that all is well and that the issue isn't actually with the switches.....but 10% is a bit much.
Also, I have been having some other isssues such as people being disconnected from files on shares etc...
But my focus is on proving / disproving the idea that the switches are having issues.
How would I go about troubleshoooting ICMP packet Loss?

The switch isn't throwing out any errors that I can see. I am getting something in my logs which I cannot figure out though:
%SYS-3-LOGGER_DROPPED: System dropped 4860 console debug messages
I'm hoping that's normal?

Switches / HubsCiscoNetworking Hardware-Other

Avatar of undefined
Last Comment
Lafflin

8/22/2022 - Mon
gcl_hk

Clearly, 10% ping drop is unacceptable on a healthy LAN environment.

That error massage seems the logging buffer configured is not enough to store the logging, but which did not cause the ping drop issue.

I think you need to describe more of your network architecture.
ASKER
Lafflin

Well, the network consists of a stack of switches, behind a Sonicwall gateway for data vlan traffic, and also on the network is a router which is the gateway for my voice lan. 2 VLANs, voice and data. Network has been up for a year plus without issue.
The ping dropping is between two hosts connected on the lan. I can't see how the culprit can't be the switches, but I'm seeing no errors on them. I am going to bounce the switches tonight to see if that helps any.
kupiszew

Lafflin,

If you have eliminated the router/gateway and other issues, it is either the physical infrastructure, the computers NICs or the switches.  Since two hosts, which I'm assuming are on the same LAN and VLAN are dropping 10%, that is certainly excessive.  

I'm assuming these are managed switches?  If so, look at the individual interfaces of the PCs that are dropping packets.  We have an issue where certain new systems don't auto up properly in terms of speed and duplex with our older switches.  When we force 100/Full - no more packet drops.  It is only noticeable when they are downloading large files - even locally.  But it is clear when you look at the switch that the ports are receiving CRC errors.  This may have nothing to do with your issue, but worth a quick look nonetheless.
Experts Exchange has (a) saved my job multiple times, (b) saved me hours, days, and even weeks of work, and often (c) makes me look like a superhero! This place is MAGIC!
Walt Forbes
ASKER CERTIFIED SOLUTION
Lafflin

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
See how we're fighting big data
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
ASKER
Lafflin

I figured it out...kinda