Link to home
Create AccountLog in
Avatar of williamstechnologygroup
williamstechnologygroupFlag for United States of America

asked on

problems accessing tsweb in server 2008

I have a Windows 2008 Server R2 setup as a terminal server. I have configured RDS on it as well as the TSWEB option. I followed the following instructions:
http://technet.microsoft.com/en-us/library/cc730673(WS.10).aspx
when I try to access the main webpage for application presentation
 http://server_name/ts  or even http://localhost/ts directly from the TS
I get the following error
Error Summary
HTTP Error 404.0 - Not Found
The resource you are looking for has been removed, had its name changed, or is temporarily unavailable. Detailed Error Information
Module IIS Web Core
Notification MapRequestHandler
Handler StaticFile
Error Code 0x80070002
Requested URL http://localhost:80/ts 
Physical Path C:\inetpub\wwwroot\ts
Logon Method Anonymous
Logon User Anonymous
 Most likely causes:
•The directory or file specified does not exist on the Web server.
•The URL contains a typographical error.
•A custom filter or module, such as URLScan, restricts access to the file.
 Things you can try:
•Create the content on the Web server.
•Review the browser URL.
•Create a tracing rule to track failed requests for this HTTP status code and see which module is calling SetStatus. For more information about creating a tracing rule for failed requests, click here.
Avatar of Chev_PCN
Chev_PCN
Flag of South Africa image

A few suggestions:
Check IIS - verify the authentication method.
Verify permissions on the website.
Browse the website directly from within IIS.

Also
Bring your server up to the latest patch level.
Verify your TS licensing.
Check your group policy - unlikely, but there may be something blocking the access there.
Try this ,  enable the ActiveX control

   1.       Connect to the TS Web Access site, and then enter your logon credentials.
   2.       Do either of the following, depending on the version of Internet Explorer that you are running.
          * If you are using Internet Explorer 7, on the Tools menu, point to Manage Add-ons, and then click Enable or Disable Add-ons.
          * If you are using Internet Explorer 6, on the Tools menu, click Manage Add-ons.

      The Manage Add-ons dialog box appears. Make sure that the Show list is set to Add-ons currently loaded in Internet Explorer.
   3.       Under Disabled, click either Microsoft Terminal Services Client Control (redist) or Microsoft RDP Client Control (redist)--whichever is listed.
   4.        Under Settings, click Enable. (If you are running Internet Explorer 6, click OK in response to the message saying that you may need to restart Internet Explorer for the changes to take effect.)
      Note       If the ActiveX control is listed two times, enable both instances.
   5.       Click OK to close the Manage Add-ons dialog box. (If you are running Internet Explorer 7, click OK in response to the message saying that you may need to restart Internet Explorer for the changes to take effect.)
ASKER CERTIFIED SOLUTION
Avatar of williamstechnologygroup
williamstechnologygroup
Flag of United States of America image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Avatar of williamstechnologygroup

ASKER

I figured out what was wrong, I was looking at documentation from Server 2008, not Server 2008R2.
apparently there is a huge difference in the R2 version. The correct path to the rd web interface is:
https://servername/rdweb   NOT /TS