Link to home
Create AccountLog in
Avatar of chrisalvin2005
chrisalvin2005

asked on

can't connect internet

I have LAN connection at my home PC and as i am writing this question i am on the internet.
when my friends come my home all they have to do is connect my LAN cable to their laptop to use internet.

I got another laptop a few days ago with that one i can't connect to internet. I did diagnose Connection Test (Network Diagnostics for Windows XP)

Result message said  "This machine does not have any installed network adapters"

When i go to System Properties-Hardware-Device manager-Network Adapters i see there is a 1394 Network Adapter and it is working.

Further more, when i got this laptop (it is a used one) i used Ubuntu on thumb drive because at that time it did not have a hard drive but was able to use internet without any problem. If this laptop does not have network adapter, how i could used internet then?
I did not install Ubuntu just used from thumb drive. I do not use Ubuntu anymore.

Then i bought hard drive and installed today windows XP without any problem but now i can't connect internet

At Network Connections, when i click on LAN connection 1394 Net Adapter i can see on the left details section it says: Connected, Speed 400mb, Firewalled.

i think this is a simple set up problem that happened after installing XP pro.
can anyone please help me?

Thanks,
Chris
xpnetdiag.xml
Avatar of Rahul Agarwal
Rahul Agarwal
Flag of India image

Hi Buddy,
              The 1394 Network Adapter you are mentioning is not used for standard LAN connection its used for Fire-wire connection. May be in Ubuntu  the LAN card driver is not installed properly thats why you are not able to connect with internet.
Avatar of chrisalvin2005
chrisalvin2005

ASKER

I am not using Ubuntu. I am using XP pro.
do you mean XP pro LAN card driver is not installed properly?
how i can install it properly?
Thanks
What your 1394 adapter is

http://www.smallbusinesscomputing.com/webmaster/article.php/3675621/Firewire-Facts-Whats-a-1394-Network-Connection.htm

What make and model is your laptop?  You may not have the correct drivers installed.
Search for the manufacturer website for the latest drivers of network card with correct model no or you  may got the correct network card drivers from the reseller where you bought the laptop.
dbrunton,

My adapter is:
Device Type: Network Adapters
Manufacturer: Microsoft
Location: on Texas Instruments OHCI Compliant IEEE 1

Driver Date: 7/1/2001
Driver Version: 5.1.2535.0

Driver File Details: C:\WINDOWS\system32\DRIVERS\nic1394.sys
Provider: Microsoft Corporation
File Version: 5.1.2600.5512 (xpsp.080413-0852)

Device Instance ID: V1394\NIC1394\D143E2FB80DA0

My laptop is Toshiba Satellite
A105-S4104
Model No PSAA8U-06U02K
Genuine Intel CPU
T2400 @1.83GHz
987MHz, 0.99 GB of RAM

Please write your responses in plain English as much as stay away from technical terms possible.

Thanks,
chris

I thought that link would take you directly to the network driver, but it doesn't. Select your operating system and LAN. I would try the Intel driver first. Be sure to reboot your computer after installing the driver.
It sounds like you need to install a LAN driver for your network chip. To identifu the driverless chip, do the following:

Start-Programs-Accessories-System Tools-System Information. Click on "components" and highlight "problem devices". Any hardware device with a driver problem will be listed here. Make a note of the PNP Device ID line of the entry. It will contain a Vendor number and a Device number (VEN. . . . DEV. . . .)
both four digits long.
Look up those numbers here:

http://www.pcidatabase.com/index.php

This will tell you the manufacturer and the chip number.  First try the manufacturer's website.  If no joy there, try a driver database like Driverguide:

http://www.driverguide.com/


These hardware diagnostics are free:

Belarc:
http://www.belarc.com/free_download.html
Siw:
http://www.gtopala.com/siw-download.html
Speccy:
http://www.piriform.com/speccy/download

Does the wireless LAN work on your laptop?
Go here

http://www.csd.toshiba.com/cgi-bin/tais/support/jsp/modelContent.jsp?ct=DL&os=&category=&moid=1364125&rpn=PSAA8U&modelFilter=A105-S4104&selCategory=2756709&selFamily=1073768663

There are five pages of drivers.

On page 2 install the Intel chipset drivers.

Now for the NIC drivers.  There are LAN drivers on Pages 1, 3, 4.  Try each of those and see which one works.
phototropic,

Wireless LAN used to work when i was experimenting Ubuntu with thump drive, not anymore. Tell the truth i am not sure how to use wireless LAN other than pushing on/off button. It is on now but when i click on internet explorer message says page can't be displayed.

I tried Start-Programs-Accessories-System Tools-System Information but it does not open. is it normal not to open?

is there any other way i can get System Information?

dbrunton,

is this the file to download http://www.csd.toshiba.com/cgi-bin/tais/support/jsp/modelContent.jsp?ct=DL&os=&category=&moid=1364125&rpn=PSAA8U&modelFilter=A105-S4104&selCategory=2756709&selFamily=1073768663

Thanks,
chris
dbrunton,

i did that.
what is next i should do?

thank you for your time and help.
chris
After you've installed the chipset drivers work you way through the NIC drivers listed above and see if you get a new NIC driver.

Unsure if you've got Wireless or standard NIC connection.  You might have both.
dbrunton,

after i installed

http://cdgenp01.csd.toshiba.com/content/support/downloads/intel_wireless_105159_os2006207a.exe 

my wireless activated. But i can't connect because i do not have wireless account. However, i can see people around my home with their wireless connections.

I installed all the other files but still can't connect internet.

i do not know what to do?

chris



See http://cdgenp01.csd.toshiba.com/content/product/pdf_files/detailed_specs/satellite_A105-S4104.pdf

You should also have a standard Intel Pro 100 connection as well.

Check you have tried that first NIC driver in the link above and check your Device Manager under Network Adapters and see what is there and report back.
I went to toshiba site found this for the A105-S4104
This is copied from site [Why does Toshiba offer two different Windows 7 install helper programs?
Toshiba laptops have features and functionality that require drivers and utilities that are available only from Toshiba.  To maximize functionality of your laptop under Windows 7, it is important to install Toshiba-provided software after your Windows 7 installation]
Here is the link for the support site for the laptop
http://www.csd.toshiba.com/cgi-bin/tais/support/jsp/modelContent.jsp?ct=SB&os=&category=&moid=1364125&rpn=PSAA8U&modelFilter=A105-S4104&selCategory=2756709&selFamily=1073768663
I do not have Windows 7. I have only XP pro. should i need to download?

After the installation now i can see i have Intel PRO Wireless 3945ABG Network Connection.
Please excuse the previous post.
You need a wireless access point (ROUTER)  to broadcast to and from the internet from your laptop using your wireless adapter.  Do you have that?
According to the specs for the laptop you have a " Intel PRO/100 VE Network Connection - 10/100 Base-TX Ethernet" which is a hardwire connection...can you see in device manager?
•thanks
Does Device Manager show a network adapter with an exclamation mark next to it?
If so, Right click on the device icon, click Properties-Details-Device Instance ID. Post the VEN_ #### and DEV_ #### numbers here.
If Device Manager just shows the 1394 Network Adapter and the wireless adapter, then the hardware for your ethernet port may have failed.

Did you try running any of the system diagnostics I posted above? Speccy will give a list of installed hardware.  See if your network adapter is listed....
Sorry guys, i am busy at work.
My problem is still same. I can't connect to internet with land line.
I run SIW (system information for windows) system diagnostics

I am attaching its results for network adapters, please check.

I also run Speccy its results are also attached

Someone ask about information for my network adapter. That is as follows.

My network adapter is:

Device Type: Network Adapters
Manufacturer: Microsoft
Location: on Texas Instruments OHCI Compliant IEEE 1

Driver Date: 7/1/2001
Driver Version: 5.1.2535.0

Driver File Details: C:\WINDOWS\system32\DRIVERS\nic1394.sys
Provider: Microsoft Corporation
File Version: 5.1.2600.5512 (xpsp.080413-0852)

Device Instance ID: V1394\NIC1394\D143E2FB80DA0

My laptop is Toshiba Satellite
A105-S4104
Model No PSAA8U-06U02K
Genuine Intel CPU
T2400 @1.83GHz
987MHz, 0.99 GB of RAM

Thanks all for your help.
Network-Adapters.txt
Speccy-System-Check.txt
Try installing the motherboard chipset drivers.

This one first http://cdgenp01.csd.toshiba.com/content/support/downloads/ta7chipsetx.exe

This one second http://cdgenp01.csd.toshiba.com/content/support/downloads/ta7videoix.exe

See what that does.

Your LAN driver is here (as posted by RonStack: above):

http://www.csd.toshiba.com/cgi-bin/tais/support/jsp/modelContent.jsp?ct=SB&os=&category=&moid=1364125&rpn=PSAA8U&modelFilter=&selCategory=2756709&selFamily=1073768663

However, neither SiW nor Speccy can see an ethernet adapter.  They both see your 1394 Net Adapter and your Wireless adapter (Intel(R) PRO/Wireless 3945ABG Network Connection), but that's it.

Is your LAN port enabled in the BIOS?

dbrunton,

i installed first one and re-started computer.
then installed second one and re-started computer.
Nothing changed other than icons on my desktop became smaller.

phototropic,

i re-started my computer and while it was starting i pressed F2. It says there that:
Built-in LAN is enabled
Wake-up on LAN is enabled

Also LAN driver link that you gave me not what i have in my pc.
I have 1394 Net Adapter.
The link was for Intel PRO 10/100 LAN driver.

i did anyways, just to check but messaged from my pc said "wizard could not find a better match..."

I found this info in another web site http://en.kioskea.net/forum/affich-37624-network-adapter-problem

Towards to bottom someone offering this suggestion:
The answer to this most aggravating problem appears to be a very simple fix in Windows which I got from another tech site - so far it has worked like a charm for me and the other user that I got the info from:
- open Add/Remove Programs in Control Panel
- select 'Set Program Access and Defaults'
- select Windows and 'OK"
Windows will run through its little routine and Bada Bing! you should be all set!
Alternatiively, you could fool with the 'Custom' settings in this same dialog box and see if that resolves your issues; but that's only if you really want to set other programs as default mail, media, messenger, etc.

I tired to do same but when i select windows it does not save, it goes to customs.

Any suggestions?
"...Also LAN driver link that you gave me not what i have in my pc.
I have 1394 Net Adapter..."

As has been pointed out before, the 1394 Net Adapter refers to a Firewire port. It is not your LAN adapter. The  Intel PRO 10/100 LAN driver I posted a link to is the network adapter that is installed in your laptop.

If it does not appear in Device Manager, does not appear in any hardware diagnostics and is not in System Information, that implies that the hardware has possibly failed.

Try opening Device Manager, go to View - Show Hidden Devices. Any sign of a network adapter now?
Phototropic,

Thanks for explanation. I had never used a firewall port before so it little confuses me. Thanks for clarification.

I check all hidden devices and found following under Network adapters section.

Visible devices:

1394 Network Adapter
Intel(R) PRO/Wireless 3945ABG Network Connection

Hidden devices:

Direct Parallel
Intel(R) PRO/Wireless 3945ABG Network Connection - Packet Scheduler Miniport
WAN Miniport (IP)
WAN Miniport (IP) - Packet Scheduler Miniport
WAN Miniport (L2TP)
WAN Miniport (PPPOE)
WAN Miniport (PPTP)

You mentioned in your earlier message "However, neither SiW nor Speccy can see an ethernet adapter"

I did not mention before but at Other Devices Section, there is a yellow question mark beside Ethernet Controller. When i check its properties it says that "The drivers for this device are not installed (Code 28)

Please ask me if you need more information. This is a used laptop may be previous owner made some modifications.

Thanks for all your time to solve my problem.







So it looks like the only NIC is the wireless connection.

When you used Ubuntu were you using wireless or cable for the Internet connection?

If you used cable then install the Intel Pro 10/100 driver.
dbrunton,

When i used Ubuntu i used cable for the internet connection. That time i was using internet without any problem. After installing XP i am not able to use it.

where i can find Intel Pro 10/100 driver download?

is it easy to install?

Thanks,
chris
Try this one first

http://cdgenp01.csd.toshiba.com/content/support/downloads/Intel100_os2006303a.exe

If it doesn't work there are others to try.
dbrunton,

how to install this program?
There is no .exe file to click.
Right click on the link and Save As

The files should download to your computer.  You can then double click on it.  It will unzip files into a folder.

Reboot and follow the instructions here http://www.computerhope.com/issues/ch000834.htm  I've copied the relevant parts here

Installing a new device

   1. Open Windows Device Manager. Information about how to do this can be found on document CH000833. In the Device Manager make sure the device you're attempting to install is not already listed from past install attempts. If the device is found highlight it and remove it from Device Manager to prevent any conflicts during the install.
   2. Once Device Manager looks ok reboot the computer.
   3. As the computer is rebooting an install new hardware wizard should appear if Windows detects the new hardware using this wizard you should be able to point Windows to the folder containing your drivers either on the CD, diskette, or the folder containing the files you downloaded.

The folder concerned is Intel100temp.

Quite probably it will not detect anything.  In which case the next paragraph applies.

If Windows does not detect any new hardware open Control Panel and double-click the Add hardware icon to run the hardware detection wizard. During the steps you will have an option to tell Windows you have a disk containing the drivers for your new hardware device, at this point Windows to the directory containing the drivers for your device.

Once drivers have been installed reboot.
dbrunton,
I am at which network adapter do you want to install page.
Manufacturer: Intel
Network Adapter: which one?
they have so many.
i chose to install Intel PRO/100 Network Connection.
After installing, device appeared but with a yellow question mark on right side.
In the properties it says This device can't start Code 10
Which version of Windows XP do you have?

Original, SP1, SP2 or SP3?  If it is not SP3 you'll need to update it to that.

This http://www.microsoft.com/downloads/en/details.aspx?FamilyId=5B33B5A8-5E76-401F-BE08-1E1555D4F3D4&displaylang=en&pf=true is SP3.  Install that if you have SP1 or SP2 on your system.
I have windows SP3
Go to another PC and download the drivers for that Laptop. Use the same thumbdrive U used to run Ubuntu - The other thought I had  is that you bought a laptop that does not have the wireless card on the board (Defective or Sold). The cards are less than the size of a credit card and have antenna connections. If all HDWR is in place drivers from OEM should resolve.
ASKER CERTIFIED SOLUTION
Avatar of dbrunton
dbrunton
Flag of New Zealand image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
dbrunton,

I will try with Ubuntu again but can't boot with thumb (because i have xp installed) so i am burning on cd Ubuntu bootable disk. i will try to connect internet with Ubuntu. Will let you know later what is going on. Thanks all the help so far.
dbrunton,

i installed Ubuntu and right now connected internet with LAN connection with my problem laptop. This is the laptop i was having problem to connect internet while using XP.
My wired network is Auto eth0. I am not familiar with Ubuntu to figure out where the device manager is located so i can check which network card Auto eth0 using.
do you have any clues?
At a terminal in Ubuntu try

lspci

and see what comes back for Ethernet
it says Intel PRO/100 VE Network Connection (rev 02)
I have decided to uninstall XP and use only Ubuntu. Thank you very much for all your time to help me.