Windows Live Mail

When i click on a link in an email that i received i can't open that link. An error message appears instead which says "This file does not a program associated with it performing this action. Create an association in the Folder Options control panel."

I am using Windows XP pro, Firefox 4.0b8, how i can do that?

Thanks,
chris
chrisalvin2005Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

johnb6767Commented:
In the Control Panel, if you use the Set Program Access and Defaults, and set Firefox as the Default Browser, it should reset the URL: file associations.....

If not....

My Computer>tools>Folder Options>File Types......

URL:Gopher Protocol
URL:HyperText Transfer Protocol
URL:HyperText Transfer Protocol with Privacy

Click the Advanced Button, then Edit.... Make sure they all show the following....


Action - open
App used to perform action - "C:\Program Files\Mozilla\Firefox.exe" (use the proper path though...)

The rest should be fine.....
johnb6767Commented:
For IE.....

My Computer>tools>Folder Options>File Types......

URL:Gopher Protocol
URL:HyperText Transfer Protocol
URL:HyperText Transfer Protocol with Privacy

Click the Advanced Button, then Edit.... Make sure they all show the following....

Action - open
App used to perform action - "C:\Program Files\Internet Explorer\iexplore.exe" -nohome
Use DDE is checked
DDE Message - "%1",,-1,0,,,,
Application - IExplore
Topic - WWW_OpenURL
chrisalvin2005Author Commented:
Johnb6767,

I am using only Firefox 4.0b7

i did what you wrote:
Firefox is default

Then i went to

My Computer>tools>Folder Options>File Types......

URL:Gopher Protocol

I do not have above protocol.

URL:HyperText Transfer Protocol
URL:HyperText Transfer Protocol with Privacy

I have two above protocols but both do not have file association, they have IE icon on the left side but written none inside the brackets.

I Click the Advanced Button

Action - open
App used to perform action - ""C:\Program Files\Mozilla Firefox 4.0 Beta 2\firefox.exe"

I changed to above both.

I tested and it works.

Thank you very much for your help.

what about  URL:Gopher Protocol that i do not have it. am i supposed to have it?

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
JavaScript Best Practices

Save hours in development time and avoid common mistakes by learning the best practices to use for JavaScript.

chrisalvin2005Author Commented:
My problem is solved
johnb6767Commented:
Might not ever have a need to use it, wouldnt worry about it for now....
chrisalvin2005Author Commented:
Thank you very much for your expert help.
johnb6767Commented:
Anytime!!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Live Mail

From novice to tech pro — start learning today.