Link to home
Create AccountLog in
Avatar of Worcse
WorcseFlag for United States of America

asked on

Coding Conflict

I have a form which has two command buttons.

Both buttons basically do the same thing:  Loop through a table of email address and send an email with a hmtl message.

The TEST button (button #1) loops through a table which only has only 10 records.  I use this to quick check that the code is operating correctly.  Coding behind this button is exactly the same as the coding behind button #2 except for the table that is used for the emails.

The EBLAST button is button #2.

I had the code to both of these working perfectly until I addded some new coding to put a small delay between each loop and to put a counter on the form itself

When I added the new coding to the TEST button (and before I added the same coding to the EBLAST button) I tried it...it worked perfecto.  BUT when I made the same additions to the code behind the EBLAST button I started having problems.  

I have attached both codes and have highlighted on both the newest coding I added.

Keep in mind that before adding the new coding... both buttons worked fine.  I was only after adding the new coding to the existing code that issues occured.

Thank you as always for any guidance you can give....

~worcse


 Test-Code.docx Eblast-Code.docx
Avatar of Dale Fye
Dale Fye
Flag of United States of America image

What kind of "problems" are you having?

Among other things, if I was opening rstNewItems, I would make sure I closed it after writing to it (both sets of code).

Avatar of Worcse

ASKER

fyed - even though your answer wasn't the solution to my problem... you must have some powerful mojo b/c I just copied, cut and re-pasted the code behind the TEST button.. and now both codes seem to be operating correclty.

I will leave this question open while I continue to test different scenerios and then come back and close it.

~worcse
ASKER CERTIFIED SOLUTION
Avatar of Worcse
Worcse
Flag of United States of America image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Avatar of Worcse

ASKER

????.... how do I close out this question w/o awarding points....????
just select you own post and select Accept as Answer.
Avatar of Worcse

ASKER

I was able to resolve the issue on my own accord.