Link to home
Create AccountLog in
Avatar of NTS_Support
NTS_Support

asked on

Web service working with local host in url, but not with local IP address in url

We've got a web service running on IIS 5 (win 2000 server). I can access it via the following URL: http://localhost/<web servuice name>/trip.asmx

When I try to access it in the following manner, it fails with the following error: http://10.xxx.xxx.xxx/<web service name>/trip.asmx"HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable. Please review the following URL and make sure that it is spelled correctly."

When I try to access it via the following URL, I get an authentication box. If I enter the windows credentials, it works. http://127.0.0.1/<web service name>/trip.asmx

This is very strange in my expierence. This same web services runs on a win 2003 box at another site and all of the above urls work.

Here are some things that I've tried:
1. tested name resolution on the server. I can ping localhost (resolves to 127.0.0.1) and the name of the server(resolves to the internal IP of the server)

2. I've open the network adapter on the server and verified the internal IP. There is only one internal IP configured on this server. I've verified that there is no TCP filtering setup on that adapter.

3. Verified that there is no firewall installed on this server. Macafee virus scanner is installed. I shutdown and disabled the services.

4. I've went through all of the IIS settings and compared them to the working server. Security, bindings,...everything is the same.

5. I checked the hosts file. It has the default setting of local host and that is it.

6. I've rebooted the server.

At this point I'm not sure what to do other than install these web services on a 2003 machine and try again. Any ideas before I take this step?

There is another web site on this server and it works fine with the local IP address.
Avatar of Dave Baldwin
Dave Baldwin
Flag of United States of America image

On the Directory Security tab, check 'Anonymous Access' and see if that helps.  In Windows Explorer under Sharing->Security, I have the "Internet Guest Account" and "IIS process account" enabled.
IIS -> website -> properties -> Advance -> set it to use "All Unassigned" , It will make the website to respond to all of the available IP addresses for server. Or you can add another entry for that IP address at same place using the default port 80 ( or  the one which you are using).
Avatar of NTS_Support
NTS_Support

ASKER

already had anonymous access checked. I did adjust folder file permissions as outlined the the issue persists.

All unassigned was already set. I've played around alot in here and assigned specific addresses and even changed ports. Nothing worked. It's back to the default assignment as outlined above.
ASKER CERTIFIED SOLUTION
Avatar of NTS_Support
NTS_Support

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Glad you got it working.  Even between Win 2000 Pro and XP Pro there are a lot of differences.  XP Pro with IIS5.1 is a lot easier to use.
Seems that there was no solution