Link to home
Create AccountLog in
Avatar of Melody Scott
Melody ScottFlag for United States of America

asked on

Firefox sometimes takes 25% of CPU

Hi, I'm running Firefox 3.6 on a brand spanking new laptop, an Inspiron N1710 running Windows 7. The laptop has 6GB of RAM.

 This happened most recently when I had only 2 tabs open. I was just working away, and as it usually happens, suddenly the web gets very slow. I check the task mgr and it shows that firfox is using 25% of CPU. I close and restart Firefox and it is fine, but it happens every few days.

I had the same problem on my old laptop and searched around for an answer, but everything pointed back to my not having enough RAM, etc. I don't think that's the case here. Can you experts help me track down the issue so I can send it to Mozilla? Thanks.
Avatar of Dale Harris
Dale Harris
Flag of United States of America image

Can you update your Firefox to the latest version?

If so, try that and see if that fixes your issue.

HTH,

Dale Harris
Avatar of Melody Scott

ASKER

This is the latest version except the beta. I had the same problem on my other laptop with 3.5 and 3.6.
Avatar of giltjr
Do you have any RSS feeds?

Are you on a page that may have a lot of client side scripting?
no, it is a different page every time. This time I was working on my store's products. But it slows down, then I close and reopen and work on exactly the same project, and it's fine.
Um, interesting.  Doing a search on firefox and CPU I found a few reports that firefox does chew up CPU at times.  One talks about it doing this only on laptops:

     http://news.cnet.com/8301-13924_3-20011592-64.html

Here is a list of other times/possible issues when Firefox will consume CPU:

     http://kb.mozillazine.org/Firefox_CPU_usage
Thanks for that, but I don't think any of those things apply to me, see my responses in bold below.

http://news.cnet.com/8301-13924_3-20011592-64.html - not a small laptop or a Mac, and the issue is very obvious not through overheating but through a slow-down.


If you're only having problems with sites that use Flash and updating to the latest Flash version doesn't help, you can use the Flashblock extension to selectively enable or disable it [1][2]
>>> no, it happens on all kinds of sites and the one today definitely doesn't use flash

If the problem happens when viewing PDF files in the browser, it's likely a problem with the Adobe Reader plugin. One possible fix is to create a "WWW_OpenURL" directory in the "AdobeUM" directory. [3] [4] Another workaround is to disable the browser plugin so that PDF files open in Adobe Reader as an external application, as explained here.
No, not on pdfs.

Some sites can cause high CPU usage through extensive use of JavaScript. You can disable JavaScript selectively using the NoScript extension.
no, the site I was using today didn't use javascipt and furthermore, this will happen on a site, then if I quit and restart firefox and go to the same page and perform the same action, it is fine

Report the site using Help -> Report Broken Web Site. Reporting the problem will help identify sites with problems so Mozilla evangelists can help fix their problems, and also help Mozilla developers track down any bugs in Firefox that could be causing excessive CPU usage.
It is not one website, it appears to be a problem with firefox, not websites.
Hello,

How may tabs are you opened with Firefox ? Have you check this ?

How many addons have you installed in Mozilla Firefox?  

Regards,
Tushar Kaskhedikar
It happens with different scenarios. Sometimes I have 4 or 5 tabs open, yesterday only 2.

I have no add-ons, but I do have these extensions:
20/20 3D viewer
Google toolbar
iGoogle tab remover
New tab homepage
Firebug 1.5.0
Addthis

Addthis and 20/20 3D viewer are new, and this happened before I installed them.

SOLUTION
Avatar of giltjr
giltjr
Flag of United States of America image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Sure, I'll try that, thanks. Disable or uninstall?
Disable should be enough to stop if from doing anything, if that is what is causing the problem.
ASKER CERTIFIED SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Update, so far so good! No slowdowns as yet.
note- I meant to give all points to this solution:
giltjr:
Can you remove Google toolbar for awhile and see if the problem goes away?  I know a few people that had performance problems when that was installed.

Sorry, not sure how that happened. Please assign  points to giltjr.
That seems to have been the issue! Google toolbar slows down firefox.