Permission problem with reports

Hi,
   We have reports which are running fine at our place. When the same reports were tried by users from other location with other domain they are shown error. The error message is as:
"The permissions granted to user XYZ\UserName are insufficient for performing this operation".
The domainusergroup xyz is included in the security setting for the reports with the role provided as browser.
Can someone help with this.
LVL 25
TempDBAAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Fingo11Commented:
Could you give us some more information on the group types/ actual permissions set  and any nesting of groups going on?  Also Domain and Forest functional levels can play a roll when it comes to tracking down permission problems.

Thanks!

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
EmesCommented:
They need rights to run the SQL on sql sever  
look  at the grant command for sql server
TempDBAAuthor Commented:
@Fingo11: No there are no nesting levels. All the domains are the main domain and all the users within that domain can access. We don't have problem with two domains but other 3 domains are throwing the error.

@Emes: They have right as the request to the procecedures and sql text is being run by a dedicated sql server login.
EmesCommented:
can you log into sql server using that use and run the sql?

based on what you said yes. but lets test it. most of the time this error is a sql rights issue.

you may be calling a function or something in the code that you do not have rights to.

TempDBAAuthor Commented:
Got the problem solved. Though the user were added in the domain user, they were actually trying to connect through their local system which doesn't fall under the domain and that too without connecting through VPN. Silly mistake.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SSRS

From novice to tech pro — start learning today.