Link to home
Create AccountLog in
Avatar of microaideinc
microaideinc

asked on

Iphone connects to Exchange Server but cannot get mail or view calendar

I have a really frustrating problem. I have a client with a new iPhone 4 who wants to attach to their exchange 2003 server. It's not a SBS2003 server so the internet connection wizard isn't available. I configured everything manually. Enabled IMAP, opened port 443, etc.  I go through the setup on the iPhone to connect to their exchange server and it verifies everything. For all intents and purposes I'm connected. I can even choose what I want to sync which is Mail and Calendars. But when I go to Calendars on the iPhone the Exchange Calendar never appears and when I go to Exchange inbox I receive an error message "Cannot Get Mail. The connection to the server failed."  I've tried to connect from my iPhone as well with the exact same problem so it's definetly as issue on the server. I can't understand how I can get all the way to actually connecting but can't view mail or the calendar. Thanks for any help.
Avatar of terrygreensill
terrygreensill
Flag of United Kingdom of Great Britain and Northern Ireland image

I have seen a similar issue if the user has a calender item with no end date. Not sure if it the same issue.
ASKER CERTIFIED SOLUTION
Avatar of Alan Hardisty
Alan Hardisty
Flag of United Kingdom of Great Britain and Northern Ireland image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
You need to update the massync.dll on Exchnage server using below hotfix:
http://support.microsoft.com/kb/957191

Also set BackgroundScanning & proactive Scanning to 1 in registry
Hklm\system\Current control set\services\MsexchangeIS\virus scan

http://support.microsoft.com/kb/827615
Whilst updating massync.dll might possibly help here, there is absolutely no evidence of Anti-Virus interference based on what has been posted.

What is more likely is there is an HTTP 500 error (once the test has been run on the test site), and kb883380 will hopefully resolve this, all of which is outlined in my article.
Avatar of microaideinc
microaideinc

ASKER

I had to turn off ssl on the Exchange Directory. Basically the exact same settings as with a SBS2003 server
Any particular reason for the B grade, which suggests that my answer was not complete and that you had to do further research?

Alan
No offense but yes that's exactly right. Your instructions stated that SSL needed to be checked for Microsoft Active Sync.

  Exchange 2003 (Not part of Small Business Server):

Microsoft-Server-Activesync Virtual Directory
•      Authentication = Basic
•      Default Domain = NETBIOS domain name - e.g., yourcompany* (no more than 15 characters)
•      Realm = NETBIOS name
•      IP Address Restrictions = Granted Access
•      Secure Communications = Require SSL and Require 128-Bit Encryption IS ticked

Then after another 2 hours of research I found this thread which ultimately fixed my issue:

https://www.experts-exchange.com/questions/21878093/New-Mobile-Phone-with-Windows-and-Activesync-on-it-connecting-to-exchange-2003.html

Thank you for your help though
The settings in my article are 100% correct.

Your closing comment states "I had to turn off ssl on the Exchange Directory. Basically the exact same settings as with a SBS2003 server" which is exactly what my article states:

Exchange Virtual Directory
•      Authentication = Integrated & Basic
•      Default Domain = NetBIOS domain name - e.g., yourcompany* (no more than 15 characters)
•      Realm = yourcompany.com
•      IP Address Restrictions = Granted Access
•      Secure Communications = Require SSL NOT ticked (very important)

Your last comment references the Microsoft-Server-Activesync virtual which will require SSL to be enabled if you want to run Activesync Securely.

Are you using SSL for Activesync?  If not - it is not in the least bit recommended to run without SSL.