Link to home
Start Free TrialLog in
Avatar of willa666
willa666Flag for United States of America

asked on

MYSQL wont start

Hiya all

I have a MYSQL  5.1.54 which i not re/starting

I get this in the terminal window.

Ww


# /etc/init.d/httpd restart
Stopping httpd:                                            [  OK  ]
Starting httpd: [Fri Dec 24 14:22:05 2010] [warn] module ssl_module is already loaded, skipping
                                                           [  OK  ]
[root@1052 ~]# /etc/init.d/mysqld restart
Stopping mysqld:                                           [  OK  ]
MySQL Daemon failed to start.
Starting mysqld:                                           [FAILED]

Open in new window

Avatar of willa666
willa666
Flag of United States of America image

ASKER

when i run a start on MYSQL I get this in the mysqld.log

101224 15:12:20 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql
101224 15:12:20 [Warning] /usr/libexec/mysqld: Option '--set-variable' is deprecated. Use --variable-name=value instead.
101224 15:12:20 [Warning] /usr/libexec/mysqld: Option '--set-variable' is deprecated. Use --variable-name=value instead.
101224 15:12:20 [Warning] /usr/libexec/mysqld: Option '--set-variable' is deprecated. Use --variable-name=value instead.
101224 15:12:20 [Warning] /usr/libexec/mysqld: Option '--set-variable' is deprecated. Use --variable-name=value instead.
101224 15:12:20 [Warning] /usr/libexec/mysqld: Option '--set-variable' is deprecated. Use --variable-name=value instead.
101224 15:12:20 [Warning] /usr/libexec/mysqld: Option '--set-variable' is deprecated. Use --variable-name=value instead.
101224 15:12:20 [Warning] /usr/libexec/mysqld: Option '--set-variable' is deprecated. Use --variable-name=value instead.
101224 15:12:20 [Warning] /usr/libexec/mysqld: Option '--set-variable' is deprecated. Use --variable-name=value instead.
101224 15:12:20 [Warning] /usr/libexec/mysqld: Option '--set-variable' is deprecated. Use --variable-name=value instead.
101224 15:12:20 [Warning] /usr/libexec/mysqld: Option '--set-variable' is deprecated. Use --variable-name=value instead.
101224 15:12:20 [Warning] /usr/libexec/mysqld: Option '--set-variable' is deprecated. Use --variable-name=value instead.
101224 15:12:20 [Warning] /usr/libexec/mysqld: Option '--set-variable' is deprecated. Use --variable-name=value instead.
101224 15:12:20 [Warning] /usr/libexec/mysqld: Option '--set-variable' is deprecated. Use --variable-name=value instead.
101224 15:12:20 [Warning] /usr/libexec/mysqld: Option '--set-variable' is deprecated. Use --variable-name=value instead.
101224 15:12:20 [Warning] /usr/libexec/mysqld: Option '--set-variable' is deprecated. Use --variable-name=value instead.
101224 15:12:20 [Warning] /usr/libexec/mysqld: Option '--set-variable' is deprecated. Use --variable-name=value instead.
101224 15:12:20 [Warning] /usr/libexec/mysqld: Option '--set-variable' is deprecated. Use --variable-name=value instead.
101224 15:12:20 [Warning] /usr/libexec/mysqld: Option '--set-variable' is deprecated. Use --variable-name=value instead.
101224 15:12:20 [Warning] /usr/libexec/mysqld: Option '--set-variable' is deprecated. Use --variable-name=value instead.
101224 15:12:20 [Warning] /usr/libexec/mysqld: Option '--set-variable' is deprecated. Use --variable-name=value instead.
101224 15:12:20 [Warning] /usr/libexec/mysqld: Option '--set-variable' is deprecated. Use --variable-name=value instead.
101224 15:12:20 [Warning] /usr/libexec/mysqld: Option '--set-variable' is deprecated. Use --variable-name=value instead.
101224 15:12:20 [Warning] /usr/libexec/mysqld: Option '--set-variable' is deprecated. Use --variable-name=value instead.
101224 15:12:20 [Warning] option 'innodb-additional-mem-pool-size': signed value 512000 adjusted to 524288
101224 15:12:20 [Warning] /usr/libexec/mysqld: Option '--set-variable' is deprecated. Use --variable-name=value instead.
101224 15:12:20 [Warning] /usr/libexec/mysqld: Option '--set-variable' is deprecated. Use --variable-name=value instead.
101224 15:12:20 [Note] Plugin 'ndbcluster' is disabled.
/usr/libexec/mysqld: Table 'mysql.plugin' doesn't exist
101224 15:12:20 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.
101224 15:12:20  InnoDB: Initializing buffer pool, size = 2.0M
101224 15:12:20  InnoDB: Completed initialization of buffer pool
101224 15:12:20  InnoDB: Started; log sequence number 0 12398569
101224 15:12:20 [ERROR] /usr/libexec/mysqld: unknown option '--skip-bdb'
101224 15:12:20 [ERROR] Aborting

101224 15:12:20  InnoDB: Starting shutdown...
101224 15:12:25  InnoDB: Shutdown completed; log sequence number 0 12398569
101224 15:12:25 [Note] /usr/libexec/mysqld: Shutdown complete

101224 15:12:25 mysqld_safe mysqld from pid file /var/run/mysqld/mysqld.pid ended

Open in new window


Try in console :
mysql_upgrade
Hiya rysic

i ran it and got this:


# mysql_upgrade
Looking for 'mysql' as: mysql
Looking for 'mysqlcheck' as: mysqlcheck
Running 'mysqlcheck with default connection arguments
mysqlcheck: Got error: 2002: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2) when trying to connect
FATAL ERROR: Upgrade failed
I'm sorry... My bad :/ Do you have any old my.cfg file in your OS? If yes, please deletoe option skip-federated from it
Hiya rysic

So i do have one in etc/my.cfg.

are you saying i should delete the file and run mysql_upgrade again, or somthing else?

Ww
when you run the mysql upgrade do it as root or sudo.
ASKER CERTIFIED SOLUTION
Avatar of rysic
rysic
Flag of Poland image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
SOLUTION
Avatar of Kerem ERSOY
Kerem ERSOY

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of Kerem ERSOY
Kerem ERSOY

Will you post your /etc/my.cnf here ?
Hi all

So i managed to get the mysql started, backed up and restored to a new image of teh server.

thank you for all your help.