"ASP.NET is not authorized to access the requested resource" error

Getting the below "ASP.NET is not authorized to access the requested resource" error.  How do I remedy this?

error.htm
arichexeAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Corey HabbasSecurityCommented:
Hi,

Did you try to open up permissions to the file using the following recommendation?

"ASP.NET is not authorized to access the requested resource. Consider granting access rights to the resource to the ASP.NET request identity. ASP.NET has a base process identity (typically {MACHINE}\ASPNET on IIS 5 or Network Service on IIS 6) that is used if the application is not impersonating. If the application is impersonating via <identity impersonate="true"/>, the identity will be the anonymous user (typically IUSR_MACHINENAME) or the authenticated request user.

To grant ASP.NET access to a file, right-click the file in Explorer, choose "Properties" and select the Security tab. Click "Add" to add the appropriate user or group. Highlight the ASP.NET account, and check the boxes for the desired access."

Do you have access to the server, or does a separate admin administer the server?  If you don't have access to the server, you may have to work with the system administrator to set the above permissions that are recommended.

Please post as to whether you have tried this yet...thanks...

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Corey HabbasSecurityCommented:
In relation to IIS there is a reference and tip by Ivailo Gardev where he suggests via this link:
http://www.computerperformance.co.uk/Logon/code/code_80070005.htm#IIS_Website_User_Name

He litterally states, "We had similar error 80070005 problem in our team. The problem was with IIS server in XP Professional environment. FoxPro 9 (foxisapi) was used for dynamic creation of the web pages.  It is strange, but the problem was resolved by changing the value in “User Name” field in the Authentication Method popup window (Control Panel > IIS > Default Web Site > Properties > page Directory Security > Anonymous Access – Edit button). The value was changed to 'EVERYONE' and the error has disappeared. However, "everyone" is not the only possible word. Seems that all words, which are different than the names of the existing IWAM_* and IUSR_* users are OK. "

Another user via the same page states, "My error 80070005 was down to a setting within IIS for my website. The default application is set to "default application pool", whereas I have changed this is "Exchange Application" and it now works fine."

The link I included has screenshot information as well.


It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
ASP.NET

From novice to tech pro — start learning today.