How to repair Ubuntu 10.04 with broken Empathy packages

Dear Experts,

In my Ubuntu 10.04, the Synaptic package manager reports the "empathy" and "empathy-common" packages as being broken, however it cannot fix it with "repair broken packages". This problem is critical because it tries and fails to fix the problem every time I try to update or install anything; it exits before anyting is applied.

I have also tried in the bash shell using "sudo apt-get remove empathy", which tells me the following:
Package is in a very bad inconsistent state - you should  reinstall it before attempting a removal.

OK, I try to install it in the bash shell using "sudo apt-get install empathy", which fails with a lot of cryptic error messages. I attach the output in a text file.

Thanks in advance for your help.

empathy.txt
PhazzAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

wdfdo1986Commented:
still this problem looks like not solved.
I think u have to wait for a solution

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
wdfdo1986Commented:
stay with ubuntu forums
PhazzAuthor Commented:
It its very bad not to be able to update or install any software. I don't really care about empathy, can I manually bypass the deadlock somehow?
Your Guide to Achieving IT Business Success

The IT Service Excellence Tool Kit has best practices to keep your clients happy and business booming. Inside, you’ll find everything you need to increase client satisfaction and retention, become more competitive, and increase your overall success.

wdfdo1986Commented:
When installing something what's the error occurring?
Cant u ignore it and continue installation?
PhazzAuthor Commented:
When I try to install something, it wants to upgrade empathy and empathy-common as well and it fails. I cannot find a way to avoid that. For example I have taken three screen shots of what happens if I try to install the package "tidy" (which has nothing to do with empathy). Synaptic dialog I get this error message This is the beginning of the detailed error log
wdfdo1986Commented:
Open up /var/cache/apt/archives/ folder in UI
keep a copy of the debs that giving errors in some where in local
and delete in terminal in sudo mode
since u need sudo permissions to delete files in var u have to do it in terminal.
and try restarting
This should help.
Good luck!!!
PhazzAuthor Commented:
Sorry, a stupid question: what is UI?
wdfdo1986Commented:
doesn't matter
just copy two deb files to a local folder eg:- somewhere in /home
I think u understand that.
That is for restoring purposes in a matter of error.
PhazzAuthor Commented:
Sure that's clear.
I did as you suggested, but afterwards the same errors come in Synaptic. And the two empathy deb files in /var/cache/apt/archives/ are re-created with the exact same sizes and time stamps as before I deleted them.

wdfdo1986Commented:
boot from cd
u can use the package nautilus-gksu if u want
http://www.watchingthenet.com/ubuntu-tips-for-windows-users-add-open-as-administrator-to-nautilus-right-click-menu.html

do the same thing and see what hapens
PhazzAuthor Commented:
Honestly I don't see why it would make a difference weather or not the files are deleted in a shell from a boot CD or a normal one as root. I will be offline the next couple of days.
wdfdo1986Commented:
u said the files were created again. so what I said is an alternative deletion mechanism
PhazzAuthor Commented:
I don't have time to check now, but I think the deb files re-appear because synaptic/ apt-get download them when it attempts to update empathy.
PhazzAuthor Commented:
Because the deb files were really deleted before synaptic was run again.
wdfdo1986Commented:
normally it doesn't happen
tell me when u are back.
PhazzAuthor Commented:
Finally I'm back! Summary of the current status (nothing new unfortunately).

Whenever I try to install/update any package with Synapic, it fails (with cryptic python errors) because it insists on upgrading the packages empathy and empathy-common, version 2.30.2-0ubuntu1 to version 2.30.3-0ubuntu1.

As you suggested I deleted the two empathy deb files:
/var/cache/apt/archives/empathy_2.30.3-0ubuntu1_i386.deb
/var/cache/apt/archives/empathy-common_2.30.3-0ubuntu1_all.deb

However, it does not work. When Synaptic is started again (after re-boot) the two above files are downloaded as Synapic once again insists to upgrade empathy.

I couldn't care less about empathy, but of course I want to be able to install and upgrade packages in general without the emapthy problem blocking.
PhazzAuthor Commented:
Eventually I have restored the system from an old backup image and updated stuff like my home dir from a copy of the new one. A lot of book-keeping.
Normally I really like debian packaging / apt-get. But in this case the mechanism was really messed up and intransparent.

@wdfdo1986, I will give you the 500 points just for trying to help :)
PhazzAuthor Commented:
I give the 500 points to the one expert who replied to my question, although his/her ideas could not solve my problem.

I accept two comments as solutions:

I accept the expert's first comment because it is correct that the problem is yet to be properly solved.

I "accept my" own final comment as well.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.