Mac flapping problem after adding etherchannel (channel-group)

Hello!

I met the problem, solution is which hard to find.
I have two ip dslam (zyxel IES-5000), Ethernet port of which is configured as trunk which consist 2 vlan, one for management, second for users uplink.

From time to time I faced with log message
%SW_MATM-4-MACFLAP_NOTIF: Host {mac_address} in vlan 865 is flapping between port NNN and port NNN
But this messages was rear and subscribers didn’t have any problems with connection.

After connecting second line between switches sw1 and sw2 (port fa0/24) and configuring etherchannel between them, subscribers faced with problem to connect to the internet and switch logs has the following entries.

1d02h: %SW_MATM-4-MACFLAP_NOTIF: Host 404a.03a4.262e in vlan 865 is flapping between port Fa0/4 and port Fa0/3
1d02h: %SW_MATM-4-MACFLAP_NOTIF: Host 404a.03a4.262e in vlan 865 is flapping between port Fa0/4 and port Fa0/3
1d02h: %SW_MATM-4-MACFLAP_NOTIF: Host 404a.03a4.262e in vlan 865 is flapping between port Fa0/4 and port Fa0/3
1d02h: %SW_MATM-4-MACFLAP_NOTIF: Host d85d.4ca6.8fe3 in vlan 865 is flapping between port Fa0/4 and port Fa0/3
1d02h: %SW_MATM-4-MACFLAP_NOTIF: Host 0008.7c2c.b01a in vlan 865 is flapping between port Fa0/3 and port Po1
1d02h: %SW_MATM-4-MACFLAP_NOTIF: Host d85d.4ca6.8fe3 in vlan 865 is flapping between port Fa0/4 and port Fa0/3
1d02h: %SW_MATM-4-MACFLAP_NOTIF: Host d85d.4ca6.8fe3 in vlan 865 is flapping between port Fa0/3 and port Fa0/4
1d02h: %SW_MATM-4-MACFLAP_NOTIF: Host 0008.7c2c.b01a in vlan 865 is flapping between port Fa0/3 and port Po1
1d02h: %SW_MATM-4-MACFLAP_NOTIF: Host 0008.7c2c.b01a in vlan 865 is flapping between port Fa0/3 and port Po1
1d02h: %SW_MATM-4-MACFLAP_NOTIF: Host d85d.4cbf.7498 in vlan 865 is flapping between port Fa0/3 and port Fa0/4
1d02h: %SW_MATM-4-MACFLAP_NOTIF: Host d85d.4cbf.7498 in vlan 865 is flapping between port Fa0/4 and port Fa0/3
1d02h: %SW_MATM-4-MACFLAP_NOTIF: Host d85d.4cbf.7498 in vlan 865 is flapping between port Fa0/4 and port Fa0/3
1d02h: %SW_MATM-4-MACFLAP_NOTIF: Host 0008.7c2c.b01a in vlan 865 is flapping between port Fa0/3 and port Po1
1d02h: %SW_MATM-4-MACFLAP_NOTIF: Host 0008.7c2c.b01a in vlan 865 is flapping between port Fa0/3 and port Po1
1d02h: %SW_MATM-4-MACFLAP_NOTIF: Host d85d.4cbf.7498 in vlan 865 is flapping between port Fa0/3 and port Fa0/4
1d03h: %SW_MATM-4-MACFLAP_NOTIF: Host 0013.4988.b79a in vlan 865 is flapping between port Fa0/4 and port Fa0/3
1d03h: %SW_MATM-4-MACFLAP_NOTIF: Host 1caf.f766.29fd in vlan 865 is flapping between port Fa0/4 and port Fa0/3
1d03h: %SW_MATM-4-MACFLAP_NOTIF: Host 404a.03ac.5ef4 in vlan 865 is flapping between port Fa0/4 and port Fa0/3
1d03h: %SW_MATM-4-MACFLAP_NOTIF: Host 1caf.f7ac.9080 in vlan 865 is flapping between port Fa0/4 and port Fa0/3
1d03h: %SW_MATM-4-MACFLAP_NOTIF: Host 0021.91e1.bc59 in vlan 865 is flapping between port Fa0/4 and port Fa0/3
1d03h: %SW_MATM-4-MACFLAP_NOTIF: Host 404a.0336.7e7a in vlan 865 is flapping between port Fa0/4 and port Fa0/3
1d03h: %SW_MATM-4-MACFLAP_NOTIF: Host 0002.cfe4.4af5 in vlan 865 is flapping between port Fa0/4 and port Fa0/3
1d03h: %SW_MATM-4-MACFLAP_NOTIF: Host d85d.4ca1.bcd0 in vlan 865 is flapping between port Fa0/4 and port Fa0/3
1d03h: %SW_MATM-4-MACFLAP_NOTIF: Host d85d.4cb3.a87c in vlan 865 is flapping between port Fa0/4 and port Fa0/3
1d03h: %SW_MATM-4-MACFLAP_NOTIF: Host 74ea.3abc.9fa9 in vlan 865 is flapping between port Fa0/4 and port Fa0/3
1d03h: %SW_MATM-4-MACFLAP_NOTIF: Host d85d.4cb3.a225 in vlan 865 is flapping between port Fa0/4 and port Fa0/3

Most of mac address belong to the subscribers modems .


************************************************************************************************
Configuration of Sw1

interface Port-channel1
description ########### Link_to_SW2 ###########
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 245,246,865
switchport mode trunk

interface FastEthernet0/1
description ########### Uplink_to_Router ###########
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 245,246,865
switchport mode trunk

interface FastEthernet0/23
description ########### Link_to_SW2 1 ###########
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 245,246,865
switchport mode trunk
channel-group 1 mode on
!
interface FastEthernet0/24
description ########### Link_to_SW2_2 ###########
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 245,246,865
switchport mode trunk
channel-group 1 mode on


******************************************************************************
Configuration of Sw2

interface Port-channel1
description ########### Link_to_sw1 ###########
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 245,246,865
switchport mode trunk

interface FastEthernet0/3
description ########### Trunk to Zyxel_1 ###########
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 245,865
switchport mode trunk
!
interface FastEthernet0/4
description ########### Trunk to Zyxel_2 ###########
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 245,865
switchport mode trunk

interface FastEthernet0/23
description ########### Link_to_sw1_1 ###########
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 245,246,865
switchport mode trunk
channel-group 1 mode on
!
interface FastEthernet0/24
description ########### Link_to_sw1_2 ###########
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 245,246,865
switchport mode trunk
channel-group 1 mode on


**********************************************************
Configuration of  Router

bba-group pppoe XXX
virtual-template 12
sessions per-vlan limit 10000

interface GigabitEthernet0/2.865
description ########### ATS_XX ###########
encapsulation dot1Q 865
ip address X.X.x.x 255.255.255.0
no ip redirects
no ip proxy-arp
ip virtual-reassembly
no snmp trap link-status
pppoe enable group XXX

interface Virtual-Template12
mtu 1492
ip unnumbered GigabitEthernet0/2.865
ip virtual-reassembly
peer default ip address pool dsl_pool_XXX
ppp authentication pap chap

********************************************


Vlan 245 is management vlan for dslams, vlan 865 subscribers vlan.
Network topology is attached.
The same thing happens if each of ip dslams is connected to the different switches and placed to the same uplink vlan.


Regards.

topology1.JPG
dctengineerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Don JohnstonInstructorCommented:
This is typical when etherchannel is used but is not successfully built. You don't specify what switches but it looks like Cisco. If that's the case, I would use PAgP or LACP to build the channel. Instead of the mode "on" use desirable.

int range f0/23 -24
 shut
 channel-group 1 mode desirable
 no shut
end


Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Switches / Hubs

From novice to tech pro — start learning today.