VPN using D-Link DIR-130

I  set up a VPN server using a D-Link DIR-130 connected to a cable modem. I am able to log in to the VPN remotely but I can not access any files in the server. What am I missing?

So far this are the steps I have taken :

1. I connected the DIR-130 to my cable modem.
2. I connected my server computer to a LAN port in the DIR-130.
3. I connected a DIR-655 to the DIR-130 (wan to lan) for my home network. I changed the private IP in this router to avoid conflicts with the address in the DIR-130.
4. In the DIR-130 setup page I created a VPN  using PPTP protocol.
5. In another computer I created a VPN client.
6. To test this arrangement I connected the computer with the VPN client to the LAN in the DIR-655 and logged in to the VPN, The connection was successful but I can not access any files in the server computer.

HELP!!!!!!!!!

jberrizAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
Try connecting to the server by IP Address. Does that help?

Also try updating the firmware in the D-Link router?

And if all that fails, I found that a D-Link router at a client failed with ever newer XP and other OS updates and we had to change it for a different router.

.. Thinkpads_User
jberrizAuthor Commented:
Thanks for your reply. What do you mean by connecting to the server by IP address?
jberrizAuthor Commented:
Also, I checked the firmware and its the latest available in D_Link's site.
Your Guide to Achieving IT Business Success

The IT Service Excellence Tool Kit has best practices to keep your clients happy and business booming. Inside, you’ll find everything you need to increase client satisfaction and retention, become more competitive, and increase your overall success.

JohnBusiness Consultant (Owner)Commented:
When you try to access files on the other end, you do so by computer name or by IP address. That is what I meant. That is the first thing to try when you can connect but not see files. ... Thinkpads_User
jberrizAuthor Commented:
I tried accessing a shared file using the IP address and could not opened it. I also tried to ping the server and got a "request timed out" message.

 However I searched for the computer using windows search and it located the computer and the file. It appears in workgroup Mshome under Microsoft Windows Network. I think this has nothing to do with the VPN and that it happened because I am using a computer connected to the DIR-655 router for my home network  which in turn is connected wan > lan to the vpn router. I placed the DIR-655 in the dir-130's dmz and thought it would not be considered part of this lan. I guess that may not be correct.
JohnBusiness Consultant (Owner)Commented:
The above is somewhat confusing. You may be getting a cached search answer. If you cannot ping through your VPN then the VPN is probably not set correctly. You need at this point to check all your firewalls. Firewall settings will prevent pings. ... Thinkpads_User

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jberrizAuthor Commented:
While following up on your suggestion I check my ISP and found that they do not allow port mapping.

"No. To offer exceptional service to all our customers, we do not permit residential customers to run servers of any kind. This includes but is not limited to PPP, FTP, HTTP, DNS, POP, SMTP, NNTP, PROXY, DHCP, IRC, TELNET, TFTP, SNMP and multi-user interactive forums, and remapping of ports for the purpose of operating a server on the network."

I guess this would be a problem in trying to run set up the VPN.?
JohnBusiness Consultant (Owner)Commented:
Thank you.   I know VPN is difficult, and I was pleased to assist. .. Thinkpads_User
jberrizAuthor Commented:
Just for educational purposes let's assume that my ISP did allow this types of connections. What settings would I have to change to make the VPN work correctly?

Would I have to access the gateways firewall setting and open the ports required for PPTP and IPsec?

Would I have to open any other ports to access the files residing in the server?

Afterward, how would I then access the server? Using the port forwarding feature in the D-LINK router to open the PPTP and IPsec ports and any other port to the server?

What services are needed to access shared files in the server? FTP?

Could I then use the firewall rule window to restrict access through the router only to authorized outside the LAN?

Finally, I read somewhere that a VPN service could be used to bypass some restrictions that internet providers may have in place. Do you think this may be a way to work around my problem?


Thanks and Happy 2011





It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VPN

From novice to tech pro — start learning today.