TZ-210 Removing Address objects

I have just cleaned up the Access rules, Address Objects, Nat Policies, and groups etc. on a new install. I am left with some Address Objects that error when trying to remove them stating that they are in use in an Access Rules when they are not. It acts like "leftovers" and they are still stuck in memory. One object states it ir referenced 24 times while another one states 3 time.

With the exception of restoring the device to factory settings and reloading the settings from an external file, any other thing I could try?

SonicOS Enhanced 5.6.0.10-52o
Bert517Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

digitapCommented:
my guess is there is a address group referencing the objects in question.  otherwise, the only thing i know to do is to actually look at it.  if you upload a sanitized tsr from diagnostics under system, we can look through the group objects, nat policies and firewall rules.
Bert517Author Commented:
Look for an entry named removeme TSI.txt
digitapCommented:
i analyzed your TSR.  i attached the results with several rules still accessing the removeme address object.  i deleted anything that didn't reference "removeme".  was your original TSR the result AFTER your changes?
Analyzed-TSR.txt
Become a Certified Penetration Testing Engineer

This CPTE Certified Penetration Testing Engineer course covers everything you need to know about becoming a Certified Penetration Testing Engineer. Career Path: Professional roles include Ethical Hackers, Security Consultants, System Administrators, and Chief Security Officers.

Bert517Author Commented:
I see where the removeme is accessing the wlan but where do I go to remove it from the sonicwall? Yes the TSR was after my changes.
digitapCommented:
go to firewall > access rules and within the matrix, click WAN To WLAN initially.  you have the address object referenced in other access rules.  i looked through the TSR that i went through and i didn't clean it completely.  i have re-attached it to this post.
Analyzed-TSR.txt

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Bert517Author Commented:
Problem is, I don't see WLAN in the fireall access rules
digitapCommented:
looking at your TSR, i see you have the enhanced OS on the TZ-210.  you should see, under the matrix view, what i've shown in the screen shot within this message.  do you not see WLAN?
greenshot-2010-12-27-12-28-01.jpg
Bert517Author Commented:
No it is not there:

accessrules.JPG
digitapCommented:
go to network interfaces and tell me if wlan is enabled.
Bert517Author Commented:
LOL...I am stricking out here:

netiface.JPG
digitapCommented:
i think you'll need to remove one of the interfaces from the lan portshield.  assign the interface the wlan zone.  you'll be able to delete the rules then.
Bert517Author Commented:
Well that helped some. I got the reference for removeme down from 24 to 16. I still need to fine the other references.
Bert517Author Commented:
Updated TSR after the port shield change TSR1227.txt
Bert517Author Commented:
Afrter tweaking the settings a little bit. I was able to remove all the rules except for MULTITASK -> Lan. Once I figure that out I tyhink I am done. Thank you for all your help as you  did tach me some things I did not know.
digitapCommented:
sure, no problem.  glad we're making progress.  regarding multitask, i've never see a default multitask zone.  is that something you created?  i'd work this like the wlan zone above.
Bert517Author Commented:
I tried to set it up like that but there is no multitask option to assign the interface to. Still playing with it though.
digitapCommented:
you might have to create the multicast zone if it does not exist.
Bert517Author Commented:
I am not sure on how to do this. I tried but not good enough
digitapCommented:
click Network > Zones.  click Add and name the new zone MULTICAST.  select Untrusted for the security type.  leave the defaults for everything else.  now, you should be able to assign the zone to the interface you used for the WLAN zone.
Bert517Author Commented:
Thank you. I set up a Multitask zone as you said and I couldn't assign the adapter to Multitask but from my palying around I was able to remove some of the objests. I rebooted the device and i removed the last. Saved the current config to an external file so we are good to go!

Thank you for all your help.
digitapCommented:
thanks, glad i could help and thanks for the points!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Software Firewalls

From novice to tech pro — start learning today.