TS Gateway - Remote Desktop - Showing old certifcate

I have a TSGateway with RemoteApp setup.  I had originally used a self-signed certicate. Then I purchased a certifcate from digicert.  When they first connect the new ssl cert connects them fine, but when I go to open remoteapp it still shows the old self-signed certifcate even though I removed it from everywhere I could find.

Where might it still be finding the old certifcate from and how do I remove it?
DavidRS4Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

terrygreensillCommented:
You might need to re-publish the remoteapps
DavidRS4Author Commented:
Tried republishing the remoteapps.  The user still gets the old certifcate...
DavidRS4Author Commented:
End User had to upgrade their version if RDP to 7.0 and then everything worked fine.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
DavidRS4Author Commented:
Discovered client needed to upgrade RDP version.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.