Event ID 6857 cannot connect to SMTP Host

Suddenly one of our subsite called Room Booking is not sending an initial email alert but it's sending email if the room booking entry is modified. In the Event log of our SP server is the "Event ID 6857 cannot connect to SMTP Host"  I've followed the resolution from this Q_25802856.html and MS Event ID 6857 but still no go. All expected services are running and we don't see any problem in the configuration. Please help


Our setup:

WSS 3.0 Single Server Configuration. Exchange 2003 server.
KhateAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ganberrygCommented:
Hi,
Hope the link below can solve ur issue

http://technet.microsoft.com/en-us/library/cc560961(office.12).aspx

Ganesh G
KhateAuthor Commented:
thanks but I've already tried that.

the Timer Job status is 100% and started this morning. The Timer Job definition immediate alerts is set to the correct web app scheduled type mins. Retyped the username and password for the service account in the Sharepoint services timer, checked Relay, my SP ip is listed in allowed.restarted IIS, tested no go.

Ive tried adding the w3wp.exe and owstimer.exe in MCafee's exclusion list but after clicking apply and ok, and check it again, the list is clear again.
ganberrygCommented:
Your Guide to Achieving IT Business Success

The IT Service Excellence Tool Kit has best practices to keep your clients happy and business booming. Inside, you’ll find everything you need to increase client satisfaction and retention, become more competitive, and increase your overall success.

Daryl SirotaDirector of Technical ServicesCommented:
Turn off McAfee and see if that 'fixes' it. Also, turn up the Exchange smtp logging and see if its getting in there. Worst case, put a copy of WireShark on wss and sniff port 25 and see what's trying to go where.  
KhateAuthor Commented:
We checked the Mcafee 8.07i logs and  added the w3wp.exe in the AccessProtection list. Tried again and it worked. Simply adding the w3wp.exe  on the exclusion list didnt fix the issue.

Thanks everyone.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
KhateAuthor Commented:
thanks
KhateAuthor Commented:
Excellent, thanks for taking time to help me. I thought just adding the w3wp.exe  on the exclusion list should fix it.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.