Link to home
Create AccountLog in
Avatar of silviotucciarone
silviotucciarone

asked on

System x3550 M2 stuck on system initializing after firmware upgrades

Hey guys so i have been having this major issue for the last few hours now.
I have a system x 3550M2 server and i ran the UEFI and IMM firmware upgrades within windows server 2008 R2 x64. All upgrades went fine and i was told to reboot. I performed the reboot cleanly using the OS restart option. Upon restarting it showed the system initializing screen and it stayed there for a good hour. After that hour i figured it froze and so i powered down and power up again. Now i can not boot back up to even see the IBM splash screen or the OS... I have tried switching the Jumpers to go to the backup UEFI and backup IMM and no luck. I have also reset the CMOS power and i have pressed the reset button 3 times on the light path and no luck. There are no lights light on the light path to indicate anything is broken. The only thing i see on the light path is the number 0.5.
Any ideas guys i am quite stumped with this problem.

Thanks a lot,

Dani Cela
Avatar of Anton74
Anton74
Flag of United States of America image

Can you still connect to IMM?
Avatar of silviotucciarone
silviotucciarone

ASKER

i have been having issues so no... unless you can tell me how to reset it so that i can connect to it. i figured if i get into imm then everything will be ok since i can re flash it...
ok i some how got IMM to work so now what should i do to rectify this situation? it just stays on the system initialization screen
so now i am seeing a 0:5 on the light path but am unsure what this means... anyone have any ideas?
I've been trying to find that out, which is not particularly easy apparently. I can use that info myself.

What is the status of the power and error LEDs (color/blinking)? Will IMM allow you to load firmware again? Does IMM show any more useful diagnostic info in Event Log or elsewhere?

If you have access to hardware support, I think it that would be the way to go at this point. I'm still trying to find more info on the light path code, but I don't have a ready answer at the moment I'm afraid, sorry.
Power is solid, error leds are all off but the code is showing me 0:5
IMM allows me to load firmware but not the UEIF because you have to be within an OS to do that... but if i try and upgrade the IMM firmware again it works perfect...

as for useful info in event log, there is absolutely nothing, according to the IMM right now my server is in this state....
"
System Health Summary    

Server power:      
On
Server state:      
System running in UEFI

      Server is operating normally. All monitored parameters are OK.
Scroll down for details about temperatures, voltages and fan speeds.
"

So according to the IMM it says the server is running perfect... except it has been in that particular state for probably 2 hours now... and the screen just says "system initializing" nothing else is on the screen.

I do have access to hardware support and i have already logged a ticket, apparently they wont get back to me until tomorrow at 8am est because today is a holiday they observe...

So pretty much i  have a paper weight for the time being until probably tomorrow. i have probably done 10 hours of research and nothing comes up... i have a feeling that the motherboard is going to get replaced.

Reason im saying this is because the system is on that screen with "system initializing" it means that the system technically has not POST'd yet.. reason i also say that is because i removed all RAM, and according to the IBM manuals when you do that,the POST will write a message on the actual screen of the server...


So essentially my issue right now is trying to get into setup menu to possibly try a few things or boot off a update cd which isnt going to happen if i stay looped on this screen.

So that is pretty much what i know at this moment, see if any of that helps you...

Thanks man
Based on IMM not reporting any problems, and the system state being "running in UEFI", I'm thinking the problem is pretty much UEFI itself - it has control, but isn't functioning at all, not even enough to report that something is broken.

That makes sense especially since you just upgraded it, but I would've expected the switch to the backup UEFI to have fixed this, which it didn't.

I don't think I'll have a solid solution for you before you hear back from the support people. I'm interested to know how they will fix it though, they may have a way to re-flash the UEFI firmware without actually booting.
yea we sort of came to that conclusion as well on my end... umm tomorrow i will get a call back for the HW case so lets see. I will for sure post back once i know what they have done...
ASKER CERTIFIED SOLUTION
Avatar of silviotucciarone
silviotucciarone

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Ah, you were right then, nothing you could've done about that on your own..

Thanks for updating us with the resolution. I think you can close the question with a refund of your points.
IBM replaced board nothing that i could have done on my own...
Problem solved IBM came and replaced the board