Link to home
Start Free TrialLog in
Avatar of R7AF
R7AFFlag for Netherlands

asked on

Java Control Panel: impossible to disable scheduled updater?

On a Windows 7 machine with Java installed, I want to disable the automatic update service for Java. If I open the Java Control Panel (C:\Program Files (x86)\Java\jre6\bin\javacpl.exe) click the update-tab, uncheck the update, click Apply, close JCP, then start JCP again, check the update-tab, it is checked again.

So whatever I do, this uncheck-option is fake or doesn't work on this computer. I suppose there is a Windows service or scheduled task running that can be disabled. How can I do this? I've taken a look at the Task Scheduler, but can't find anything there.
SOLUTION
Avatar of John Griffith
John Griffith
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
ASKER CERTIFIED SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Try to go to javacpl.exe -> right click -> run as admin
Avatar of R7AF

ASKER

Yeah later on I realized this might be a rights problem, so I'm going to try to run as admin. I will let you know. Sysinternals is a good tip as well.
Avatar of nltech
nltech

use msconfig to disable jusched.exe on the startup tab.
Avatar of R7AF

ASKER

Thanks! With admin rights it works. With sysinternals I disabled some other annoying services.