Link to home
Create AccountLog in
Avatar of Srinivas_Vengala
Srinivas_VengalaFlag for India

asked on

Getting the follwoing error while removing the Static route on AIX

Hi,
Getting the follwoing error while removing the Static route on AIX
Method error (/usr/lib/methods/chginet):
0514-009 Cannot delete an object from the device
configuration database.

Could some one please help me

Thanks,
Sv
Avatar of coredatarecovery
coredatarecovery
Flag of United States of America image

are you doing this as root?

Use smit to change routes in aix. It's the easiest way to change them and hard to screw things up.
Avatar of Srinivas_Vengala

ASKER

yes, I have loged in as root.

and I am tring to do this using smitty only. smitty netstat->remove a static route-->and entered the destination ip and gateway.

same error.....
Avatar of woolmilkporc
Hi,

it seems that you're trying to remove a route using "chginet" (which is called by "smitty") that has not been added using chginet, but with "route add ..."

chginet adds its route definition to the ODM database ("device configuration database") when creating a route and consequently tries to remove this definition when deleting a route.
"route add .." and "route delete ..." on the other hand don't use the ODM (they create  kind of "volatile" definitions which will not survive a reboot), thus "chginet" will fail trying to remove such a route definition completely.

Are you sure that the route you tried to remove is still present? "chginet" is a two-step process, and although the second step ("remove from ODM") will fail, the first step ("remove from running configuration residing in memory") usually succeeds. Please check!

If the route still exists and if I'm right with my above guess remove it using "route delete ..."
The further parameters depend on whether it's a route to a network or to a host.
The general syntax is

route delete [-net|-host] gateway

wmp
I tried the following

route delete -net <destination host> gateway

but getting the error as "writing to routing socket: No such process"
Sorry, the correct syntax of the "route" command is

route delete [-net|-host] [i]destination[/i]
Saw your last comment too late!

If you use <destination host> the correct option is "-host", not "-net"!

And the message you're getting could also indicate that the route is already gone! Did you verify that it's still there?
still same error....

i have tried route delete -net <destination>

error is : writing to routing socket: No such process

I guess this is not a persistent one, could you please guide me in that way

Thanks,
VS
Hi WMP,

I tried using -host as well, but same error....

Yes, in netstat -rn the IP is showing up.

Thanks,
VS
Please post the relevant line of the "netstat -r" output!
The relevent line in netstat -r is
10.45.48/20        10.45.17.1        UGS       0     15005 en1      -      -   =>
route delete -net 10.45.48
Still same error
 =>route delete -net 10.45.48
writing to routing socket: No such process
Should have worked!

Maybe your route has been created for this specific interface only?

Try

route delete -net 10.45.48 -interface en1

And what does the line following the posted one say?
Here is the message:
route delete -net 10.45.48 -interface en1
en1: bad value

OK,

so it's indeed a route by gateway only and not by interface.

Last resort: Specify the netmask!

route delete -net 10.45.48/20


that should do it for certain.
I am still getting the same error message....
=>route delete -net 10.45.48/20
writing to routing socket: No such process
ASKER CERTIFIED SOLUTION
Avatar of woolmilkporc
woolmilkporc
Flag of Germany image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Any news regarding this issue?

Cheers

wmp
Didn't get a chance to check, will let you know.