How do I setup seperate static VPN ASA?

I have a really simple network with a Cisco ASA 5510 firewall on the edge. Inside that network are a variety of desktops/devices, and a couple servers. All are on the 192.168.1.0 range. The Cisco ASA 5510 has an internal IP of 192.168.1.1. We were recently given an additional ASA 5510 by another agency that we do some electronic communication with with some pre-programmed site to site VPN info in it. I'm trying to setup our network so that any communication with the IP addresses requiring the new ASA works properly (172.29.12.0). Here is the basic info:

Our normal firewall: Cisco ASA5510
Internal IP: 192.168.1.1
External IP: 146.129.245.186

Firewall provided by our partner: ASA5510
Internal IP: 192.168.1.2
External IP: 146.129.245.187

Below are the running configs. I've been able to ping the 172.29.12.0 range from the Tools menu in the ASDM of the 192.168.1.1 ASA, but not from the unit with the actual VPN info in it, or from devices inside our network. Any ideas on what changes I need to make?

Thanks,
SS

Simple Network Diagram
ASA #1 Config

: Saved
:
ASA Version 8.0(4) 
!
hostname AdminASA5510
domain-name adminasa.kcfd20.org
enable password XXXXX
passwd XXXXX
names
name 74.94.67.57 Station21
name 192.168.21.0 station21-network
name 146.129.245.186 Admin-Bldg-INET
name 74.93.110.249 Comcast-Admin-Bldg
name 74.93.110.250 Comcast-PR22
name 192.168.1.10 KCFDDC
name 192.168.1.43 PR22
dns-guard
!
interface Ethernet0/0
 description IP: 146.129.245.186-190
 nameif outside
 security-level 1
 ip address Admin-Bldg-INET 255.255.255.248 
!
interface Ethernet0/1
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Ethernet0/2
 nameif Inside
 security-level 15
 ip address 192.168.1.1 255.255.255.0 
!
interface Ethernet0/3
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Management0/0
 nameif management
 security-level 100
 ip address 192.168.2.1 255.255.255.0 
 management-only
!
boot system disk0:/asa804-k8.bin
ftp mode passive
clock timezone PST -8
clock summer-time PDT recurring 1 Sun Apr 2:00 last Sun Oct 2:00
dns domain-lookup outside
dns server-group DefaultDNS
 name-server 208.67.222.222
 name-server 208.67.220.220
 name-server 68.87.69.146
 domain-name adminasa.kcfd20.org
access-list inside_access_in extended permit ip any any 
access-list inbound extended permit tcp any interface outside eq 9100 
access-list inbound extended permit tcp any interface outside eq www 
access-list inbound extended permit tcp any interface outside eq https 
access-list inbound extended permit tcp any interface outside eq 4125 
access-list inbound extended permit tcp any interface outside eq 3389 
access-list inbound extended permit udp any host KCFDDC eq domain 
access-list inbound extended permit tcp any interface outside eq smtp 
access-list inbound extended permit tcp any interface outside eq pop3 
access-list inbound extended permit tcp any interface outside eq ftp 
access-list inbound extended permit tcp any interface outside eq imap4 
access-list outside_access_out extended permit ip interface outside any 
access-list management_nat0_outbound extended permit ip any 192.168.1.192 255.255.255.192 
access-list management_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 host Station21 
access-list management_nat0_outbound extended permit ip station21-network 255.255.255.0 192.168.1.0 255.255.255.0 
access-list vpn_splitTunnelAcl standard permit any 
access-list no-nat extended permit ip 192.168.1.0 255.255.255.0 station21-network 255.255.255.0 
access-list Inside_cryptomap extended permit ip 192.168.1.0 255.255.255.0 station21-network 255.255.255.0 
access-list Inside_cryptomap extended permit ip host KCFDDC host Station21 
pager lines 24
logging enable
logging buffer-size 8192
logging asdm informational
mtu outside 1500
mtu Inside 1500
mtu management 1500
ip local pool VPNIPs 192.168.1.220-192.168.1.230 mask 255.255.255.0
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-61551.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (Inside) 0 access-list no-nat
nat (Inside) 1 0.0.0.0 0.0.0.0
nat (management) 0 access-list management_nat0_outbound
static (Inside,outside) tcp interface www KCFDDC www netmask 255.255.255.255  dns 
static (Inside,outside) tcp interface https KCFDDC https netmask 255.255.255.255  dns 
static (Inside,outside) tcp interface smtp KCFDDC smtp netmask 255.255.255.255  dns 
static (Inside,outside) tcp interface 4125 KCFDDC 4125 netmask 255.255.255.255  dns 
static (Inside,outside) tcp interface pop3 KCFDDC pop3 netmask 255.255.255.255  dns 
static (Inside,outside) tcp interface ftp KCFDDC ftp netmask 255.255.255.255  dns 
static (Inside,outside) tcp interface imap4 KCFDDC imap4 netmask 255.255.255.255  dns 
static (Inside,outside) udp interface dnsix KCFDDC dnsix netmask 255.255.255.255 
static (Inside,outside) tcp interface 3389 KCFDDC 3389 netmask 255.255.255.255  dns 
static (Inside,outside) tcp interface 9100 PR22 9100 netmask 255.255.255.255  dns 
access-group inbound in interface outside
route outside 0.0.0.0 0.0.0.0 146.129.245.185 1
route Inside 172.29.12.0 255.255.255.0 192.168.1.2 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.2.0 255.255.255.0 management
http 192.168.1.0 255.255.255.0 Inside
http 192.168.0.0 255.255.255.0 Inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac 
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac 
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac 
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac 
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac 
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac 
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac 
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac 
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac 
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map outside_dyn_map 20 set pfs group1
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto dynamic-map outside_dyn_map 20 set security-association lifetime seconds 28800
crypto dynamic-map outside_dyn_map 20 set security-association lifetime kilobytes 4608000
crypto dynamic-map outside_dyn_map 40 set pfs group1
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-SHA
crypto dynamic-map outside_dyn_map 40 set security-association lifetime seconds 28800
crypto dynamic-map outside_dyn_map 40 set security-association lifetime kilobytes 4608000
crypto dynamic-map outside_dyn_map 60 set pfs group1
crypto dynamic-map outside_dyn_map 60 set transform-set ESP-3DES-SHA
crypto dynamic-map outside_dyn_map 60 set security-association lifetime seconds 28800
crypto dynamic-map outside_dyn_map 60 set security-association lifetime kilobytes 4608000
crypto map outside_map 10 match address Inside_cryptomap
crypto map outside_map 10 set peer Station21 
crypto map outside_map 10 set transform-set ESP-AES-256-SHA
crypto map outside_map 10 set security-association lifetime seconds 28800
crypto map outside_map 10 set security-association lifetime kilobytes 4608000
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
no crypto isakmp nat-traversal
telnet KCFDDC 255.255.255.255 Inside
telnet timeout 5
ssh timeout 5
console timeout 0
management-access management
threat-detection basic-threat
threat-detection statistics port
threat-detection statistics protocol
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
 enable outside
group-policy vpn_1 internal
group-policy vpn_1 attributes
 wins-server value 192.168.1.10
 dns-server value 192.168.1.10
 vpn-tunnel-protocol IPSec 
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value vpn_splitTunnelAcl
username XXXXXX password XXXXX
tunnel-group 74.94.67.57 type ipsec-l2l
tunnel-group 74.94.67.57 ipsec-attributes
 pre-shared-key *
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns migrated_dns_map_1
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns migrated_dns_map_1 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny  
  inspect sunrpc 
  inspect xdmcp 
  inspect sip  
  inspect netbios 
  inspect tftp 
!
service-policy global_policy global
smtp-server 192.168.1.10
prompt hostname context 
Cryptochecksum:2d474e6a943fc18930bdd833c567571e
: end
asdm image disk0:/asdm-61551.bin
asdm location KCFDDC 255.255.255.255 Inside
asdm location Station21 255.255.255.255 management
asdm location station21-network 255.255.255.0 management
asdm location Admin-Bldg-INET 255.255.255.255 outside
asdm location 146.129.245.187 255.255.255.255 Inside
no asdm history enable

Open in new window



Second ASA Config

: Saved
:
ASA Version 8.2(2) 
!
hostname remotevpn
enable password XXXXX
passwd XXXXXXXX
names
!
interface Ethernet0/0
 nameif outside
 security-level 0
 ip address 146.129.245.187 255.255.255.248 
!
interface Ethernet0/1
 nameif inside
 security-level 100
 ip address 192.168.1.2 255.255.255.0 
!
interface Ethernet0/2
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Ethernet0/3
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Management0/0
 shutdown
 no nameif
 no security-level
 no ip address
 management-only
!
boot system disk0:/asa822-k8.bin
ftp mode passive
clock timezone PST -8
clock summer-time PDT recurring
dns domain-lookup inside
dns server-group DefaultDNS
 name-server 192.168.1.10
access-list valley_nat0 extended permit ip 10.99.13.0 255.255.255.0 172.29.12.0 255.255.255.0 
access-list valley_cryptomap extended permit ip 10.99.13.0 255.255.255.0 172.29.12.0 255.255.255.0 
access-list inside_access_in extended deny ip any any 
pager lines 24
logging enable
logging asdm informational
mtu outside 1500
mtu inside 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-631.bin
no asdm history enable
arp timeout 14400
global (outside) 1 10.99.13.1-10.99.13.254 netmask 255.255.255.0
nat (inside) 1 192.168.1.0 255.255.255.0
route outside 0.0.0.0 0.0.0.0 146.129.245.185 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac 
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac 
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac 
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac 
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac 
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac 
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac 
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac 
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac 
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
crypto ipsec transform-set TEST esp-aes-256 esp-sha-hmac 
crypto ipsec transform-set VALLEY esp-aes-256 esp-sha-hmac 
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto map valley_map 1 match address valley_nat0
crypto map valley_map 1 set pfs group5
crypto map valley_map 1 set peer 146.129.253.3 
crypto map valley_map 1 set transform-set VALLEY
crypto map valley_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption aes-256
 hash sha
 group 5
 lifetime 86400
crypto isakmp ipsec-over-tcp port 10000 
telnet timeout 5
ssh timeout 5
console timeout 0
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
username XXXXX password XXXXXXX
tunnel-group 146.129.253.3 type ipsec-l2l
tunnel-group 146.129.253.3 ipsec-attributes
 pre-shared-key *****
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny  
  inspect sunrpc 
  inspect xdmcp 
  inspect sip  
  inspect netbios 
  inspect tftp 
  inspect ip-options 
!
service-policy global_policy global
prompt hostname context 
call-home
 profile CiscoTAC-1
  no active
  destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
  destination address email callhome@cisco.com
  destination transport-method http
  subscribe-to-alert-group diagnostic
  subscribe-to-alert-group environment
  subscribe-to-alert-group inventory periodic monthly
  subscribe-to-alert-group configuration periodic monthly
  subscribe-to-alert-group telemetry periodic daily
Cryptochecksum:f1da8b8c8ad0c48862a3e06f993b3a1e
: end
asdm image disk0:/asdm-631.bin
no asdm history enable

Open in new window

LVL 1
ssittigAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

FideliusCommented:
Hello,

Ping from the "remotevpn" ASA doesn't work because traffic is not coming through inside interface and there is no NAT for those pings, so you don't have interesting traffic for crypto ACL.

Problem for devices inside your network could be asymmetric routing. Traffic goes from clients to default gateway, which is "AdminASA5510" ASA and from there to "remotevpn" ASA. When it is returning it goes directly to client, not through "AdminASA5510" ASA.

I would suggest following topology: create DMZ on "AdminASA5510" ASA, and put inside interface of "remotevpn" ASA in it. Do NAT:
global (outside) 1 10.99.13.3-10.99.13.254 netmask 255.255.255.0
nat (inside) 1 192.168.1.0 255.255.255.0

on "AdminASA5510" ASA, and use addresses 10.99.13.1 and 2 for DMZ interface on "AdminASA5510" ASA and inside interface on  "remotevpn" ASA.


Regards!

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
pwindellCommented:
If a diagram will help,..I believe Fidelius is describing this below.  The diagram shows the LAN of both companies,..so the other agency would be the other LAN in the diagram.  However it is their responsiblity to correctly handle their routing on their side,...you only have to worry about your half.

If your LAN had more than one IP Segment with a regular LAN Router between them it would be done differently,...but this is the correct approach with a single-subnet LAN and it keeps the Routing Symentrical.

 VPN Sample 3
FideliusCommented:
Thanks pwindell,

That is exactly what I meant. Thanks for the picture.
SS, keep us posted regarding progress.

Regards!
Your Guide to Achieving IT Business Success

The IT Service Excellence Tool Kit has best practices to keep your clients happy and business booming. Inside, you’ll find everything you need to increase client satisfaction and retention, become more competitive, and increase your overall success.

pwindellCommented:
You're welcome. This is one of my "favorite issues" so I have a pile of diagrams for that stuff.  You're welcomed to download the JPG and reuse it if you like.
ssittigAuthor Commented:
Thanks for that great diagram. It turns out the agency who gave us the ASA is going to help us implement it. I'll post what they end up using for a solution when it gets set up.
ssittigAuthor Commented:
I ended up putting the remotevpn on in the DMZ for our network, and that seemed to allow the traffic to pass correctly. Thanks for your help!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Cisco

From novice to tech pro — start learning today.