Link to home
Create AccountLog in
Avatar of John Shannon
John ShannonFlag for United States of America

asked on

HP Array 1000 SAN issue

I'm having trouble with a SAN partition or LU, This SAN has several LU's assigned and all but one are working great. The one which is bad is giving errors indicating the format is corrupt and instructs me to reformat. Ive posted before about this and asked for help formatting the LU. I tried to format after performing a full backup of this LU, the backup failed to format. Is there something I should do with the controller? I'm at a loss.
Avatar of gheist
gheist
Flag of Belgium image

What Logical Units you are talking about?
Is there a peoblem with array control device or some storage device?
Avatar of John Shannon

ASKER

Logical Drives, This SAN is broken into smaller "logical drives" one of these drives seems corrupt. Windows is constantly advising I run chkdsk. I've run it in the past and all the security information disappears including the shares. Last night I ran Chkdsk /x/f and it seems to have run without dumping the security.

In an earlier post, I tried to format the Logical Drive, but couldn't.

Any help would be appreciated.
ASKER CERTIFIED SOLUTION
Avatar of gheist
gheist
Flag of Belgium image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
No this drive is shared via other servers. Is that what you mean? This network consists of 4 servers each have a fiber board which connect to the san.
If you say that multiple hosts access NTFS file system concurrently - this is the problem, it leads to filesystem damage.
Eliminate the concurrent access situation and filesystem will be fine.
Avatar of David
gheist has it ... looks like more than one computer is attached to same LUN. This won't work unless you buy some extra software (which is very expensive).  
I think I throw everyone off. Each server/fiber board has its own LUN. They are shared via Windows Shares.
Avatar of Member_2_231077
Member_2_231077

I'd be tempted to delete the logical disk and create a new one, then re-present it to the server using ACU.
I'm including a screen print of the format results. I cant login to the SAN. I don't have any info on it. I inhereted this SAN from a technician which was fired. The last thing that was done was replacement of the Fiber Card. This board was part of a kit that sold with the HP Array 1000. I will try to get the information on the Fiber board.
mrm-format-prob.JPG
Servers cannot connect to the same LUN, unless you use Microsoft Clustering, or Secure Path, or LUN masking or Zone-ing to prevent, a servers accessing the same LUN.

What's happening, is a servers is trying to claim the disk, and re-write the disk signature, this doesn't then agree with the server which currently has access, and believes the disk has become corrupted.

You need to selectively present each LUN to each server ONLY.

Is this an MSA 1000?
SANSTECH - lets' make sure we're all on same page, as gheist and I and others have said, you can't share.  But let me be specific.

You are not allowed to have the SAME LUN accessed via the fibre channel on more than one host at a time.  And even that has some risk due to permissions.   Use one host to mount "D", then tell that host to make it a  NTFS network-share, so that other people access the D drive via TCP/IP over the NIC.

You are free to slice the MSA into 3 LUNs, i.e, 3 different "D", drives, and 2 more computers mount one of those new slices each, and let each of those computers present their own private D drive as something else.

Anything beyond this is going to require some extra software, and it is very expensive software, BTW.
Can't log into the SAN doesn't make sense, there's no security, you just use the same Array Configuration Utility that you use for local disks.
Never able to resolve this issue. Customer purchased a new controller which needed to be reconfigured and this seemed to fix the issue.
You described a common mistake about SAN - concurrently accessing same file system without proper locking like fine clusters (or vmware) does.
There is no problem with controllers or hardware at all...
SANSTECH - If it seems to have fixed the issue, I assure you it hasn't. iT is probable that it is destroying data unless everything is mounted read-only, or you've been lucky due to flushing frequency.  All the experts keep telling you this.  Give it up.  It may "seem" to work, but it WILL slowly destroy data. It has to.
Particular "SAN" is extermely slow when accessed concurrently with proper arbitration. (e.g VMWare disk read is in range of 1s on actually shared volume and everything else appears blocked for that second). Glad your customer escaped the doom.