Link to home
Create AccountLog in
Avatar of RyanReese
RyanReeseFlag for United States of America

asked on

Localhost/Machine Name :7001

I had to reinstall Weblogic last week and since I have done this can only access the Admin Server Console using localhost:7001.  Before I could access the Admin Console using
http://laptopname:7001/console  but when I do this know it will not answer.  My application needs to be accessed by it's machine name not using localhost.  How do I change this?.  

I am running Weblogic 10.3 on Windows 7 64bit pro.
Avatar of rmody
rmody
Flag of India image

Hi,

You can achieve your requirement using the following steps

=======
Option-1
=======
1. Start you weblogic server.
2. Open the console using http://localhost:7001/console
3. Go to the path: Servers -> AdminServer -> Configuration [tab] -> General [sub-tab]
4. In "Listen Address:" give your machine name like

Listen Address: laptopname

5. Save the changes and restart the server.

=======
Option-2
=======
1. You can also change it directly from the "config.xml"  Path: BEA_HOME/user_projects/domains/Domain_7001/config
2. Search for "<name>AdminServer</name>" in "config.xml"
3. In "listen-address" element (which might be empty at this time) give your machine name like

<server>
    <name>AdminServer</name>
    <listen-port>7001</listen-port>
   <listen-address>laptopname</listen-address>
  </server>

4. Save the changes and start the server.

Now you can access the console using (http://laptopname:7001/console)

NOTE: "laptopname" should be given in your etc/hosts file OR your IP address should be mapped with the  "laptopname" which your machine name.

Hope this would solve your issue.

Regards,
Ravish Mody
Avatar of reddykiran449
reddykiran449

go to C:\Windows\System32\drivers\etc  edit hosts file
add this line at end of the file
127.0.0.1  yourlaptopname
and try to access the console.
Avatar of RyanReese

ASKER

So I updated the listen-address like you said and know my server will not start.  The start admin server window comes up then shut's down.  

Thank you for you help
Hi,

So undo the changes you made in the config.xml file and then try the Option -1, it seems that the config.xml file has not been updated properly hence it is not starting up.

Note: It is always recommended to make sure that you keep a backup file of the config.xml file always before changing anything in it.

Let me know if that helps.

Regards,
Ravish Mody
Ok, so I have changed the machine name back.  The server starts again and can browse to http://localhost:7001 and works find.  But if I change the listening address it fails to start with the following error messages.

xecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1294172615647> <BEA-090082> <Security initializing using security realm myrealm.>
####<Jan 4, 2011 3:23:37 PM EST> <Notice> <WebLogicServer> <terlap138> <AdminServer> <main> <<WLS Kernel>> <> <> <1294172617426> <BEA-000365> <Server state changed to STANDBY>
####<Jan 4, 2011 3:23:37 PM EST> <Notice> <WebLogicServer> <terlap138> <AdminServer> <main> <<WLS Kernel>> <> <> <1294172617426> <BEA-000365> <Server state changed to STARTING>
####<Jan 4, 2011 3:23:37 PM EST> <Notice> <Log Management> <terlap138> <AdminServer> <[STANDBY] ExecuteThread: '1' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1294172617519> <BEA-170027> <The Server has established connection with the Domain level Diagnostic Service successfully.>
####<Jan 4, 2011 3:23:37 PM EST> <Notice> <WebLogicServer> <terlap138> <AdminServer> <main> <<WLS Kernel>> <> <> <1294172617566> <BEA-000365> <Server state changed to ADMIN>
####<Jan 4, 2011 3:23:37 PM EST> <Notice> <WebLogicServer> <terlap138> <AdminServer> <main> <<WLS Kernel>> <> <> <1294172617582> <BEA-000365> <Server state changed to RESUMING>
####<Jan 4, 2011 3:23:37 PM EST> <Emergency> <Security> <terlap138> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1294172617597> <BEA-090087> <Server failed to bind to the configured Admin port. The port may already be used by another process.>
####<Jan 4, 2011 3:23:37 PM EST> <Error> <Server> <terlap138> <AdminServer> <DynamicListenThread[Default]> <<WLS Kernel>> <> <> <1294172617597> <BEA-002606> <Unable to create a server socket for listening on channel "Default". The address 10.10.10.10 might be incorrect or another process is using port 7001: java.net.BindException: Cannot assign requested address: JVM_Bind.>
####<Jan 4, 2011 3:23:37 PM EST> <Critical> <WebLogicServer> <terlap138> <AdminServer> <main> <<WLS Kernel>> <> <> <1294172617597> <BEA-000362> <Server failed. Reason: Server failed to bind to any usable port. See preceeding log message for details.>
####<Jan 4, 2011 3:23:37 PM EST> <Notice> <WebLogicServer> <terlap138> <AdminServer> <main> <<WLS Kernel>> <> <> <1294172617597> <BEA-000365> <Server state changed to FAILED>
####<Jan 4, 2011 3:23:37 PM EST> <Error> <WebLogicServer> <terlap138> <AdminServer> <main> <<WLS Kernel>> <> <> <1294172617597> <BEA-000383> <A critical service failed. The server will shut itself down>
####<Jan 4, 2011 3:23:37 PM EST> <Notice> <WebLogicServer> <terlap138> <AdminServer> <main> <<WLS Kernel>> <> <> <1294172617597> <BEA-000365> <Server state changed to FORCE_SHUTTING_DOWN>
ASKER CERTIFIED SOLUTION
Avatar of rmody
rmody
Flag of India image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Thank you so much for your help.  This was driving me crazy.