Cannot Install Apps! Windows Installer Service Not Working

I've done everything I can think of and I cannot get windows installer service started on one computer.  Here's  what I've tried:

    * Starting it in safe mode
    * currently running v. 4.. cannot upgrade to v.4.5 as that requires windows installer service
    * Unregistering then re-registering it
    * Doing a "Selective Startup" and disabling all startup services except Microsoft services.

If I try to start the Windows Installer Service I get  "Error 1053" the service didn't respond in a timely manner..

Can anybody help with this please?? I need to get anti-virus program on this computer..
LVL 1
jab56Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

sureshpstCommented:
My suggestion:-

If you get the error message timely manner means, The antivirus sever and client has different time zone. Please try to fix the time. or try to push GRC.DAT file from the server.

Once is done. try to restart the system and try for windows installer service.

Regards,
Suresh.
EnriquePhoenixCommented:
Double click on the service, click on the Log On tab, select "Local System Account" and
"Allow service to interact with desktop".
jab56Author Commented:
Neither of these suggestions worked.. I selected Allow to Interact with Desktop then tried to start the service - Same results - Error 1053

There is no antivirus program on this computer. That's the original problem that led me to the discovery that I Cannot Install anything...
Build an E-Commerce Site with Angular 5

Learn how to build an E-Commerce site with Angular 5, a JavaScript framework used by developers to build web, desktop, and mobile applications.

jab56Author Commented:

"Try this:

http://wiki.lunarsoft.net/wiki/Dial-a-fix#Mirrors.2Fdownload_locations.2C_and_articles"

Thanks for the offer, but I don't think I'm going to use unknown software on this computer
Qlemo"Batchelor", Developer and EE Topic AdvisorCommented:
Anyway, doesn't look like that tool would do more than you have already done - reregister the Installer -, so it is useless.

Did you perform    sfc /scannow    already? (too make sure the installer files are "genuine")
No messages in Event Log?
What happens if just start msiexec (no parameters)? (It should happen nothing)

Imal UpalakshithaIT System AdministratorCommented:
jab56Author Commented:
I ran sfc /scannow but the generated file is huge and I'm not sure what it's reporting.. I'm going to try to attach it to this message..........

Can you please look through this and tell me what it means please??
thanks,
DD CBS.csv
Imal UpalakshithaIT System AdministratorCommented:
Repair windows from cd &  install latest service pack will resolve this
Qlemo"Batchelor", Developer and EE Topic AdvisorCommented:
SFC has not repaired anything related to the install service. There were some repairs applied, and maybe Installer works again, but I don't think so.
jab56Author Commented:
Nothing has worked... The unfortunate thing is I don't have a Vista CD........
Qlemo"Batchelor", Developer and EE Topic AdvisorCommented:
I have requested attention; maybe someone else can provide more help.
jvuzCommented:
Can you logon with another user that has admin rights? If yes, then try to install it. See what happens.
Lukasz ChmielewskiCommented:
http://support.microsoft.com/kb/315346
Scroll down the page.
It says that in vista when you have service set to turned off this error may appear, try ms suggestion.
Davis McCarnOwnerCommented:
You already have a big problem in that your SFC log reports l:46{23}]"\??\C:\Windows\System32"\[l:20{10}]"tcpmon.ini"; source file in store is also corrupted
This may mean you are already infected.  Try TDSSKiller ( http://support.kaspersky.com/viruses/solutions?qid=208280684 ) to check.
Who made the computer and what model is it?
Rick HobbsRETIREDCommented:
Al JeeCommented:
So this is Vista??

I see tags for 3 different o/s's and this question seems to be in the XP Zone.

Anyway, it looks like you have a seriously corrupted o/s.
I assume that, whatever computer this is, there is not a partition on the hard drive for reinstalling everything to the OEM state?

Without a way to reinstall/repair the o/s you have no solution.
Trying to repair a seriously infected machine [ as this one may be ] is fruitless if you have no way to replace the corrupted system files.

If you are able to get an installation CD you could try doing a re-install [ not a repair ] of the o/s and then work on getting AV apps installed to try to clean the infections before they re-corrupt the system.
That is going to take a lot of time assuming that it works at all.

You have to have the basic tools.

Time-wise, your best bet is wipe the hard drive and reinstall everything.
Imal UpalakshithaIT System AdministratorCommented:
press F8 when booting and select startup repair,do a system restore at there
jab56Author Commented:
I'll try an online virus scanner, as again, I can't install anything...

As soon as I get ahold of the user, I'll also try to login as a new administrator and see if it will run under that account...
Al JeeCommented:
Ask the user for the installation CD/DVD


So this is Vista and not XP????
jab56Author Commented:

I can't get any online scanners to work.. often their sites are blocked in the first place (www.trend.com) . Logging in as another Admin user and trying to start the  service gives the same result..

I'm trying an offline scan with a symantec product..
Davis McCarnOwnerCommented:
Reread my fist post as you don't need to install TDSSKiller and; again, who made the computer and what model is it?
jab56Author Commented:
I'll try that website.. once the scan is  done... so it has found conficker Upaddown.autorun and updown.b (yea, I've mispelled these, but you know what  I mean..)

The machine is a Dell Vostro..
Davis McCarnOwnerCommented:
Some Vostro's have a recovery partition, some don't; but then were shipped with CD/DVD's.  What's the service tag number?
Rick HobbsRETIREDCommented:
jab56Author Commented:
We have Symantec Small Business.. I'm going to turn this over to them.. It is for sure a virus that is causing this...

Thanks everyone for the help..

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Al JeeCommented:
Just out of curiosity, did you try any of the AV solutions that I & others recommended?
jab56Author Commented:

All AV websites were blocked that I tried and any kind of local install would fail due to the installer service being inoperable..
jvuzCommented:
You could try one of these to boot from the cd. That way you could launch a virus scan before Windows is loaded.

http://www.techmixer.com/free-bootable-antivirus-rescue-cds-download-list/
We usually use http://support.kaspersky.com/viruses/rescuedisk

Jvuz
jab56Author Commented:
I'm escalating the issue..
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Installation

From novice to tech pro — start learning today.