Cannot Install Windows Server 2008 to 80 GB SSD - Windows is unable to find a system volume that meets its criteria for installation

I'm stumped and need help.  I cannot get Windows Server 2008 with SP2 (64-bit) to install on an Intel X25-M 80 GB SSD.  Attempts to select the disk for install report that "Windows is unable to find a system volume that meets its criteria for installation"  I have already referenced http://support.microsoft.com/kb/927520 and confirmed the following:

Method 1: Verify that the partition is compatible with Windows
>>  The drive is unpartitioned.

Method 2: Update the drivers for the hard disk controller
Method 3: Provide the correct drivers for the hard disk controller
>>  Using the on-board SATA controller in IDE mode.  No additional drivers available.

Method 4: Examine the Setupact.log file to verify that the partition is active
>>  Wasn't able to find this file where the KB article says it is.  I did find a file with the same name in another location but there was no reference to the partition in the log file.

Method 5: Check for firmware updates and for system BIOS updates
>>  Running 2HD SSD firmware; BIOS is one version old however the release notes state that the new BIOS only updates support for 4 processors, none of which are installed/in use on this system.

Method 6: Verify that the system BIOS correctly detects the hard disk
>>  It does

Method 7: Use the Chkdsk.exe utility to check for problems
>>  Haven't ran this...  I assume I'd have to partition and format the drive first before running chkdsk...  doesn't feel like the problem to me though.

Method 8: Use the Diskpart.exe utility to clean the disk, and then run Windows Setup again
>>  I have cleaned the disk using this method, I even used diskpart to create a new NTFS formatted partition and marked it as active before attempting to select it with the installer to no effect.

I am at a total loss as to what to do next.  Suggestions?

Hardware Config
==============
Intel X-25M 80 GB SSD

Intel Server Board S5000PSL
>>  On board SATA connected to DVD-R/W and SSD (IDE Mode)

Intel® RAID Controller RS2BL080
>>  For RAID Storage (6 SAS drives); doesn't matter at this stage
LVL 4
swallsvcsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

KenMcFCommented:
Is this a clean install of 2008 or an upgrade?

it sounds like you are doing a clean install, Have you tried method 3? It sounds like you will need to install the correct drivers for the controller during install.

Method 3: Provide the correct drivers for the hard disk controller
If you are trying to perform a clean installation of Windows, you must provide the correct drivers for the hard disk controller. When you are prompted to select the disk on which to install Windows, you must also click to select the Load Driver option. Windows Setup will guide you through the rest of the process.


swallsvcsAuthor Commented:
Thanks for your reply Ken.  Yes, this is a clean install.  Unfortunately there are no drives available for the hard disk controller per se (or at least I have been unable to find any).

Method 3: Provide the correct drivers for the hard disk controller
>>  Using the on-board SATA controller in IDE mode.  No additional drivers available.

The motherbaord is an Intel Server Board S5000PSL if that helps.
IT-Monkey-DaveCommented:
Have you tried using AHCI mode (or AHCI/RAID) rather than IDE Mode in the system BIOS settings?  I would get that drive out of IDE mode if possible, it's deprecated and probably somewhat cripples drive functionality.

Bootstrap 4: Exploring New Features

Learn how to use and navigate the new features included in Bootstrap 4, the most popular HTML, CSS, and JavaScript framework for developing responsive, mobile-first websites.

swallsvcsAuthor Commented:
Hi Dave,

That's actually what I tried first.  When in AHCI mode, booting to the Server 2008 CD hangs on the "Microsoft Corporation" screen where the green bar just continually scrolls across the bottom of the screen.  After waiting about 20 minutes to boot I gave up and googled the problem which suggested switching to IDE mode.  Once switched the installer would then launch (resolving that problem) but then presented the problem I am having now when I actually tried to perform the install.
IT-Monkey-DaveCommented:
Hmm.  I'm sure you want to be in AHCI mode if at all possible.  Is the motherboard BIOS updated to the most current version?  Do you have a conventional SATA hard drive you can try in place of the SSD just to see if Windows at least gets started with the install when a drive is in AHCI mode?  If a hard drive works but the SSD doesn't I'd suspect a compatibility issue with the SSD and that motherboard.

Intel manual for that mobo (if you don't already have it): ftp://download.intel.com/support/motherboards/server/sb/d38960006_s5000datasheet.pdf

swallsvcsAuthor Commented:
Troubleshooting and Repair Log (TSR):
Disconnected cables from SAS enclosure to RAID card (RAID card still installed)
Attempted installation on drive as unpartitioned space; creating a partition using the GUI and using the CLI.  No affect.
swallsvcsAuthor Commented:
Hi Dave,

I don't have a SATA drive on me today; but I'll be sure to bring one with me tomorrow to give that a try.  As for the system BIOS it is one version old however the release notes state that the new BIOS only updates support for 4 processors, none of which are installed/in use on this system.  The SSD firmware is current.
Olaf De CeusterCommented:
Having the same issue on a S5000VSA with normal Sata drives: Tried:  Different Drives, Drivers, AHCI, Diskpart, latest Bios.
Server 2003 installs without issues.
Interested to hear what other experts have to add.
Olaf
IT-Monkey-DaveCommented:
Sorry, you mentioned the bios before. I would update it anyway just on general principles. Maybe it contains undocumented changes.
swallsvcsAuthor Commented:
Hi Dave,

I agree about the BIOS update.  Unfortunately when booting to the Intel Deployment Assistant disc to do a BIOS update...
1.  If allowing it to download the latest drivers it downloads an old version.
2.  If attempting to map a network location no matter what I try I get an access denied (tried connecting to a workstation share, a server 2003 share, all sorts of accounts (username with and without domain both in slash form and @ form, changing slash direction on the share names, etc.)
3.  If updating from USB it claims I don't have one plugged in regardless of if I plug it in before its on, afterwards, etc.

I am planning to try again tomorrow when I bring a handful of different USB memory sticks with me  in case for whatever reason it just doesn't like this one.
swallsvcsAuthor Commented:
TSR Log
Put on-board controller back into AHCI mode.
Attempted to install windows again with cables from SAS enclosure to RAID card disconnected.
>>  Waited 8 minutes at "green scrolling bar"; HDD light stayed on solid entire time.  Powered off system.
Removed RAID card entirely (leaving AHCI on for on-board controller) and attempted to boot once again to installation DVD.
>>  Waited 8 minutes at "green scrolling bar"; HDD light stayed on solid entire time.  Powered off system.
Set system back to IDE mode for further tests with no RAID card installed.
IT-Monkey-DaveCommented:
Sorry, had to split this up.

I suspect you're using outdated Intel utilities (correct me if I'm wrong). I'd go straight to the latest of everything.

I'd remove the RAID board for now and leave it out until you get the SSD going (if it can be made to work).

Another option might be to connect only the SSD to the RAID board, by itself, and see if you get any further. This is to find out if the problem is the SSD & mobo compatibility, or if the SSD is possibly at fault. Process of elimination.
DavidPresidentCommented:
Placing a SSD behind a RAID controller is just asking for trouble.  Not only are there incompatibility issues with vast majority of them, but also, you'll almost always take a performance hit.  (a huge hit)

So take the RAID out of the equation.  Most likely they simply won't work together
IT-Monkey-DaveCommented:
diethe, my point was to just try it and see if it gets off the ground at all.  The SSD is inappropriate for use with a RAID controller full-time and I didn't suggest that as a solution, only as a troubleshooting step, process of elimination.  As you say it may not work at all but if the install at least starts, it tells us the SSD itself isn't dead.
swallsvcsAuthor Commented:
Good morning everyone.  Thanks for the responses last night.  Let me get you up to speed as to what is happening this morning.

1.  With my new memory stick I was able to update the BIOS from 99 to 101.
>>  Still unable to boot the system in AHCI mode; nor select the drive for installation when in IDE mode or using the embedded RAID with the disk setup as a single drive RAID 0 array.
1a.  The Intel SSD already has firmware 02HD, which is the latest firmware for this drive and did not need to be updated.

2.  In a chat with Intel last night they indicated that the system might not boot in AHCI mode when the network cards are not both plugged into a switch and/or disabled.  I tested by plugging all ethernet jacks (2 onboard, 1 RMM) to a switch as well as disabling in the BIOS however system still hung on install.

3.  Intel also suggested trying the install with the onboard SATA ports in RAID.  As mentioned in 1 I tried that to avail.

4.  I didn't have a copy of Windows 7 on me this morning so I downloaded Windows Hyper-V Server (as it is based on Server 2008 R2 which is in turn based on Win7).  I was able to boot the system in AHCI mode and install the OS to the SSD without incident confirming the SSD is working properly and is able to have an OS installed to it.

I think my next step is going to be to re-try the Hyper-V installation in IDE mode to see if I get the same error or if it completes successfully.  If it causes the same error I feel that the solution might be found in getting Windows Server 2008 to boot with the controller in AHCI mode.  I do have the AHCI drivers for Server 2008... but is there a way to force the installer to use them pre-boot ... prior to the hang?  It's acting as if the installer looses access to the DVD drive half way through boot due to not having the correct AHCI drivers to read from the disc once the boot is passed off to the Win PE environment.  Unfortunately as this is prior to the "Load Drivers" screen I'm not sure what to do about that...  Perhaps attempting to create a Server 2008 bootable USB is the answer?

Any further advice, and reflections on my "shots in the dark" are greatly appreciated.
swallsvcsAuthor Commented:
Windows Hyper-V Server 2008 R2 also installs in IDE mode.  Attempting to create a bootable Windows Server 2008 USB stick now...
swallsvcsAuthor Commented:
Bootable USB stick worked; however still after a very long hang at the "Microsoft Corporation" green bar screen.  Once in the installer I was able to load the AHCI drivers from my USB stick and perform the install to the SSD.

For anyone who finds this post later the key solution to this problem is to wait.  Apparently Vista-based OSes (as Windows Server 2008 is) has an issue with AHCI compatibility with the installer CD.  Just wait it out.  When you think you've waited longer... wait some more.  Give yourself a full 30 minutes of waiting before giving up (DVD or USB).  

Once the installer fully loads ensure you update the AHCI drivers using Load Drivers even if the drive is visible and then install the OS.  Once installed boot times will be normal - its just the installation CD that has so much trouble with the AHCI controller.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
IT-Monkey-DaveCommented:
Sounds like you worked it out.  :)
swallsvcsAuthor Commented:
The suggestion to attempt to install Windows 7 that came from another colleague outside of this thread led me on the path to the correct solution.  That said, the people on this thread that helped out still deserve recognition for their assistance in the troubleshooting process.  Points awarded accordingly.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.